Product Documentation

System Requirements

Sep 08, 2015

To run XenMobile 10.1, you need the following minimum system requirements:

  • One of the following:
    • XenServer (supported versions: 6.5.x, 6.2.x, 6.1.x, or 6.0.x); for details, refer to XenServer
    • VMWare (supported versions: ESXi 4.1, ESXi 5.1, or ESXi 5.5); for details, refer to VMware
    • Hyper-V (supported versions: Windows Server 2008 R2, Windows Server 2012, or Windows Server 2012 R2); for details, refer to Hyper-V
  • Dual core processor
  • Two virtual CPUs
  • 4 GB of RAM
  • 50 GB disk space

The recommended configuration for 10,000 devices is the following:

  • Quad core processor
  • 16 GB of RAM

NetScaler Gateway System Requirements

To run NetScaler Gateway with XenMobile 10.1, you need the following minimum system requirements:
  • One of the following:
    • XenServer (supported versions: 6.2.x, 6.1.x, or 6.0.x)
    • VMWare (supported versions: ESXi 4.1, ESXi 5.1, or ESXi 5.5)
    • Hyper-V (supported versions: Windows Server 2008 R2, Windows Server 2012, or Windows Server 2012 R2)
  • Two virtual CPUs
  • 2 GB of RAM
  • 20 GB disk space

You also need to be able to communicate with Active Directory, which requires a service account. You only need query and read access.

XenMobile 10.1 Database Requirements

The XenMobile repository requires a Microsoft SQL Server database running on one of the following supported versions (for more information about Microsoft SQL Server databases, see Microsoft SQL Server):

  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
  • Microsoft SQL Server 2008

XenMobile 10.1 supports SQL Server AlwaysOn Availability Groups.

Citrix recommends using Microsoft SQL remotely. PostgreSQL is included with XenMobile and should be used locally or remotely only in test environments.
Note: Make sure the service account of the SQL Server to be used on XenMobile has the DBcreator role permission. For more information about SQL Server service accounts, see the following pages on the Microsoft Developer Network site (these links point to information for SQL Server 2014. If you are using a different version, select your server version from the Other Versions list):

XenMobile 10.1 Mail Server Requirements

XenMobile 10.1 supports the following mail servers:

  • Exchange 2013
  • Exchange 2010