Product Documentation

Endpoint Analysis Requirements

When Citrix Gateway installs the Endpoint Analysis Plug-in on the user device, the plug- in scans the user device for the endpoint security requirements that you configured on Citrix Gateway. The requirements include information, such as the operating system, antivirus, or web browser versions.

When Windows users connect to Citrix Gateway using the browser for first time, the portal requests the installation of the Endpoint Analysis Plug-in. On subsequent log on attempts, the plug-in checks the upgrade control configuration to decide if the client endpoint analysis plug-in upgrade is necessary. If it is necessary, the user will receive a prompt to download and install the newer Endpoint Analysis Plug-in. The Endpoint Analysis Plug-in for Windows is installed as a Windows 32-bit application. No special privileges are required to install or use it.

For Mac OS X, the user is required to install the Endpoint Analysis Plug-in. The plug- in for Mac OS X is installed as a 32-bit application. No special privileges are necessary to install it. On subsequent log on attempts, if the plug-in versions do not match, the user will be prompted to download and install the plug-in.

To use the Endpoint Analysis Plug-in, the following software is required on the user device:

Operating System Supported Browsers
Mac OS X (10.9 and later) Safari 7.1 or later; Google Chrome Release 30 or later; Mozilla Firefox Release 30 or later
Windows 10 Internet Explorer 11; Google Chrome Release 30 or later; Mozilla Firefox Release 24 or later; Microsoft Edge is not supported
Windows 8.1 Internet Explorer 11; Google Chrome Release 30 or later; Mozilla Firefox Release 24 or later
Windows 8 Internet Explorer 9 and 10; Google Chrome Release 30 or later; Mozilla Firefox Release 24 or later
Windows 7 Internet Explorer 8, 9, 10, and 11; Google Chrome Release 30 or later; Mozilla Firefox Release 24 or later
Windows Vista Internet Explorer 7, 8 and 9; Mozilla Firefox Release 9 and 10
Linux; Ubuntu 12.04 LTS, 14.04 LTS and 16.04 LTS  
Note: 32-bit and 64-bit OS are supported. Mozilla Firefox Release 44 and above; Google Chrome 50 and above

Note 1: All editions of the operating system variants mentioned above are supported.

Note 2: For Windows editions, all service packs and critical updates must be installed.

Note 3: For Internet Explorer versions, cookies must be enabled. The minimum required version is 7.0.

Note 4: For Mozilla Firefox versions, Endpoint Analysis must be Plug-in enabled, the minimum required version is 3.0.

Important: In case of Pre-Authentication Endpoint Analysis, if a user does not install the Endpoint Analysis Plug-in on the user device or chooses to skip the scan, the user cannot log on with the Citrix Gateway Plug-in. In case of Post-Authentication Endpoint Analysis, the user can access resources for which a scan is not required by using either clientless access or by using Citrix Receiver.

Endpoint Analysis Requirements

In this article