Compatibilidad con sistemas operativos invitados

Al instalar máquinas virtuales y asignar recursos como memoria y espacio en disco, siga las directrices del sistema operativo y de cualquier aplicación relevante.

Sistema operativo RAM mínima RAM máxima Espacio mínimo en disco
Windows 8.1, Windows 10 (32 bits) 1 GB 4 GB 24 GB (40 GB o más recomendados)
Windows 8.1 (64 bits) 2 GB 512 GB 24 GB (40 GB o más recomendados)
Windows 10 (64 bits) [La última versión probada es 1909] 2 GB 1,5 TB 32 GB (40 GB o más recomendados)
Windows Server 2012, Windows Server 2012 R2 (64 bits) 1 GB 1,5 TB 32 GB (40 GB o más recomendados)
Windows Server 2016, Windows Server Core 2016 (64 bits) 1 GB 1,5 TB 32 GB (40 GB o más recomendados)
Windows Server 2019, Windows Server Core 2019 (64 bits) 1 GB 1,5 TB 32 GB (40 GB o más recomendados)
CentOS 7.x (64 bits) [La última versión probada es 7,7] 2 GB 1,5 TB 10 GB
CentOS 8.x (64 bits) [La última versión probada es 8.0] 2 GB 1,5 TB 10 GB
Red Hat Enterprise Linux 7.x (64 bits) [La última versión probada es 7,6] 2 GB 1,5 TB 10 GB
Red Hat Enterprise Linux 8.x (64 bits) [La última versión probada es 8.1] 2 GB 1,5 TB 10 GB
SUSE Linux Enterprise Server 12 SP3, 12 SP4, 12 SP5 (64 bits) 1 GB 1,5 TB 8 GB
SUSE Linux Enterprise Server 15, 15 SP1 (64 bits) 1 GB 1,5 TB 8 GB
SUSE Linux Enterprise Desktop 12 SP3, 12 SP4 (64 bits) 1 GB 1,5 TB 8 GB
SUSE Linux Enterprise Desktop 15, 15 SP1 (64 bits) 1 GB 1,5 TB 8 GB
Oracle Linux 7.x (64 bits) [La última versión probada es 7,6] 2 GB 1,5 TB 10 GB
Oracle Linux 8.x (64 bits) [La última versión probada es 8.0] 2 GB 1,5 TB 10 GB
Scientific Linux 7.x (64 bits) 2 GB 1,5 TB 10 GB
Debian Jessie 8 (32 bits) 128 MB 64 GB 8 GB
Debian Jessie 8 (64 bits) 128 MB 1,5 TB 8 GB
Debian Stretch 9 (32 bits) 256 MB 64 GB 10 GB
Debian Stretch 9 (64 bits) 256 MB 1,5 TB 10 GB
Debian Buster 10 (64 bits) 1 GB 1,5 TB 10 GB
Ubuntu 16.04 (32-bits) 512 MB 64 GB 10 GB
Ubuntu 16.04 (64 bits) 512 MB 1,5 TB 10 GB
Ubuntu 18.04 (64 bits) 512 MB 1,5 TB 10 GB
Ubuntu 20.04 (64 bits) 512 MB 1,5 TB 10 GB
CoreOS estable (64 bits) [La última versión probada es 2191.5.0] 2 GB 512 GB 8 GB
NeoKYlin Linux Advanced Server 7.2 (64 bits) 1 GB 1,5 TB 10 GB
  • Todos los sistemas operativos compatibles se ejecutan en modo HVM.

    La compatibilidad con máquinas virtuales paravirtualizadas (PV) se elimina en Citrix Hypervisor 8.1. Puede importar máquinas virtuales existentes que utilicen estos sistemas operativos en la instalación de Citrix Hypervisor 8.1 o posterior. Sin embargo, Citrix no proporciona soporte para máquinas virtuales con estos sistemas operativos. Actualice sus máquinas virtuales a una versión más reciente y compatible del sistema operativo lo antes posible.

  • Las versiones individuales de los sistemas operativos también pueden imponer sus propios límites máximos a la cantidad de memoria soportada (por ejemplo, por razones de licencia).

  • Al configurar la memoria de invitado, no exceda la cantidad máxima de memoria física que el sistema operativo puede abordar. Establecer un máximo de memoria que sea mayor que el límite admitido por el sistema operativo podría provocar problemas de estabilidad dentro de su huésped.

  • Para crear una máquina virtual de una versión secundaria más reciente de RHEL que se muestra en la tabla anterior, utilice el método siguiente:
    • Instale la máquina virtual desde los medios compatibles más recientes para la versión principal
    • yum update`` Utilícelo para actualizar la VM a la versión secundaria más reciente

    Este enfoque también se aplica a sistemas operativos basados en RHEL como CentOS y Oracle Linux.

  • Algunos sistemas operativos Windows de 32 bits pueden admitir más de 4 GB de RAM mediante el modo de extensión de dirección física (PAE). Para volver a configurar una máquina virtual con más de 4 GB de RAM, utilice la CLI xe, no XenCenter, ya que la CLI no impone límites superiores paramemory-static-max.

Soporte a largo plazo para huéspedes

Citrix Hypervisor incluye una directiva de soporte para invitados a largo plazo (LTS) para máquinas virtuales Linux. La directiva LTS le permite consumir actualizaciones de versiones secundarias mediante uno de los métodos siguientes:

  • Instalación desde nuevos medios invitados
  • Actualización desde un huésped compatible existente

Sistemas operativos fuera de soporte

La lista de sistemas operativos invitados admitidos puede contener sistemas operativos compatibles con sus proveedores en el momento en que se lanzó esta versión de Citrix Hypervisor, pero ahora ya no son compatibles con sus proveedores.

Citrix ya no ofrece soporte para estos sistemas operativos (incluso si siguen listados en la tabla de invitados admitidos o si sus plantillas permanecen disponibles en los hosts de Citrix Hypervisor). Al intentar solucionar y resolver un problema notificado, Citrix evalúa si el problema se relaciona directamente con un sistema operativo fuera de soporte en una máquina virtual. Para ayudar a realizar esa determinación, Citrix podría pedirle que intente reproducir un problema mediante una versión compatible del sistema operativo invitado. Si el problema parece estar relacionado con el sistema operativo no compatible, Citrix no investigará el problema más a fondo.