Gérer les licences dans My Account sur citrix.com

Remarque :

Citrix souhaite améliorer l’expérience liée aux licences dans My Account sur citrix.com. Vous pouvez choisir Manage Licenses pour trouver, allouer, télécharger, modifier, renvoyer, masquer et afficher facilement les licences. L’expérience « All Licensing Tools » héritée est toujours disponible pour une durée limitée.

Vous pouvez effectuer plusieurs procédures d’administration sans utiliser Citrix Licensing Manager ou License Administration Console. Nous vous recommandons d’utiliser la console appropriée dans la mesure du possible.

Vous pouvez également utiliser l’option Manage Licenses sur citrix.com. Cet article décrit comment gérer les licences sur citrix.com.

Pour les tâches suivantes, accédez à la section Manage Licenses (Gérer les licences) de My Account (Connexion) comme suit :

Pour accéder à « Manage Licences » sur citrix.com

  1. Depuis un navigateur Web, accédez à http://www.citrix.com.
  2. Sélectionnez Sign In > My Account et entrez votre ID utilisateur et mot de passe.
  3. Sélectionnez Gérer les licences.

Outils de licence

Introduction aux concepts de gestion de licences

Nouvelles licences

Vous pouvez afficher uniquement les nouvelles licences en choisissant New Licenses dans le menu Filter by.

  • Les nouvelles licences sont celles que vous avez achetées auprès de Citrix au cours des 30 derniers jours.
  • La section des nouvelles licences affiche les cinq derniers achats récents.
  • Les nouvelles licences sont indiquées par une barre verte et le mot (New) en vert. Nouvelles licences
  • Vous pouvez allouer des licences à partir de la page d’accueil uniquement pour les nouvelles licences. Sélectionnez la licence requise et lancez le processus d’allocation en cliquant sur Allocate licenses.

Licences temporaires arrivant à expiration

Vous pouvez afficher uniquement les licences arrivant à expiration en choisissant Expiring Licenses dans le menu Filter by.

  • Les licences arrivant à expiration sont des licences temporaires qui expirent dans les 90 jours.
  • Les licences qui arrivent à expiration dans les 0 à 30 prochains jours s’affichent avec une barre rouge. Les licences qui arrivent à expiration dans les 31 à 90 prochains jours sont affichées avec une barre orange. Licences arrivant à expiration
  • La colonne Expires indique le nombre de jours avant la date d’expiration de la licence.
  • La colonne Allocated affiche la quantité allouée et la quantité totale achetée.
  • La section des licences arrivant à expiration affiche les 5 achats les plus récents.

Composants de ressource

Pour afficher les composants des ressources, cliquez sur View my products en haut de l’écran. Choisissez une licence et cliquez sur la flèche vers le bas pour développer et afficher les détails. Vous pouvez basculer entre la vue du numéro de commande et la vue du code d’accès à la licence.

Composants de ressource

Allouer des licences

  1. Sélectionnez les licences que vous souhaitez allouer. La page d’accueil affiche uniquement les nouvelles licences dans un délai de 30 jours et les licences à terme expirant. Vous pouvez utiliser le menu Filter by pour rechercher des types spécifiques de licences ou sélectionner Quick find: All active pour afficher toutes les licences.
  2. Dans le menu Sélectionner une action, sélectionnez Allouer des licences.
  3. Suivez le processus pour allouer et générer un fichier.

Modifier les licences – Allouer à un autre serveur

Lorsque vous modifiez une licence, un fichier de licences unique est renvoyé et vous permet d’allouer la licence à un autre serveur.

  1. Pour sélectionner un produit, cliquez sur le lien et affichez la page des détails de la licence produit.
  2. Cochez la case de la licence allouée à modifier.
  3. Dans le menu Select an action, sélectionnez Modify allocations.
  4. Saisissez une nouvelle adresse d’hôte du serveur.
  5. Sélectionnez Modify license file.
  6. Sélectionnez Oui, créer un fichier de licences. Si vous souhaitez effectuer une modification avant de créer le fichier de licence, sélectionnez No, modify the allocation et apportez la modification requise. Sélectionnez ensuite Yes, create license file.
  7. Sélectionnez Download license file et enregistrez le fichier dans un emplacement temporaire. Mémorisez le nom du fichier et l’emplacement sur lequel vous avez téléchargé le fichier. Vous aurez besoin de cet emplacement.
  8. Installez la licence. Consultez Installer des licences.

Télécharger les licences

  1. Sélectionnez les licences que vous souhaitez télécharger. La page d’accueil affiche uniquement les nouvelles licences dans un délai de 30 jours et les licences à terme expirant. Vous pouvez utiliser le menu Filtrer par pour rechercher des types spécifiques de licences ou sélectionner Recherche rapide : Toutes les licences actives pour afficher toutes les licences.
  2. Dans le menu Sélectionner une action, sélectionnez Télécharger toutes les licences et enregistrez le fichier dans un emplacement temporaire. Mémorisez le nom du fichier et l’emplacement sur lequel vous avez téléchargé le fichier. Vous aurez besoin de cet emplacement.
  3. Depuis une invite de commandes, accédez au dossier, puis saisissez la commande suivante :

    lmreread -c @localhost -all

Masquer et afficher les licences

Lorsque vous masquez des licences, celles-ci ne sont pas supprimées d’un compte. Lorsque vous masquez les licences, elles sont supprimées de l’affichage.

  1. Sélectionnez les licences que vous souhaitez masquer.
  2. Dans le menu Select an action, sélectionnez Hide licenses.
  3. Pour afficher les licences, sélectionnez Quick find: All hidden et sélectionnez les licences.
  4. Dans le menu Select an action, sélectionnez Unhide licenses.

Renvoyer les licences

Lorsque vous renvoyez des licences, celle-ci sont replacées dans le regroupement de licences. Ces licences peuvent ensuite être allouées quelle que soit la quantité souhaitée et à tout moment.

  1. Sélectionnez les licences que vous souhaitez renvoyer.
  2. Dans le menu Select an action, sélectionnez Return allocations.

Mise à niveau de l’édition de licence

Si vous êtes éligible à une mise à niveau de version dans le cadre de votre maintenance, vous pouvez obtenir une nouvelle licence et l’ajouter au serveur de licences.

  1. Au bas de la page d’accueil, sélectionnez Upgrade my licenses.
  2. Suivez les options et les instructions du site pour mettre à niveau vos licences d’édition de produit.
  3. Téléchargez ou commandez de nouveaux supports. Vous recevrez un e-mail vous invitant à retourner sur citrix.com pour allouer ou recevoir des licences de fonctionnalités supplémentaires.
  4. Connectez-vous à www.citrix.com pour attribuer vos licences, générer un fichier de licences, télécharger le fichier de licences sur votre serveur de licences et relire le fichier.

Gérer plusieurs licences

Vous pouvez appliquer des actions à plusieurs licences en même temps. Pour appliquer des actions à plusieurs licences, notez les considérations suivantes :

  • Vous pouvez appliquer certaines actions uniquement aux licences possédant les mêmes attributs. Par exemple, vous ne pouvez allouer que des licences ayant le même type de liaison. Un message d’erreur s’affiche lorsque vous sélectionnez des licences qui ne sont pas compatibles avec une action en bloc.

    La première licence que vous sélectionnez sert de base aux sélections suivantes à des fins de compatibilité.

  • Si vous sélectionnez des licences pour lesquelles une action ne peut être appliquée à toutes ces licences, certaines actions peuvent être désactivées ou non affichées, et un message peut apparaître. Par exemple, si vous sélectionner deux licences, une qui a été allouée et une autre qui n’a pas été allouée, un message apparaît. Le message indique que l’action ne peut s’appliquer qu’aux licences allouées.

Installer des licences

  1. Sélectionnez Download license files et enregistrez le fichier dans un répertoire.
  2. Sur le serveur de licences, copiez le fichier de licences à partir du répertoire dans lequel il a été enregistré sur le dossier myfiles.

    Assurez-vous que le fichier de licences conserve l’extension du nom de fichier .lic (en minuscule). Certains processus de copie ne reconnaissent pas le type de fichier de cette extension et ajoutent une extension de fichier .txt lors de la copie. Vous ne pouvez pas importer de fichiers de licences avec une extension de nom de fichier incorrecte.

    • C:\Program Files\Citrix\Licensing\MyFiles sur un ordinateur 32 bits
    • C:\Program Files (x86)\Citrix\Licensing\MyFiles sur un ordinateur 64 bits
  3. À l’invite de commande, accédez à :

    • C:\Program Files\Citrix\Licensing\LS sur un ordinateur 32 bits
    • C:\Program Files (x86)\Citrix\Licensing\LS sur un ordinateur 64 bits

    et entrez la commande suivante : lmreread -c @localhost -all

Rechercher des licences

  • Dans le menu Find a license by, sélectionnez le critère de recherche, saisissez le texte de recherche et sélectionnez Search.

    Vous pouvez sélectionner Afficher options avancées pour affiner davantage votre recherche.

Filtrer les licences

Utilisez le menu Filter by pour limiter votre liste aux licences expirées, aux nouvelles licences, aux allocations disponibles ou aux licences d’essai.

  • Dans le menu Filter by, choisissez la façon dont vous souhaitez filtrer vos résultats.

Create a product license report - Export to Excel (CSV)

Sélectionnez cette option pour exporter votre liste complète de ressources vers Excel.

  1. Sélectionnez les licences que vous souhaitez inclure dans le rapport.
  2. Cliquez sur le lien Export to Excel (.CSV). Dans l’écran View my product, il est au-dessus de la liste des produits. Dans l’écran Manage my licenses, il est en bas de la liste.
  3. Enregistrez le fichier.