Citrix ADC

双方向フォワーディング検出の設定

双方向フォワーディング検出(BFD)プロトコルは、フォワーディングパスの障害を迅速に検出するためのメカニズムです。BFD は、パス障害をミリ秒単位で検出します。BFDは、動的ルーティングプロトコルで使用されます。

BFD 動作では、ルーティングピアはネゴシエートされた間隔で BFD パケットを交換します。ネゴシエートされた間隔に猶予間隔を加えた範囲内にピアからパケットを受信しなかった場合、ピアはDeadと見なされ、登録されたルーティングプロトコルのセットに通知が送信されます。次に、ルーティングプロトコルは最適パスを再計算し、ルーティングテーブルを再プログラムします。BFD では、ルーティングプロトコルによって提供されるタイマーと比較して、より短い時間間隔がサポートされるため、障害の検出が高速になります。

Citrix ADCアプライアンスは、BGP(IPv4およびIPv6)、OSPFv2(IPv4)、およびOSPFv3(IPv6)のルーティングプロトコルに対してBFDをサポートします。Citrix ADCアプライアンスのBFDサポートは、RFC5880、5881、および5883に準拠しています。

双方向フォワーディング検出の設定で考慮すべきポイント

BFD の設定を開始する前に、次の点を考慮してください。

  • RFC 5880、5881、および 5883 で説明されている BFD のさまざまなコンポーネントについて理解していることを確認してください。
  • Citrix ADCアプライアンス上のBFDは、次のルーティングプロトコルでサポートされています。
    • BGP(IPv4およびIPv6)
    • OSPFv2 (IPv4)
    • OSPFv3 (IPv6)
  • Citrix ADCアプライアンスのBFDは、次のルーティングプロトコルではサポートされていません。
    • ISIS
    • RIP (IPv4)
    • RIPng (IPv6)
  • Citrix ADCアプライアンスでは、次のBFD機能はサポートされていません。
    • BFD Echo mode
    • BFD 認証
    • BFD デマンド非同期モード
  • BFD間隔およびBFDRxタイマーの最小値は100ミリ秒です。
  • 共有IPアドレスを使用するトポロジでBFDを使用する場合(たとえば、SNIPアドレスを使用するレイヤー2高可用性セットアップ、またはストライプIPアドレスを使用するクラスターセットアップ)、BFD障害検出時間(順序)により、フェイルオーバー中にアクティブセッションが停止します。ミリ秒単位)は、HAフェイルオーバー検出間隔(3〜4秒)よりも短いです。したがって、フェイルオーバー処理中にルートが保持されるため、レイヤ2のHAトポロジでは正常な再起動を使用することをお勧めします。

構成の手順

Citrix ADCアプライアンスでのBFDの構成は、次のタスクで構成されます。

  • BFD パラメータの設定
  • ダイナミックルーティングプロトコルに対する BFD サポートの設定

BFD パラメータの設定

Citrix ADCアプライアンスは、シングルホップセッション、IPv4マルチホップセッション、IPv6マルチホップセッション用に個別のBFDセッションパラメータを提供します。セッションタイプに BFD パラメータを設定しない場合、デフォルト値がそのセッションに適用されます。

各 BFD パラメータのデフォルト値は、シングルホップセッション、IPv4 マルチホップセッション、および IPv6 マルチホップセッションで同じです。次の表に、各 BFD パラメータのデフォルト値を示します。

BFD パラメータ名 デフォルト値
Interval 750ミリ秒
最小Rx 500 ミリ秒
乗数 3

重要:

CitrixアプライアンスのMellanoxNICは、初期化に約1500ミリ秒かかります。MellanoxNICを搭載したCitrix ADCアプライアンスでは、BFDタイマーを1500ミリ秒以上に設定する必要があります。BFDタイマーを3000ミリ秒に設定することをお勧めします。

  • 間隔Tx = 600ミリ秒
  • 最小受信 = 600ミリ秒
  • マルチプラー = 5

シングルホップセッションの BFD パラメータの設定

VTYSHコマンドラインを使用してシングルホップセッションの BFD パラメータを設定するには、コマンドプロンプトで次のコマンドを順番に入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
interface vlan ID> インターフェイス構成モードを開始します。
bfd singlehop-peer interval <num> minrx <num> multiplier <num> 指定したインターフェイスで BFD パラメータを設定します。

設定例:

> vtysh

ns# configure terminal

ns(config)# interface vlan3

ns(config-if)# bfd singlehop-peer interval 200 minrx 200 multiplier 5

ns(config-if)# exit
<!--NeedCopy-->

IPv4 マルチホップセッションの BFD パラメータの設定

VTYSHコマンドラインを使用して IPv4 マルチホップセッションの BFD パラメータを設定するには、コマンドプロンプトで次のコマンドを順番に入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
bfd multihop-peer <ipv4addr> interval <num> minrx <num> multiplier <num> IPv4マルチホップセッションのBFDパラメータを設定します。

設定例:

    > vtysh

    ns# configure terminal

    ns(config)# bfd multihop-peer 20.20.20.138 interval 300 minrx 300 multiplier 5

    ns(config)# exit
<!--NeedCopy-->

IPv6 マルチホップセッションの BFD パラメータの設定

VTYSHコマンドラインを使用して IPv6 マルチホップセッションの BFD パラメータを設定するには、コマンドプロンプトで次のコマンドを、表示された順序で入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
bfd multihop-peer ipv6 <ipv6addr> interval <num> minrx <num> multiplier <num> IPv6マルチホップセッションのBFDパラメータを設定します。

設定例:

    > vtysh

    ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

    ns(config)# exit
<!--NeedCopy-->

ダイナミックルーティングプロトコルに対する BFD サポートの設定

ピアとのセッションタイプのダイナミックルーティングプロトコルに対して BFD を有効にできます。たとえば、シングルホップとマルチホップ。Citrix ADCアプライアンスは、関連するBFDパラメータ設定をセッションに適用します。

IPv4 BGP シングルホップセッションの BFD の設定

VTYSHコマンドラインを使用して IPv4 BGP シングルホップセッションの BFD を設定するには、コマンドプロンプトで次のコマンドを次のように入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
router bgp <asnumber> BGP自律システム。 asnumber は必須パラメーターです。
neighbor <ipv4addr> remote-as <num> 指定した自律システム内のネイバーの IPv4 アドレスで IPv4 BGP テーブルを更新します。
neighbor <ipv4addr> fall-over bfd 指定されたネイバーの BFD を有効にします。

設定例:

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd

    ns(config-router)#redistribute kernel

    ns(config-router)#exit
<!--NeedCopy-->

IPv4 BGP マルチホップセッションの BFD の設定

VTYSHコマンドラインを使用して IPv4 BGP マルチホップセッションの BFD を設定するには、コマンドプロンプトで次のコマンドを次のように入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
router bgp <asnumber> BGP自律システム。 asnumber は必須パラメーターです。
neighbor <ipv4addr> remote-as <num> 指定した自律システム内のネイバーの IPv4 アドレスで IPv4 BGP テーブルを更新します。
neighbor <ipv4addr> fall-over bfd multihop 指定されたネイバーの BFD を有効にします。

設定例:

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd multihop

    ns(config-router)#redistribute kernel

    ns(config-router)#exit
<!--NeedCopy-->

IPv6 BGP シングルホップセッションの BFD の設定

VTYSHコマンドラインを使用して IPv6 BGP シングルホップセッションの BFD を設定するには、コマンドプロンプトで次のコマンドを次のように入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
router bgp <asnumber> BGP自律システム。 asnumber は必須パラメーターです。
neighbor <ipv6addr> remote-as <num> 指定した自律システム内のネイバーのリンクローカル IPv6 アドレスで IPv6 BGP テーブルを更新します。
neighbor <ipv6addr> fall-over bfd 指定されたネイバーの BFD を有効にします。
address-family ipv6 アドレスファミリ構成モードを開始します。
neighbor <ipv6addr> activate リンクローカルアドレスを使用して、ピアとローカルノード間の IPv6 ルータファミリのプレフィクスを交換します。

設定例:

> vtysh

ns# configure terminal ns(config)#router bgp 1

ns(config-router)#neighbor 30fe:123::124 remote-as 1

ns(config-router)#neighbor 30fe:123::124 fall-over bfd

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 30fe:123::124 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#exit

<!--NeedCopy-->

IPv6 BGP マルチホップセッションの BFD の設定

VTYSHコマンドラインを使用して IPv6 BGP マルチホップセッションの BFD を設定するには、コマンドプロンプトで次のコマンドを、表示された順序で入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
router bgp <asnumber> BGP自律システム。 asnumber は必須パラメーターです。
neighbor <ipv6addr> remote-as <num> 指定した自律システム内のネイバーのリンクローカル IPv6 アドレスで IPv6 BGP テーブルを更新します。
neighbor <ipv6addr> fall-over bfd multihop 指定されたネイバーの BFD を有効にします。
address-family ipv6 アドレスファミリ構成モードを開始します。
neighbor <ipv6addr> activate リンクローカルアドレスを使用して、ピアとローカルノード間の IPv6 ルータファミリのプレフィクスを交換します。

設定例:

> vtysh

ns# configure terminal

ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

ns(config)#router bgp 1

ns(config-router)#neighbor 20fe:125::138 remote-as 1

ns(config-router)#neighbor 20fe:125::138 fall-over bfd multihop

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 20fe:125::138 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#end

<!--NeedCopy-->

インターフェイスでの OSPFv2(IPv4)の BFD の設定

BFD は、すべて、または OSPFv2 プロトコルを使用する特定のインターフェイスで有効にできます。

VTYSHコマンドラインを使用して、すべてのインターフェイスで OSPFv2 の BFD を設定するには、次の手順を実行します。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
router ospf <process tag> OSPFv2 構成モードを開始します。
bfd all-interfaces OSPFv2 を使用するすべてのインターフェイスで BFD を有効にします。

設定例:

    > vtysh

    ns# configure terminal

    ns(config)#router ospf 1

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit
<!--NeedCopy-->

VTYSHコマンドラインを使用して、特定のインターフェイスで OSPFv2 の BFD を設定するには、次の手順を実行します。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
interface <vlan ID> インターフェイス構成モードを開始します。
ip ospf bfd OSPFv2 を使用する指定されたインターフェイスで BFD を有効にします。

設定例:

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan5

    ns(config-if)# ip ospf bfd

    ns(config-if)# exit
<!--NeedCopy-->

インターフェイスでの OSPFv3(IPv6)の BFD の設定

BFD は、すべて、または OSPFv3 プロトコルを使用する特定のインターフェイスで有効にできます。

VTYSHコマンドラインを使用して、すべてのインターフェイスで OSPFv3 の BFD を設定するには、次の手順を実行します。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
router ipv6 ospf <process tag> OSPFv3 構成モードを開始します。
bfd all-interfaces OSPFv3 を使用するすべてのインターフェイスで BFD を有効にします。

設定例:

    > vtysh

    ns# configure terminal

    ns(config)#router ipv6 ospf 10

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit
<!--NeedCopy-->

VTYSHコマンドラインを使用して、特定のインターフェイスで OSPFv3 の BFD を設定するには、次の手順を実行します。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド Specifies
vtysh VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードを開始します。
interface <vlan ID> インターフェイス構成モードを開始します。
ipv6 ospf bfd OSPFv3 を使用する指定されたインターフェイスで BFD を有効にします。

設定例:

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan15

    ns(config-if)# ipv6 ospf bfd

    ns(config-if)# exit
<!--NeedCopy-->
双方向フォワーディング検出の設定