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对与安装、升级和降级过程相关的问题进行故障排除

如果在完成安装、升级或降级过程后设备无法按预期运行,首先要做的是检查问题的最常见原因。

故障排除的资源

为获得最佳结果,请使用以下资源来解决与安装、升级或降级 NetScaler 相关的问题:

  • 来自设备的配置文件。如果是高可用性对,则为两台设备中的配置文件。
  • 设备中的以下文件:
    • 相关 newnslog 文件。
    • ns.log 文件。
    • 消息文件。
  • 网络拓扑图。

问题和解决方案

下面是最常见的安装、升级和降级问题以及解决这些问题的提示:

  1. 问题

    由于硬件和软件不兼容,升级 NetScaler MPX 设备失败。

    解决方案

    请参阅 NetScaler MPX 硬件-软件兼容性表 ,并检查 NetScaler MPX 硬件是否支持该软件版本。

  2. 问题

    由于 NetScaler VPX 设备和虚拟机管理程序不兼容,升级 NetScaler VPX 设备失败。

    解决方案

    请参阅 NetScaler VPX 设备和虚拟机管理程序兼容性列表 ,并检查虚拟机管理程序是否支持 NetScaler VPX 设备型号。

  3. 问题

    由于硬件错误,升级 NetScaler 设备失败。

    解决方案

    验证 NetScaler 设备的完整性。如果您有 NetScaler 硬件设备,Citrix 建议运行 fsck 以运行磁盘检查和验证 NetScaler 硬盘的完整性。

    有关更多信息,请参阅如何验证 NetScaler 设备的文件系统完整性

  4. 问题

    使用 GUI 失速升级 NetScaler 设备。

    解决方案

    刷新浏览器以检查升级是否正在进行。

  5. 问题

    由于 /var 目录中的空间不足,升级 NetScaler 设备失败

    解决方案

    释放 /var 目录上的空间。有关更多信息, 请参阅 如何在 /var 目录上释放空间

  6. 问题

    软件降级后无法访问 NetScaler

    原因

    在软件降级过程中,如果现有发行版和内部版本的配置文件与早期发行版和内部版本的配置文件不匹配,设备将无法加载配置,并且将为设备分配默认 IP 地址。

    解决方案

    • 验证是否可以从控制台访问设备。
    • 验证设备上的 NSIP 地址和路由。
      • 如果 IP 地址已更改为默认的 192.168.100.1 IP 地址,请根据需要更改 IP 地址。
      • 验证设备是否可访问。
  7. 问题

    升级期间,如果我运行同步命令,则会显示以下消息:

    命令在辅助节点上运行失败,但在主节点上成功运行。

    解决方案

    在进行高可用性 (HA) 同步时,请勿运行任何依赖命令 (set /unset /bind /unbind)。

  8. 问题

    在升级过程中,运行强制故障转移命令时,流量不会通过新主节点传输。

    解决方案

    • 检查网络拓扑和交换机配置是否存在问题。
    • 运行 set L2param -garpreply ENABLED 命令以启用 GARP 答复。
    • 如果尚未使用,请尝试使用虚拟 MAC。
    • 运行 sendarp - 主节点上的命令。
  9. 问题

    升级或降级 NetScaler 设备后,通过 SSH 连接到该设备会失败。

    解决方案

    在 NetScaler 设备中执行以下操作:

    • 删除旧的或不安全的主机密钥,位置为 /nsconfig/ssh/ssh_host_*
    • 查看自定义 SSHD 配置(位置为 /nsconfig/sshd_config),然后检查其是否仍然相关且兼容。相应地重命名或删除自定义 SSHD 配置。
    • 冷重启 NetScaler 设备
  10. 问题

    在高可用性对中,运行高可用性强制故障转移命令后,设备将继续重新启动。升级后辅助设备无法启动。

    解决方案

    检查 /var 目录是否已满载。如果是,请删除旧安装文件。运行 df –h 命令以显示可用的磁盘空间。

  11. 问题

    升级高可用性对后,其中一个节点被列为状态 UNKNOWN。

    解决方案

    • 检查两个节点是否正在运行同一版本。如果内部版本不同,且高可用性节点版本不匹配,则在运行 show ha node 命令时,某些字段将显示为 UNKNOWN。
    • 检查辅助设备是否可访问。
  12. 问题

    升级 NetScaler 后,界面显示大多数负载平衡虚拟服务器和服务已关闭。

    解决方案

    验证辅助设备上的 SNIP 地址是否处于激活状态。此外,请键入 show service 命令以查看服务是否正在运行。

  13. 问题

    执行升级后,辅助设备上的所有虚拟服务器都处于关闭状态。

    解决方案

    通过运行以下命令启用高可用性状态和高可用性同步:

    • set node hastate enable
    • set node hasync enable

    不建议禁用高可用性。

  14. 问题

    执行降级后,NetScaler 无法正常启动。

    解决方案

    检查是否安装了正确的许可证。

  15. 问题

    在高可用性对中,某些功能在执行升级后不会同步。

    解决方案

    运行 sync ha file misc 命令,以将配置文件从主节点同步到辅助节点。

  16. 问题

    在重新启动期间,将显示以下错误消息:

    ns.conf 中的一个或多个命令失败,我该怎么办?

    解决方案

    确保 ns.conf 文件中的任何命令都未超过 255 字节的限制。在创建超过 255 字节限制的策略的命令中,可以使用模式集来缩短策略。

    示例:

    add cs policy p11 -rule 'HTTP.REQ.URL.ENDSWITH_ANY("ctx_file_extensions")'
    Done
    <!--NeedCopy-->
    

    ctx_file_extensions 是一个默认的模式集,涵盖了大量扩展。除了默认模式集之外,您还可以创建用户定义的模式集。通过运行以下命令添加模式集:

    add patset <name>
    <!--NeedCopy-->
    

    注意:模式集仅在 9.3 版或更高版本中受支持。

  17. 问题

    在升级 NetScaler VPX 设备时,我被告知要在 /var 中腾出空间。我该删除哪些文件?

    解决方案

    请从 /var/tmp/ 目录中删除旧安装文件。还可以从 /flash 中删除不需要的文件。

  18. 问题

    在辅助设备上运行高可用性强制故障转移命令时,未与图形用户界面 (GUI) 建立连接。

    解决方案

    使用命令行界面登录到辅助设备,然后通过运行 set ns ip <IP> -gui enabled 命令来启用对 GUI 的访问。

  19. 问题

    执行升级后,当我单击 GUI 上必须加载 java 小程序的任何链接(升级向导或许可证向导)时,将显示以下错误消息:GUI version does not match with the kernel version. Please close this instance, clear java plug-in cache and reopen.(GUI 版本与内核版本不匹配。请关闭此实例,清除 java 插件缓存并重新打开。)

    解决方案

    • 使用 GUI 登录 NetScaler。
    • 导航到 NetScaler Gateway > 全局设置。
    • 单击“Settings”(设置)下的“Change Global Settings”(更改全局设置)。
    • 在详细信息窗格的“Client Experience”(客户端体验)下,从 UI 主题列表中选择“Default”(默认)。
    • 单击确定。
  20. 问题

    如果由于任何原因升级 NetScaler 设备失败,如何使用备份的文件还原设备?

    解决方案

    如果升级不成功,请使用备份的文件将设备还原到 NetScaler 设备的早期版本。 有关更多信息,请参阅备份和还原 NetScaler 设备。

    有关备份和还原 NetScaler 群集设置的详细信息,请参阅集 群设置的备份和还原

  21. 问题

    如果 NetScaler 设备升级失败后许可证丢失,如何解决该问题?

    解决方案

    如果缺少任何许可证或者您想重新分配许可证,请参阅以下主题 许可概述

注意

这些故障排除步骤也适用于在多个版本中降级软件时出现配置丢失的问题。

有关任何其他问题,请参阅发行说明、知识中心文章和常见问题解答。

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