App Layering

Exporter et importer des couches

La fonction Exporter et importer des couches vous permet d’exporter des couches à partir de votre appliance App Layering et d’importer les couches dans une appliance installée dans un autre emplacement de votre environnement. Par exemple, vous pouvez utiliser cette fonctionnalité pour déplacer des couches d’une appliance dans un environnement local vers une appliance dans un environnement cloud. Ou, d’un environnement de preuve de concept à la production.

L’appliance exécute une analyse sur chaque couche qu’elle importe afin de déterminer si elle convient à la superposition élastique. Les résultats de l’analyse sont inclus dans les détails de la couche.

Avant de commencer

Avant d’exporter ou d’importer des couches, veuillez répondre aux exigences suivantes et examiner les considérations connexes.

Exigences

Pour exporter et importer des couches, vous devez disposer des éléments suivants :

  • l’appliance qui contient les couches que vous souhaitez exporter.

  • Appliance vers laquelle vous souhaitez déplacer les couches.

  • Un partage de fichiers réseau SMB configuré qui est :
    • Accessible par les deux appareils.
    • A suffisamment d’espace pour toutes les couches exportées, plus les méta-données et les icônes des couches.
  • Informations requises :
    • Chemin d’accès, nom d’utilisateur et mot de passe du partage de fichiers réseau SMB vers lequel vous souhaitez exporter les couches.
    • Nom et mot de passe administrateur de la console de gestion.

Considérations

Tenez compte des points suivants lors de l’exportation et de l’importation de couches.

Si les noms de fichiers sur le partage de fichiers contiennent des caractères spéciaux

Étant donné que le partage de fichiers ne prend pas en charge certains caractères spéciaux, les noms de calques comportant des caractères spéciaux sont temporairement remplacés par des traits de soulignement (_) sur le partage de fichiers. Tous les caractères non pris en charge sont modifiés.

Par exemple, une couche nommée’Notepad + + “devient’Notepad__’ lors de l’exportation. Lorsque les couches sont importées sur la nouvelle appliance, le nom d’origine est restauré et il apparaît de nouveau sous la forme « Bloc-notes + + ».

Exécutez pas plus d’une importation ou d’une exportation à la fois

Une seule importation ou exportation doit être exécutée à la fois.

La couche OS requise doit être incluse dans l’exportation de votre couche

Vous pouvez copier des couches exportées vers un partage de fichiers différent pour importation, mais assurez-vous de déplacer le fichier de couche OS requis avec les autres fichiers de couche. l’appliance importe d’abord la couche OS, car elle est nécessaire pour importer d’autres couches.

Nommer les couches pour l’exportation

Toutes les couches sont exportées vers le répertoire suivant sur le partage de fichiers :

\*network-file-share*\Unidesk\Exported Layers\

Les noms de fichiers exportés reflètent le nom de la couche, le nom de la version de la couche et les GUID de la couche.

Sélection de couches

Lors de la sélection de couches, les icônes indiquent non seulement les couches sélectionnées, mais elles indiquent également si un dossier contient des couches déjà exportées ou importées, en fonction de l’opération que vous effectuez.

Lors de l’exportation de couches :

  • Si une icône est partiellement sélectionnée, cela signifie que le dossier inclut des couches qui ne sont pas sélectionnées.
  • Si une icône est grisée, cela signifie que la couche ne peut pas être sélectionnée pour l’exportation, très probablement parce que la couche a déjà été exportée. Passez la souris sur la couche pour obtenir un message expliquant pourquoi elle ne peut pas être sélectionnée.

Lors de l’importation de couches :

  • Si une icône est partiellement sélectionnée, cela signifie que le dossier inclut des couches qui ne sont pas sélectionnées.
  • Si une icône est grisée, cela signifie que la couche ne peut pas être sélectionnée pour l’importation, très probablement parce que la couche a déjà été importée. Passez la souris sur la couche pour obtenir un message expliquant pourquoi elle ne peut pas être sélectionnée.

Recherche de couches

La zone Rechercher vous permet de trouver tous les calques et versions contenant le texte de recherche. Les recherches ne sont pas sensibles à la casse.

N’oubliez pas que lorsque vous sélectionnez un dossier, l’interface utilisateur sélectionne uniquement le sous-ensemble de couches visibles. Lorsqu’un dossier sélectionné comporte une icône partiellement sélectionnée, cela signifie que certaines des couches sélectionnées ont déjà été exportées ou importées. Vous pouvez afficher ces couches, qui sont normalement masquées, en activant la case à cocher Afficher les versions qui ne peuvent pas être sélectionnées au-dessus de la liste.

Vitesse de recherche affectée par le nombre de niveaux de sous-répertoires

Lors de l’exportation d’une couche, si vos sous-répertoires ont plusieurs niveaux de profondeur, notre logiciel analyse tous les niveaux de ce répertoire et met donc plus de temps à afficher les répertoires.

Exporter des couches

  1. Dans la console de gestion de App Layering, sélectionnez Calques > Exporter.

  2. Sous l’onglet Partage de fichiers, entrez le chemin d’accès du partage de fichiers dans lequel vous souhaitez exporter les couches. Le logiciel App Layering ajoute le chemin suivant à la convention UNC (Universal Naming Convention) que vous spécifiez :

    **\Unidesk\Exported Layers\**

    Entrez le nom d’utilisateur et le mot de passe d’un administrateur disposant d’un accès complet au fichier.

  3. Cliquez sur Tester le partage de fichiers SMB. Si nécessaire, ajustez les informations d’identification jusqu’à ce que le test réussisse. Vous ne pouvez pas continuer tant qu’il n’y a pas de connexion au partage de fichiers.

  4. Sous l’onglet Sélection de version, choisissez les couches à exporter :

    1. Développez chaque couche de système d’exploitation disponible pour afficher les dossiers des versions de vos couches de système d’exploitation, des couches de plate-forme et des couches d’application.
    2. Si vous avez déjà exporté vers l’emplacement sélectionné, vous pouvez cocher la case à cocher Afficher les versions qui ne peuvent pas être sélectionnées pour afficher les couches précédemment exportées vers cet emplacement.
    3. Sélectionnez les couches et les versions à exporter.
  5. Sous l’onglet Confirmer et terminer, vérifiez les couches à exporter et assurez-vous que l’espace disponible dépasse la taille estimée du fichier. Lorsque l’espace est suffisant, l’assistant vous permet de cliquer sur Exporter les couches. Une tâche d’ exportation de couche est créée dans laquelle vous pouvez suivre la progression.

  6. Si vous annulez l’exportation avant l’exportation complète de la couche OS, veillez à réexporter tous les calques, y compris la couche OS.

  7. Si vous créez d’autres couches après l’exportation initiale, exécutez une autre exportation vers le même emplacement. Seules les nouvelles couches sont exportées.

    Avertissement

    N’essayez pas de modifier ou de renommer les fichiers exportés.

Importer des couches

Lors de l’importation de couches d’une appliance dans une autre, si deux couches portent le même nom, même si le contenu de la couche est différent, la couche importée a un « 1 » ajouté au nom. Si d’autres couches portant le même nom sont importées, le « 1 » est incrémenté.

  1. Connectez-vous à la console de gestion App Layering et sélectionnez Calques > Importer.

    Remarque :

    Vous pouvez désélectionner des couches individuelles dans le dossier, comme expliqué à l’étape #4 ci-dessous.

  2. Sous l’onglet Partage de fichiers, entrez le chemin d’accès au partage de fichiers dans lequel vous avez exporté les couches. Ce qui suit est ajouté à l’URL que vous spécifiez.

    **\Unidesk\Exported Layers\**

  3. Entrez le nom d’utilisateur et le mot de passe d’un administrateur disposant d’un accès complet au partage de fichiers.

  4. Cliquez sur Tester le partage de fichiers SMB. Si nécessaire, ajustez les informations d’identification jusqu’à ce que le test réussisse.

    L’assistant compare le contenu de l’appliance avec celui du partage de fichiers sélectionné et se prépare à importer les couches qui n’ont pas encore été importées.

  5. Sous l’onglet Sélection de version, choisissez les couches à importer :

    1. Développez la couche OS qui inclut les couches que vous souhaitez importer, puis sélectionnez l’un des sous-dossiers à importer. Cette option sélectionne toutes les couches et toutes les versions disponibles pour l’importation dans le dossier.

    2. Si vous souhaitez afficher les couches qui ont déjà été importées à partir de cet emplacement, les rendre visibles en cochant la case Afficher les versions qui ne peuvent pas être sélectionnées.

    3. Si l’un des dossiers comprend des couches que vous ne souhaitez pas importer, désélectionnez chacune de ces couches.

  6. Sous l’onglet Confirmer et terminer : vérifiez les couches à importer.

    • Vérifiez les couches mises en file d’attente pour l’importation. Seules les couches qui n’ont pas encore été importées depuis le partage de fichiers sont répertoriées.
    • Vérifiez que l’espace de stockage local de l’appliance est suffisant pour les couches. L’Assistant n’autorise pas l’importation à continuer tant qu’il n’y a pas suffisamment d’espace pour les couches.

    Important

    Si vous annulez une importation de couche OS, toutes les importations de couche qui dépendent de la couche OS sont annulées.

  7. Lorsque tous les paramètres sont valides, cliquez sur Importer les couches. Une tâche Importer est créée dans laquelle vous pouvez suivre la progression.

    Une fois les couches importés, une analyse d’ajustement élastique est exécutée sur les couches, ce qui vous permet de voir quels couches peuvent être affectés de manière élastique.

Exporter et importer des couches