App Layering

Configuration système requise

L’appliance virtuelle App Layering s’exécute sur les hyperviseurs pris en charge répertoriés dans cet article. L’appliance est l’endroit où vous déployez Enterprise Layer Manager (ELM) pendant l’installation.

Vous pouvez créer des couches à utiliser sur pratiquement n’importe quel hyperviseur ou logiciel de provisioning. Pour une expérience utilisateur optimale, publiez des images sur les plates-formes prises en charge.

Hyperviseurs pour l’appliance

L’Enterprise Layer Manager (ELM) s’exécute sur une appliance virtuelle déployée sur un hyperviseur pris en charge.

  • Citrix Hypervisor, versions 6.5, 7.0—7.6, 8.0, 8.1, 8.2
  • Azure Resource Manager
  • Google Cloud
  • Microsoft Hyper-V s’exécutant sur Windows Server 2012 R2, Windows Server 2016, Windows Server 2019 ou Windows Server 2022
    • Les machines virtuelles de génération 2 sont prises en charge lorsque vous utilisez la fonction de composition de déchargement.
  • Hyperviseur Nutanix Acropolis (AHV), versions 5.0 à 5.5 (Prism Element uniquement), 5.8, 5.9, 5.10, 5.11, 5.15 (version de support à long terme), 5.16, 5.17, 5.18, 5.19, 5.20 (version de support à long terme)
  • vSphere vCenter, versions 5.5, 6.0, 6.5, 6.7, 7.0 (y compris les mises à jour ultérieures)
    • Les machines virtuelles de génération 2 sont prises en charge sur les versions 6.7 et 7.0 de vSphere vCenter (et les mises à jour ultérieures) lorsque vous utilisez la fonctionnalité de composition de déchargement

Protocole de partage de fichiers réseau

  • Bloc de messages serveur (SMB)

Connexion réseau

  • Citrix recommande une connexion de 10 Gbit/s entre l’appliance et le partage de fichiers.

Service d’annuaire

  • Microsoft Active Directory

La console de gestion prend en charge les navigateurs Web suivants :

  • Edge version 94 ou ultérieure (version 102 officiellement testée)
  • Chrome (versions 90 et 102 officiellement testées)
  • Firefox (version 45 - 52.9 officiellement testée)

Système d’exploitation pour images en couches

Vous pouvez superposer les versions suivantes du système d’exploitation Windows. Les applications du Windows Store fonctionnent sur toutes les versions Windows prises en charge.

  • Systèmes d’exploitation Windows Server : les versions d’hôte de session suivantes sont prises en charge :

    • Windows Server 2022, 64 bits (éditions Standard et Datacenter)
    • Windows Server 2019, 64 bits (Éditions Standard et Datacenter)
    • Windows Server 2016, 64 bits (éditions standard et datacenter)
    • Windows Server 2012 R2, 64 bits (éditions Standard et Datacenter)
  • Systèmes d’exploitation de bureau - Les versions de bureau suivantes sont prises en charge :

    • Windows 11, version 21H2. Pris en charge dans App Layering version 2112 et versions ultérieures.
    • Windows 10, version 21H2. Pris en charge dans App Layering version 2110 et versions ultérieures.
    • Windows 10, version 21H1. Pris en charge dans les versions 2107 et ultérieures d’App Layering.
    • Windows 10, version 20H2. Pris en charge dans les versions 2011 et ultérieures d’App Layering.

      Avertissement : si vous mettez à niveau la couche du système d’exploitation vers Windows 10 20H2 à partir d’une version antérieure, effectuez une mise à niveau directement vers la version 19042.630 ou une version ultérieure. La mise à niveau vers des versions de Windows 10 20H2 publiées avant le 16/11/2020 peut entraîner des déploiements d’images incohérents.

    • Windows 10, 64 bits, versions 2004, 1909, 1903, 1809, 1803, 1709, 1703 et 1607 (Éditions Éducation et Entreprise)
    • Windows 10, 64 bits, versions 2004, 1909, 1903, 1809, 1803 (édition professionnelle)
    • Windows 7, 64 bits (Édition Entreprise et Professionnelle)
    • Windows 7, 32 bits (Édition Entreprise et Professionnelle)

App Layering prend en charge les modules linguistiques à un octet pour le système d’exploitation Windows anglais américain de base. Il prend en charge les modules linguistiques multi-octets lorsque la couche OS est déployée sur les versions prises en charge de :

  • Citrix Hypervisor
  • VMware vSphere
  • Microsoft Hyper-V

Installez les modules linguistiques sur la machine du système d’exploitation avant d’importer le système d’exploitation dans une couche du système d’exploitation. Les modules linguistiques installés sur une version de couche du système d’exploitation ne fonctionnent pas correctement.

Couches utilisateur

Les couches utilisateur complet sont prises en charge sur les plates-formes suivantes :

  • Systèmes d’exploitation :
    • Windows 7, 64 bits
    • Windows 10, 64 bits
    • Windows 11, 64 bits (uniquement s’il est déployé sur une plate-forme activée pour la composition de déchargement)
  • Plateformes de publication :
    • Citrix Virtual Desktops
    • VMware Horizon View

Images en couches

Les images en couches sont des images de démarrage composées à partir de calques. Chaque image en couches contient une couche de système d’exploitation, une couche de plate-forme et un nombre illimité de couches d’application. Vous pouvez publier des images en couches sur ces plates-formes :

  • Création de machine pour Citrix Hypervisor (anciennement Citrix MCS pour XenServer)
  • Création de machine pour Azure et Azure Government
  • Création de machines pour vSphere
  • Création de machines pour Nutanix AHV
  • Citrix Provisioning, versions 2203, 2106, 2012, 2009, 2006, 2003, 1912, 1909, 7.15 CU6, 1912 CU3, et Provisioning Service (PVS), versions 7.15 LTSR (toutes versions)

    Remarques :

    • Citrix recommande des vitesses réseau de 10 Gbps pour le magasin Provisioning.
    • Les versions 7.1, 7.6 à 7.9, 7.11—7.18 et 1808 de Provisioning Service (PVS) ne sont plus prises en charge.

L’appliance et les connecteurs s’exécutent dans les environnements suivants :

  • Citrix Virtual Apps and Desktops, versions 7:1808, 1811, 1903, 1906, 1909, 1912 (LTSR, CU1- CU5), 2003, 2006, 2009, 2012, 2103, 2106, 2112, 2203 (LTSR)
  • Citrix XenApp et XenDesktop, versions 6.5, 7.0 à 7.18 et 7.15 (LTSR, CU3 à CU7)
  • Citrix Virtual Apps and Desktops Essentials pour Azure
  • Citrix Hypervisor (anciennement Citrix XenServer)
  • Google Cloud
  • Microsoft Azure
  • Microsoft Hyper-V
  • Nutanix Acropolis
  • VMware vSphere
  • VMware Horizon View, versions 6.x, 7.0.x, 7.1.x, 7.2, 7.3, 7.4, 7.6, 7.8, 7.9, 7.11, 7.13, 8.2

Provisionnement des postes de travail et livraison des applications

Vous pouvez utiliser des images en couches pour les postes de travail persistants, tant que vous n’activez pas la couche Elastic Layering ou les couches utilisateur (Full ou Office 365).

Pour activer les couches utilisateur ou les couches Elastic, vous devez utiliser des machines non persistantes.

Remarque :

La couche élastique ne prend pas en charge View Persona Management.

Fonctionnalités d’App Layering par édition

Selon la matrice des fonctionnalités Citrix DaaS et Citrix Virtual Apps and Desktops (CVAD), Citrix App Layering est disponible dans toutes les éditions. Cela signifie que vous pouvez effectuer les opérations suivantes sur n’importe quel nombre de sites Citrix DaaS et CVAD de votre environnement :

  • Créez un nombre illimité de couches de systèmes d’exploitation, de plateformes et d’applications
  • Créez un nombre illimité d’images superposées
  • Créez un nombre illimité de couches élastiques