Citrix Workspace app for Windows

Gestion des plugins

L’application Citrix Workspace pour Windows offre une fonctionnalité de gestion des plug-ins qui fait de l’application Citrix Workspace une application cliente unique requise sur le terminal pour installer et gérer des agents tels que Secure Access Agent et le plug-in Endpoint Analysis (EPA).

Grâce à cette fonctionnalité, les administrateurs peuvent facilement déployer et gérer les agents requis à partir d’une console de gestion unique.

La gestion des plug-ins inclut les étapes suivantes :

  • Les administrateurs doivent spécifier les agents requis sur les appareils des utilisateurs finaux dans Global App Configuration Service. Les administrateurs peuvent spécifier Secure Access Agent et l’agent Endpoint Analysis (EPA).
  • L’application Citrix Workspace extrait la liste des agents à partir de Global App Configuration Service.
  • Sur la base de la liste extraite de Global App Configuration Service, l’application Citrix Workspace télécharge les packages d’agents via le service de mise à jour automatique. Si l’agent n’est pas déjà installé sur le terminal, l’application Citrix Workspace déclenche l’installation de l’agent. Si l’agent est déjà installé, l’application Citrix Workspace déclenche une mise à jour de l’agent (si la version de l’agent téléchargé est supérieure à la version installée).

L’application Citrix Workspace garantit la mise à jour automatique des agents chaque fois qu’une mise à jour est disponible à l’avenir.

L’application Citrix Workspace se connecte automatiquement aux agents à l’aide des informations d’identification de Citrix Workspace.

Remarques :

  • Si les plug-ins EPA et ZTNA n’existent pas, ils sont téléchargés et installés lors de l’ajout du magasin ou du compte pour la première fois.
  • Si le magasin ou le compte et les plug-ins existent déjà et que le programme d’installation contient une version supérieure, les plug-ins sont mis à jour pendant le cycle de mise à jour automatique.

Le schéma suivant illustre le workflow :

Gestion des plugins

Important :

Global App Configuration Service est requis pour activer la fonctionnalité de gestion des plug-ins.

  • Pour les magasins cloud, l’interface utilisateur de Global App Configuration Service est accessible dans la section Configuration de l’espace de travail du portail d’administration Citrix Cloud. Pour plus d’informations, consultez Configurer l’application Citrix Workspace.
  • Pour intégrer des magasins sur site ou pour les clients qui souhaitent configurer la détection basée sur les e-mails pour les magasins cloud, consultez la documentation de Global App Configuration Service.

Vous pouvez activer la fonctionnalité de gestion des plug-ins à l’aide des méthodes suivantes :

  • Utilisation de l’interface utilisateur de Global App Configuration Service : utilisez cette méthode pour déployer la dernière version du client.
  • Utilisation de l’API Global App Configuration Service : utilisez cette méthode pour personnaliser l’installation avec des paramètres permettant de contrôler la version, les modes de déploiement, les intervalles de mise à jour automatique, etc.

Activer la gestion des plug-ins à l’aide de l’interface utilisateur de Global App Configuration Service

Cette méthode s’applique uniquement aux magasins cloud. Les agents (EPA/Secure Access, plug-in Zoom ou plug-in WebEx) peuvent être déployés par les administrateurs à l’aide de l’interface utilisateur.

  1. Connectez-vous à Citrix Cloud.
  2. Dans le menu en haut à gauche de l’écran, sélectionnez Configuration de l’espace de travail. Configuration de l'espace de travail La page Configuration de l’espace de travail s’affiche. Page Configuration de l'espace de travail
  3. Cliquez sur l’onglet Configuration de l’application.
  4. Cliquez sur Mises à jour.
  5. Assurez-vous que la case Windows est cochée.
  6. Sélectionnez les agents requis à côté de Windows dans la liste déroulante Paramètres de l’agent de gestion des applications clientes.

    Mises à jour

Activer la gestion des plug-ins à l’aide de l’API Global App Configuration Service

  1. Configurez et intégrez les paramètres dans Global App Configuration Service à l’aide de l’API. Pour plus d’informations, consultez Mapper les URL de service et configurer les paramètres.
  2. La configuration Global App Configuration suivante doit être intégrée pour que le magasin/compte puisse intégrer l’analyse de point de terminaison et ZTNA/Secure Access Client :
{
    "serviceURL":
    {
        "url": "https://storefront.acme.com:443"
    },
    "settings":
    {
        "description": "Install and update plugins",
        "name": "Install and update plugins",
        "useForAppConfig": true,
        "appSettings":
        {
            "windows":
            [
                {
                    "assignedTo":
                    [
                        "AllUsersNoAuthentication"
                    ],
                    "category": "AutoUpdate",
                    "settings":
                    [
                        {
                            "name": "Auto Update plugins settings",
                            "value":
                            [
                                {
                                    "pluginId": "8A8AF6C0-11F6-4343-BA2D-A85A766170D4",
                                    "pluginName": "Citrix EPA Client",
                                    "pluginSettings":
                                    {
                                        "delayGroup": "Fast",
                                        "deploymentMode": "InstallAndUpdate",
                                        "detectRule": "UpgradeCode:{37A181F7-870E-4BDF-B0EA-E3B4766119FE}",
                                        "isBlocking": true,
                                        "isFTU": true,
                                        "maximumAllowedVersion": "23.8.1.24",
                                        "minimumAllowedVersion": "0.0.0.0",
                                        "stream": "Current",
                                        "upgradeToLatest": true
                                    }
                                },
                                {
                                    "pluginId": "9A8AF6C0-11F6-4343-BA2D-A85A766170D5",
                                    "pluginName": "Citrix Secure Access Client",
                                    "pluginSettings":
                                    {
                                        "delayGroup": "Fast",
                                        "deploymentMode": "InstallAndUpdate",
                                        "detectRule": "UpgradeCode:{F0ED53AB-11BE-4E9C-87E5-CD4A81DA2A4D}",
                                        "isBlocking": false,
                                        "isFTU": true,
                                        "maximumAllowedVersion": "21.8.0.0",
                                        "minimumAllowedVersion": "0.0.0.0",
                                        "stream": "Current",
                                        "upgradeToLatest": true
                                    }
                                },
                                {
                                    "pluginId": "C03BAE37-F3AC-4D63-8BC1-3C9CD2BC9E8D",
                                    "pluginName": "WebEx VDI AutoUpgrade Plugin",
                                    "pluginSettings":
                                    {
                                        "delayGroup": "Fast",
                                        "deploymentMode": "InstallAndUpdate",
                                        "detectRule": "UpgradeCode:{AA2AACDC-D30B-433F-A602-3E25975010A6}",
                                        "isBlocking": false,
                                        "isFTU": false,
                                        "maximumAllowedVersion": "3.1.0.24263",
                                        "minimumAllowedVersion": "0.0.0",
                                        "stream": "Current",
                                        "upgradeToLatest": true
                                    }
                                }
                            ]
                        }
                    ],
                    "userOverride": false
                }
            ]
        }
    }
}

<!--NeedCopy-->

Le tableau suivant répertorie le schéma, les valeurs et la description des paramètres de gestion des plug-ins.

|Paramètre du schéma|Valeur| Description| |—|—|—| |isBlocking| True ou False |Lorsque le paramètre isBlocking est défini sur true, le plug-in est considéré comme obligatoire et la page de connexion n’apparaît que lorsque le plug-in requis est installé. Citrix vous recommande de définir EPA comme plug-in obligatoire.| |pluginName||Nom convivial pour le plug-in. Le nom du plug-in peut être modifié.| |pluginId| |Identifiant du plug-in, ne doit pas être modifié.| |delayGroup| Fast, Medium, Slow| Intervalle de mise à jour automatique auquel les plug-ins doivent être mis à jour.| |deploymentMode|InstallAndUpdate/Update|InstallAndUpdate : le plug-in peut être nouvellement installé et mis à jour avec la nouvelle version.Update : seule une mise à jour est autorisée, aucune nouvelle installation. | |None||Aucune action n’est requise pour ce plug-in.| |detectRule|La valeur ne peut pas être modifiée.| Vérifie si le plug-in est déjà installé ou non.| |maximumAllowedVersion| |Version maximale autorisée du plug-in.| |minimumAllowedVersion| |Version minimale autorisée du plug-in.| |upgradeToLatest|True ou False| Doit être défini sur False pour prendre en charge maximumAllowedVersion et minimumAllowedVersion. True : la dernière version du plug-in est prise en compte lors de la mise à jour. | |Stream|Current|Doit être réglé sur Current pour recevoir l’installation ou la mise à jour automatique des plug-ins|

Flux de travail utilisateur

  1. Téléchargez et installez l’application Citrix Workspace pour Windows version 2212.
  2. Cliquez sur Ajouter un compte à la fin de l’installation.
  3. Ajoutez le magasin/compte dans lequel les paramètres de configuration de l’application sont intégrés.

    Le message suivant s’affiche lors de l’installation des plug-ins obligatoires :

    Install On Hold (Installation en attente)

  4. Lorsque l’installation est terminée, la notification toast suivante s’affiche :

    Gestion des plug-ins - Réussite

  5. Cliquez sur Know More (En savoir plus) pour connaître les plug-ins installés.

    Know More

Gestion des plug-ins pour le plug-in Zoom

Le téléchargement, l’installation et la mise à jour automatique du plug-in Zoom sont également pris en charge et gérés de la même manière que les plug-ins EPA et ZTNA.

Le paramètre Global App Configuration suivant doit être intégré pour que le magasin/compte puisse tirer parti de cette fonctionnalité :


{
    "serviceURL":
    {
        "url": "https://storefront.acme.com:443"
    },
    "settings":
    {
        "description": "Install and update plugins",
        "name": "Install and update plugins",
        "useForAppConfig": true,
        "appSettings":
        {
            "windows":
            [
                {
                    "assignedTo":
                    [
                        "AllUsersNoAuthentication"
                    ],
                    "category": "AutoUpdate",
                    "settings":
                    [
                        {
                            "name": "Auto Update plugins settings",
                            "value":
                            [
                                {
                                    "pluginId": "1A4BB471-022C-4C87-BDCD-0B64FB42869C",
                                    "pluginName": "Zoom VDI AutoUpgrade Plugin",
                                    "pluginSettings":
                                    {
                                        "delayGroup": "Fast",
                                        "deploymentMode": "InstallAndUpdate",
                                        "detectRule": "UpgradeCode:{34225638-14F3-4059-BE34-175AC9B35435}",
                                        "isBlocking": false,
                                        "isFTU": false,
                                        "maximumAllowedVersion": "5.11.2872",
                                        "minimumAllowedVersion": "0.0.0",
                                        "stream": "Current",
                                        "upgradeToLatest": true
                                    }
                                }
                            ]
                        }
                    ],
                    "userOverride": false
                }
            ]
        }
    }
}

<!--NeedCopy-->