Gérer les licences sur citrix.com

Cet article explique comment gérer les licences à partir du site citrix.com. Vous pouvez utiliser Manage Licenses sur citrix.com pour trouver, allouer, télécharger, modifier, renvoyer, masquer et afficher facilement les licences.

Remarque :

Vous pouvez effectuer plusieurs actions liées à la gestion des licences à partir de Citrix Studio et Citrix Licensing Manager.

Pour accéder à « Manage Licences » sur citrix.com

  1. À partir d’un navigateur Web, ouvrez la page http://www.citrix.com.
  2. Sélectionnez Sign In > My Account et entrez votre ID utilisateur et mot de passe.
  3. Sélectionnez Gérer les licences.

Outils de licence

Rechercher des licences

Dans le menu Find a license by, sélectionnez le critère de recherche, saisissez le texte de recherche et sélectionnez Search. Vous pouvez sélectionner Afficher options avancées pour affiner davantage votre recherche.

Allouer des licences

  1. Sélectionnez les licences que vous souhaitez allouer. La page d’accueil affiche uniquement les nouvelles licences dans un délai de 30 jours et les licences à terme expirant. Vous pouvez utiliser la fonction de recherche Rechercher une licence par…. pour rechercher toutes les licences à l’aide de l’un des critères de recherche, puis le menu Filtrer par pour limiter l’affichage à des types spécifiques de licences ou vous pouvez sélectionner Recherche rapide : Toutes les licences actives pour afficher toutes les licences.

  2. Dans le menu Sélectionner une action, sélectionnez Allouer des licences.

  3. Entrez l’ID de liaison (par exemple, nom d’hôte ou adresse Ethernet) et le nombre de licences à allouer, puis cliquez sur Créer un fichier de licences.

  4. Sélectionnez Oui, créer un fichier de licences. Si vous souhaitez effectuer une modification avant de créer le fichier de licence, sélectionnez No, modify the allocation et apportez la modification requise. Sélectionnez ensuite Yes, create license file.

  5. Sélectionnez Download license file et enregistrez le fichier dans un emplacement temporaire. Mémorisez le nom du fichier et l’emplacement sur lequel vous avez téléchargé le fichier. Vous aurez besoin de cet emplacement.

  6. Installez la licence. Consultez Installer des licences.

Télécharger les licences

  1. Sélectionnez les licences que vous souhaitez télécharger. La page d’accueil affiche uniquement les nouvelles licences dans un délai de 30 jours et les licences à terme expirant. Vous pouvez utiliser la fonction de recherche Rechercher une licence par…. pour rechercher toutes les licences à l’aide de l’un des critères de recherche, puis le menu Filtrer par pour limiter l’affichage à des types spécifiques de licences ou vous pouvez sélectionner Recherche rapide : Toutes les licences actives pour afficher toutes les licences.
  2. Dans le menu Sélectionner une action, sélectionnez Télécharger toutes les licences et enregistrez le fichier dans un emplacement temporaire (généralement, le dossier Téléchargements).
  3. Copiez les fichiers de licences téléchargés dans le dossier MyFiles :

    • C:\Program Files\Citrix\Licensing\MyFiles sur un ordinateur 32 bits
    • C:\Program Files (x86)\Citrix\Licensing\MyFiles sur un ordinateur 64 bits

    Assurez-vous que le fichier de licences conserve l’extension du nom de fichier .lic (en minuscule). Certains processus de copie ne reconnaissent pas le type de fichier de cette extension et ajoutent une extension de fichier .txt lors de la copie. Vous ne pouvez pas importer de fichiers de licences avec une extension de nom de fichier incorrecte.

  4. Depuis une invite de commandes, accédez au dossier C:\Program Files (x86)\Citrix\Licensing\LS ou C:\Program Files\Citrix\Licensing\LS, puis saisissez la commande suivante :

    lmreread -c @localhost -all

Pour plus d’informations sur la commande lmreread, consultez Relire les fichiers de licences et d’options (lmreread).

Installer des licences

Pour plus d’informations sur l’installation de licences pour des solutions Citrix spécifiques, consultez :

Pour plus d’informations sur l’installation de licences à l’aide de Citrix Licensing Manager, consultez Installer des licences.

Composants d’affichage des ressources

Pour afficher les composants de ressources, cliquez sur View my products en haut de l’écran. Choisissez une licence et cliquez sur la flèche vers le bas pour développer et afficher les détails. Vous pouvez basculer entre la vue du numéro de commande et la vue du code d’accès à la licence.

Composants des ressources

Renvoyer des allocations

Lorsque vous renvoyez des allocations, les licences sont replacées dans le regroupement de licences Vous pouvez ensuite allouer ces licences quelle que soit la quantité souhaitée et à tout moment. Par exemple, vous pouvez renvoyer une licence si vous désactivez un serveur de licences, mais vous n’êtes pas prêt à déployer les licences existantes ailleurs.

  1. Cochez la case des licences que vous souhaitez renvoyer.
  2. Dans le menu Select an action, sélectionnez Return allocations.
  3. Sélectionnez Yes, process return. Si vous choisissez cette option, vous ne pouvez pas l’annuler.

Modifier les licences

Lorsque vous modifiez une licence, un fichier de licences unique est renvoyé et vous permet d’allouer la licence à un autre serveur. Par exemple, vous avez 5 000 licences installées sur le serveur de licences 1. Vous souhaitez déplacer 1 000 licences vers le serveur de licences 2. Modifiez les allocations, puis allouez 4 000 licences au serveur de licences 1 et 1 000 licences au serveur de licences 2.

  1. Pour sélectionner un produit, cliquez sur le lien et affichez la page des détails de la licence produit.
  2. Cochez la case de la licence allouée à modifier.
  3. Dans le menu Select an action, sélectionnez Modify allocations.
  4. Saisissez une nouvelle adresse d’hôte du serveur.
  5. Sélectionnez Modify license file.
  6. Sélectionnez Oui, créer un fichier de licences. Si vous souhaitez effectuer une modification avant de créer le fichier de licence, sélectionnez No, modify the allocation et apportez la modification requise. Sélectionnez ensuite Yes, create license file.
  7. Sélectionnez Download license file et enregistrez le fichier dans un emplacement temporaire. Mémorisez le nom du fichier et l’emplacement sur lequel vous avez téléchargé le fichier. Vous aurez besoin de cet emplacement.
  8. Installez la licence. Consultez Installer des licences.

Mettre à niveau les licences

Si vous êtes éligible à une mise à niveau de version dans le cadre de votre maintenance, vous pouvez télécharger une licence de renouvellements CSS et l’ajouter au serveur de licences.

  1. Au bas de la page d’accueil, sélectionnez Upgrade my licenses.
  2. Suivez les options et les instructions du site pour mettre à niveau vos licences d’édition de produit.
  3. Téléchargez ou commandez de nouveaux supports. Vous recevrez un e-mail vous invitant à retourner sur citrix.com pour allouer ou recevoir des licences de fonctionnalités supplémentaires.
  4. Connectez-vous à www.citrix.com pour attribuer vos licences, générer un fichier de licences, télécharger le fichier de licences sur votre serveur de licences et relire le fichier.

Masquer et afficher les licences

Lorsque vous masquez des licences, celles-ci ne sont pas supprimées d’un compte. Lorsque vous masquez les licences, elles sont supprimées de l’affichage. Vous pouvez masquer les licences d’anciens produits. En masquant ces licences, vous augmentez la visibilité des licences de produits que vous souhaitez afficher.

  1. Sélectionnez les licences que vous souhaitez masquer.
  2. Dans le menu Select an action, sélectionnez Hide licenses.
  3. Pour afficher les licences, sélectionnez Quick find: All hidden et sélectionnez les licences.
  4. Dans le menu Select an action, sélectionnez Unhide licenses.

Gérer plusieurs licences (actions groupées)

Vous pouvez appliquer des actions à plusieurs licences en même temps. Cochez les cases des différentes licences, puis sélectionnez et action.

Pour appliquer des actions à plusieurs licences, notez les considérations suivantes :

  • Vous pouvez appliquer certaines actions uniquement aux licences possédant les mêmes attributs. Par exemple, vous ne pouvez allouer que des licences ayant le même type de liaison. Un message d’erreur s’affiche lorsque vous sélectionnez des licences qui ne sont pas compatibles avec une action en bloc. La première licence que vous sélectionnez sert de base aux sélections suivantes à des fins de compatibilité.

  • Si vous sélectionnez des licences pour lesquelles une action ne peut être appliquée à toutes ces licences, certaines actions peuvent être désactivées ou non affichées, et un message peut apparaître. Par exemple, si vous sélectionner deux licences, une qui a été allouée et une autre qui n’a pas été allouée, un message apparaît. Le message indique que l’action ne peut s’appliquer qu’aux licences allouées.

    Erreur d'action en bloc

Filtrer les licences

Utilisez le menu Filter by pour limiter votre liste aux licences expirées, aux nouvelles licences, aux allocations disponibles ou aux licences d’essai. Dans le menu Filter by, choisissez la façon dont vous souhaitez filtrer vos résultats.

Create a product license report - Export to Excel (CSV)

Sélectionnez cette option pour exporter votre liste complète de ressources et de données vers Excel.

  1. Sélectionnez les licences que vous souhaitez inclure dans le rapport.
  2. Cliquez sur le lien Export to Excel (.CSV). Sur la page View my product, il est au-dessus de la liste des produits. Sur la page Manage my licenses, il est en bas de la liste.
  3. Enregistrez le fichier.