Session Recording

Aufzeichnungen öffnen und wiedergeben

Aufzeichnungen öffnen

Sie können Sitzungsaufzeichnungen im Session Recording-Player auf drei Arten öffnen:

  • Führen Sie eine Suche mit dem Session Recording-Player durch. Aufgezeichnete Sitzungen, die die Suchkriterien erfüllen, werden im Suchergebnisbereich angezeigt.
  • Greifen Sie direkt von Ihrem lokalen Laufwerk oder einem freigegebenen Laufwerk auf aufgezeichnete Sitzungsdateien zu.
  • Greifen Sie über einen Favoritenordner auf aufgezeichnete Sitzungsdateien zu.

Wenn Sie eine Datei öffnen, die ohne digitale Signatur aufgezeichnet wurde, wird eine Warnmeldung angezeigt. Sie besagt, dass Ursprung und Integrität der Datei nicht überprüft wurden. Wenn Sie von der Integrität der Datei überzeugt sind, klicken Sie im Warnfenster auf Ja, um die Datei zu öffnen.

Der Session Recording-Player überprüft die Version der Citrix Workspace™-App, bevor eine aufgezeichnete Sitzung wiedergegeben wird. Wenn der Player die Version der Citrix Workspace™-App nicht unterstützt, wird ein Fehler zurückgegeben. Um den Fehler zu beheben, wählen Sie unter Session Recording Server-Eigenschaften die Option Überprüfung der Citrix Workspace™-App-Version überspringen.

Überprüfung der Citrix Workspace-App-Version überspringen

Hinweis:

Mit der Administratorprotokollierungsfunktion von Session Recording können Sie die Downloads von Aufzeichnungen im Session Recording-Player protokollieren. Weitere Informationen finden Sie unter Administratorprotokollierung.

Aufzeichnung im Suchergebnisbereich öffnen

  1. Melden Sie sich an dem Computer an, auf dem der Session Recording-Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Führen Sie eine Suche durch.
  4. Wenn der Bereich Suchergebnisse nicht sichtbar ist, wählen Sie Suchergebnisse im Bereich Arbeitsbereich.
  5. Wählen Sie im Bereich Suchergebnisse die Sitzung aus, die Sie wiedergeben möchten.
  6. Führen Sie einen der folgenden Schritte aus:
    • Doppelklicken Sie auf die Sitzung.
    • Klicken Sie mit der rechten Maustaste und wählen Sie Wiedergabe.
    • Wählen Sie in der Menüleiste des Session Recording Players die Option Wiedergabe > Wiedergabe.

Eine Aufzeichnung durch Dateizugriff öffnen

Der Name einer Aufzeichnungsdatei beginnt mit i_, gefolgt von einer eindeutigen alphanumerischen Datei-ID und dann der Erweiterung .icl oder .icle. Die Erweiterung .icl kennzeichnet Aufzeichnungen ohne angewendeten Wiedergabeschutz. Die Erweiterung .icle kennzeichnet Aufzeichnungen mit angewendetem Wiedergabeschutz. Aufgezeichnete Sitzungsdateien werden in einem Ordner gespeichert, der das Datum der Sitzungsaufzeichnung enthält. Beispielsweise wird die Datei für eine am 22. Dezember 2014 aufgezeichnete Sitzung im Ordnerpfad 2014\12\22 gespeichert.

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording Player installiert ist.
  2. Wählen Sie im Startmenü die Option Session Recording Player.
  3. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie in der Menüleiste des Session Recording Players die Option Datei > Öffnen und suchen Sie die Datei.
    • Navigieren Sie mit dem Windows-Explorer zur Datei und ziehen Sie die Datei in das Fenster Player.
    • Navigieren Sie mit dem Windows-Explorer zur Datei und doppelklicken Sie darauf.
    • Wenn Sie Favoriten im Bereich Arbeitsbereich erstellt haben, wählen Sie Favoriten und öffnen Sie die Datei aus dem Favoritenbereich auf die gleiche Weise, wie Sie Dateien aus dem Suchergebnisbereich öffnen.

Favoriten verwenden

Durch das Erstellen der Ordner Favoriten können Sie schnell auf häufig angezeigte Aufzeichnungen zugreifen. Diese Ordner Favoriten verweisen auf aufgezeichnete Sitzungsdateien, die auf Ihrer Arbeitsstation oder einem Netzlaufwerk gespeichert sind. Sie können diese Dateien auf andere Arbeitsstationen importieren und exportieren und diese Ordner mit anderen Benutzern des Session Recording Players teilen.

Hinweis:

Nur Benutzer mit Zugriffsrechten auf den Session Recording Player können die aufgezeichneten Sitzungsdateien herunterladen, die den Ordnern Favoriten zugeordnet sind. Wenden Sie sich an Ihren Session Recording-Administrator, um die Zugriffsrechte zu erhalten.

So erstellen Sie einen Unterordner Favoriten:

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Wählen Sie im Fenster Session Recording Player den Ordner Favoriten im Bereich Arbeitsbereich aus.
  4. Wählen Sie in der Menüleiste Datei > Ordner > Neuer Ordner. Ein neuer Ordner wird unter dem Ordner Favoriten angezeigt.
  5. Geben Sie den Ordnernamen ein, und drücken Sie dann die Eingabetaste oder klicken Sie an eine beliebige Stelle, um den neuen Namen zu übernehmen.

Verwenden Sie die anderen Optionen, die im Menü Datei > Ordner angezeigt werden, um die Ordner zu löschen, umzubenennen, zu verschieben, zu kopieren, zu importieren und zu exportieren.

Aufzeichnungen wiedergeben

Nachdem Sie eine aufgezeichnete Sitzung im Session Recording Player geöffnet haben, können Sie mit den folgenden Methoden durch die aufgezeichneten Sitzungen navigieren:

  • Verwenden Sie die Player-Steuerelemente, um die Wiedergabe zu starten, zu stoppen, anzuhalten und die Wiedergabegeschwindigkeit zu erhöhen oder zu verringern.
  • Verwenden Sie den Suchschieberegler, um vor- oder zurückzuspringen.

Sie können auch durch die aufgezeichnete Sitzung navigieren, indem Sie zu den eingefügten Markierungen und benutzerdefinierten Ereignissen gehen.

Hinweis:

  • Während der Wiedergabe einer aufgezeichneten Sitzung kann ein zweiter Mauszeiger erscheinen. Der zweite Zeiger erscheint an dem Punkt in der Aufzeichnung, an dem der Benutzer innerhalb von Internet Explorer navigierte und auf ein Bild klickte, das ursprünglich größer als der Bildschirm war, aber automatisch von Internet Explorer skaliert wurde. Während der Sitzung erscheint nur ein Zeiger, während der Wiedergabe können jedoch zwei erscheinen.
  • Diese Version von Session Recording unterstützt weder SpeedScreen Multimedia Acceleration noch die Richtlinieneinstellung für die Flash-Qualitätsanpassung. Wenn diese Option aktiviert ist, wird bei der Wiedergabe ein schwarzes Quadrat angezeigt.
  • Wenn Sie eine Sitzung mit einer Auflösung von 4096 x 4096 oder höher aufzeichnen, können Fragmente im Erscheinungsbild der Aufzeichnung auftreten.

Player-Steuerelemente verwenden

Sie können die Player-Steuerelemente im unteren Teil des Player-Fensters anklicken oder über die Menüleiste des Session Recording Players unter Wiedergabe aufrufen.

Player-Steuerelement Funktion
Wiedergabetaste Spielt die ausgewählte Sitzungsdatei ab.
Pause-Taste Hält die Wiedergabe an.
Stopp-Taste Stoppt die Wiedergabe. Wenn Sie auf Stopp und dann auf Wiedergabe klicken, beginnt die Aufzeichnung am Anfang der Datei erneut.
Wiedergabegeschwindigkeit rückwärts Halbiert die aktuelle Wiedergabegeschwindigkeit auf ein Minimum von einem Viertel der normalen Geschwindigkeit.
Wiedergabegeschwindigkeit vorwärts Verdoppelt die aktuelle Wiedergabegeschwindigkeit bis maximal zum 32-fachen der normalen Geschwindigkeit.

Die Suchleiste verwenden

Verwenden Sie die Suchleiste im unteren Teil des Player-Fensters, um zu einer anderen Position innerhalb der aufgezeichneten Sitzung zu springen. Sie können die Suchleiste zu dem Punkt in der Aufzeichnung ziehen, den Sie ansehen möchten, oder an eine beliebige Stelle der Suchleiste klicken, um zu dieser Stelle zu gelangen.

Sie können auch die folgenden Tastaturtasten verwenden, um die Suchleiste zu steuern:

Tastaturtaste Funktion
Pos1 Springt zum Anfang.
Ende Springt zum Ende.
Pfeil nach rechts Springt fünf Sekunden vorwärts.
Linker Pfeil Spult fünf Sekunden zurück.
Mausrad eine Stufe nach unten bewegen Spult 15 Sekunden vor.
Mausrad eine Stufe nach oben bewegen Spult 15 Sekunden zurück.
Strg + Rechter Pfeil Spult 30 Sekunden vor.
Strg + Linker Pfeil Spult 30 Sekunden zurück.
Bild ab Spult eine Minute vor.
Bild auf Spult eine Minute zurück.
Strg + Mausrad eine Stufe nach unten bewegen Springt 90 Sekunden vorwärts.
Strg + Mausrad eine Stufe nach oben drehen Springt 90 Sekunden rückwärts.
Strg + Bild ab Springt sechs Minuten vorwärts.
Strg + Bild auf Springt sechs Minuten rückwärts.

So passen Sie die Geschwindigkeit des Suchschiebereglers an: Wählen Sie in der Menüleiste des Session Recording Players die Option Extras > Optionen > Player und ziehen Sie den Schieberegler, um die Suchreaktionszeit zu erhöhen oder zu verringern. Eine schnellere Reaktionszeit erfordert mehr Arbeitsspeicher. Die Reaktion kann je nach Größe der Aufzeichnungen und der Hardware Ihres Computers langsam sein.

Wiedergabegeschwindigkeit ändern

Sie können eine Wiedergabegeschwindigkeit in exponentiellen Schritten von einem Viertel der normalen Wiedergabegeschwindigkeit bis zum 32-fachen der normalen Wiedergabegeschwindigkeit einstellen.

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording Player installiert ist.
  2. Wählen Sie im Startmenü die Option Session Recording Player.
  3. Wählen Sie in der Menüleiste des Session Recording Players die Option Wiedergabe > Wiedergabegeschwindigkeit.
  4. Wählen Sie eine Geschwindigkeitsoption.

Die Geschwindigkeit wird sofort angepasst. Text, der die exponentielle Rate anzeigt, erscheint kurz in Grün im unteren Teil des Playerfensters.

Leerlaufzeiten aufgezeichneter Sitzungen hervorheben

Leerlaufzeiten einer aufgezeichneten Sitzung sind die Abschnitte, in denen keine Aktion stattfindet. Der Session Recording Player kann die Leerlaufzeiten aufgezeichneter Sitzungen während der Wiedergabe hervorheben. Die Option ist standardmäßig Ein. Weitere Informationen finden Sie unter Leerlaufzeiten hervorheben.

Abschnitte überspringen, in denen keine Aktion stattgefunden hat

Im schnellen Überprüfungsmodus können Sie den Player so einstellen, dass er die Abschnitte aufgezeichneter Sitzungen überspringt, in denen keine Aktion stattfindet. Diese Einstellung spart Zeit bei der Wiedergabe. Sie überspringt jedoch keine animierten Sequenzen wie animierte Mauszeiger, blinkende Cursor oder angezeigte Uhren mit Sekundenzeigerbewegungen.

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Wählen Sie in der Menüleiste des Session Recording Players die Option Wiedergabe > Schneller Überprüfungsmodus.

Die Option schaltet sich ein und aus. Jedes Mal, wenn Sie sie auswählen, wird ihr Status kurz grün im Player-Fenster angezeigt.

Wiedergabeanzeige ändern

Sie können Folgendes tun, um zu ändern, wie aufgezeichnete Sitzungen im Player-Fenster angezeigt werden:

  • Das Bild schwenken und skalieren.
  • Wiedergabe im Vollbildmodus anzeigen
  • Das Player-Fenster in einem separaten Fenster anzeigen
  • Einen roten Rahmen um die aufgezeichnete Sitzung anzeigen, um sie vom Hintergrund des Player-Fensters abzuheben.

Das Player-Fenster im Vollbildmodus anzeigen

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Wählen Sie in der Menüleiste des Session Recording Player die Option Ansicht > Player im Vollbildmodus.
  4. Um zur Originalgröße zurückzukehren, drücken Sie Esc oder F11.

Player-Fenster in einem separaten Fenster anzeigen

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Wählen Sie in der Menüleiste des Session Recording Player die Option Ansicht > Player in separatem Fenster. Ein neues Fenster mit dem Player-Fenster wird angezeigt. Sie können das Fenster ziehen und seine Größe ändern.
  4. Um das Player-Fenster in das Hauptfenster einzubetten, wählen Sie Ansicht > Player in separatem Fenster oder drücken Sie F10.

Sitzungswiedergabe skalieren, damit sie in das Player-Fenster passt

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Wählen Sie in der Menüleiste des Session Recording Player die Option Wiedergabe > Schwenken und Skalieren > An Fenster anpassen.
    • An Fenster anpassen (Schnelles Rendering) verkleinert Bilder bei guter Qualität. Bilder werden schneller gezeichnet als bei der Option Hohe Qualität, aber die Bilder und Texte sind nicht scharf. Verwenden Sie diese Option, wenn Sie bei Verwendung des Modus Hohe Qualität Leistungsprobleme haben.
    • An Fenster anpassen (Hohe Qualität) verkleinert Bilder bei hoher Qualität. Bei Verwendung dieser Option kann es vorkommen, dass die Bilder langsamer gezeichnet werden als bei der Option Schnelles Rendering.

Bild schwenken

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording-Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Wählen Sie in der Menüleiste des Session Recording Player die Option Wiedergabe > Schwenken und Skalieren > Schwenken. Der Zeiger ändert sich in eine Hand. Eine kleine Darstellung des Bildschirms wird oben rechts im Playerfenster angezeigt.
  4. Ziehen Sie das Bild. Die kleine Darstellung zeigt an, wo Sie sich im Bild befinden.
  5. Um das Schwenken zu beenden, wählen Sie eine der Skalierungsoptionen.

Roten Rahmen um die Sitzungsaufzeichnung anzeigen

  1. Melden Sie sich an der Arbeitsstation an, auf der der Session Recording-Player installiert ist.
  2. Wählen Sie im Menü Start die Option Session Recording Player.
  3. Wählen Sie in der Menüleiste des Session Recording Player die Option Extras > Optionen > Player.
  4. Aktivieren Sie das Kontrollkästchen Rahmen um Sitzungsaufzeichnung anzeigen. Wenn das Kontrollkästchen Rahmen um Sitzungsaufzeichnung anzeigen nicht aktiviert ist, können Sie den roten Rahmen vorübergehend anzeigen, indem Sie die linke Maustaste gedrückt halten, während sich der Zeiger im Playerfenster befindet.
Aufzeichnungen öffnen und wiedergeben