Gérer les licences dans My Account sur citrix.com

Remarque :

Citrix souhaite améliorer l’expérience liée aux licences dans My Account sur citrix.com. Vous pouvez choisir Manage Licenses pour trouver, allouer, télécharger, modifier, renvoyer, masquer et afficher facilement les licences. L’expérience « All Licensing Tools » héritée est toujours disponible pour une durée limitée.

Vous pouvez effectuer plusieurs procédures d’administration sans utiliser Citrix Licensing Manager ou License Administration Console. Nous vous recommandons d’utiliser la console appropriée dans la mesure du possible.

Vous pouvez également utiliser l’option Manage Licenses sur citrix.com. Cet article décrit comment gérer les licences sur citrix.com.

Pour les tâches suivantes, accédez à la section Manage Licenses (Gérer les licences) de My Account (Connexion) comme suit :

Pour accéder à « Manage Licences » sur citrix.com

  1. Depuis un navigateur Web, accédez à http://www.citrix.com.
  2. Sélectionnez Sign In > My Account et entrez votre ID utilisateur et mot de passe.
  3. Sélectionnez Manage Licenses.

Outils de licence

Allouer des licences

  1. Sélectionnez les licences que vous souhaitez allouer. La page d’accueil affiche uniquement les nouvelles licences dans un délai de 30 jours et les licences à terme expirant. Vous pouvez utiliser le menu Filter by pour rechercher des types spécifiques de licences ou sélectionner Quick find: All active pour afficher toutes les licences.
  2. Dans le menu Select an action, sélectionnez Allocate licenses.
  3. Suivez le processus pour allouer et générer un fichier.

Modifier les licences

Lorsque vous modifiez une licence, un fichier de licences unique est renvoyé et vous permet d’allouer la licence à un autre serveur.

  1. Sélectionnez un produit et cliquez sur le lien pour afficher les détails de la licence produit.
  2. Sélectionnez la licence allouée à modifier.
  3. Dans le menu Select an action, sélectionnez Modify allocations.
  4. Saisissez un nouveau nom de serveur.
  5. Sélectionnez Modify license file.

Télécharger les licences

  1. Sélectionnez les licences que vous souhaitez télécharger. La page d’accueil affiche uniquement les nouvelles licences dans un délai de 30 jours et les licences à terme expirant. Vous pouvez utiliser le menu Filter by pour rechercher des types spécifiques de licences ou sélectionner Quick find: All active pour afficher toutes les licences.
  2. Dans le menu Select an action, sélectionnez Download all licenses et enregistrez le fichier dans un emplacement temporaire. Mémorisez le nom du fichier et l’emplacement sur lequel vous avez téléchargé le fichier. Vous aurez besoin de cet emplacement.
  3. Depuis une invite de commandes, accédez au dossier, puis saisissez la commande suivante :

    lmreread -c @localhost -all

Masquer et afficher les licences

Lorsque vous masquez des licences, celles-ci ne sont pas supprimées d’un compte, Lorsque vous masquez les licences, elles sont supprimées de l’affichage.

  1. Sélectionnez les licences que vous souhaitez masquer.
  2. Dans le menu Select an action, sélectionnez Hide licenses.
  3. Pour afficher les licences, sélectionnez Quick find: All hidden et sélectionnez les licences.
  4. Dans le menu Select an action, sélectionnez Unhide licenses.

Renvoyer les licences

Lorsque vous renvoyez des licences, celle-ci sont replacées dans le regroupement de licences. Ces licences peuvent ensuite être allouées quelle que soit la quantité souhaitée et à tout moment.

  1. Sélectionnez les licences que vous souhaitez renvoyer.
  2. Dans le menu Select an action, sélectionnez Return allocations.

Mise à niveau de l’édition de licence

Si vous êtes éligible à une mise à niveau de version dans le cadre de votre maintenance, vous pouvez obtenir une nouvelle licence et l’ajouter au serveur de licences.

  1. Au bas de la page d’accueil, sélectionnez Upgrade my licenses.
  2. Suivez les options et les instructions du site pour mettre à niveau vos licences d’édition de produit.
  3. Téléchargez ou commandez de nouveaux supports. Vous recevrez un e-mail vous invitant à retourner sur citrix.com pour allouer ou recevoir des licences de fonctionnalités supplémentaires.
  4. Connectez-vous à www.citrix.com pour attribuer vos licences, générer un fichier de licences, télécharger le fichier de licences sur votre serveur de licences et relire le fichier.

Gérer plusieurs licences

Vous pouvez appliquer des actions à plusieurs licences en même temps. Pour appliquer des actions à plusieurs licences, notez les considérations suivantes :

  • Vous pouvez appliquer certaines actions uniquement aux licences possédant les mêmes attributs. Par exemple, vous ne pouvez allouer que des licences ayant le même type de liaison. Un message d’erreur s’affiche lorsque vous sélectionnez des licences qui ne sont pas compatibles avec une action en bloc.

    La première licence que vous sélectionnez sert de base aux sélections suivantes à des fins de compatibilité.

  • Si vous sélectionnez des licences pour lesquelles une action ne peut être appliquée à toutes ces licences, certaines actions peuvent être désactivées ou non affichées, et un message peut apparaître. Par exemple, si vous sélectionner deux licences, une qui a été allouée et une autre qui n’a pas été allouée, un message apparaît. Le message indique que l’action ne peut s’appliquer qu’aux licences allouées.

Installer des licences

  1. Sélectionnez Download license files et enregistrez le fichier dans un répertoire.
  2. Sur le serveur de licences, copiez le fichier de licences à partir du répertoire dans lequel il a été enregistré sur le dossier MyFiles.

    Assurez-vous que le fichier de licences conserve l’extension du nom de fichier .lic (en minuscule). Certains processus de copie ne reconnaissent pas le type de fichier de cette extension et ajoutent une extension de fichier .txt lors de la copie. Vous ne pouvez pas importer de fichiers de licences avec une extension de nom de fichier incorrecte.

    • C:\Program Files\Citrix\Licensing\MyFiles sur un ordinateur 32 bits
    • C:\Program Files (x86)\Citrix\Licensing\MyFiles sur un ordinateur 64 bits
  3. À l’invite de commande, accédez à :

    • C:\Program Files\Citrix\Licensing\LS sur un ordinateur 32 bits
    • C:\Program Files (x86)\Citrix\Licensing\LS sur un ordinateur 64 bits

    et entrez la commande suivante : lmreread -c @localhost -all

Rechercher des licences

  • Dans le menu Find a license by, sélectionnez le critère de recherche, saisissez le texte de recherche et sélectionnez Search.

    Vous pouvez sélectionner Show advanced search options pour affiner davantage votre recherche.

Filtrer les licences

Utilisez le menu Filter by pour limiter votre liste aux licences expirées, aux nouvelles licences, aux allocations disponibles ou aux licences d’essai.

  • Dans le menu Filter by, choisissez la façon dont vous souhaitez filtrer vos résultats.

Créer un rapport sur les licences produit

  1. Sélectionnez les licences que vous souhaitez inclure dans le rapport.
  2. Cliquez sur le lien Export to Excel (.CSV) en bas de l’écran.
  3. Enregistrez le fichier.