App Layering

系统要求

App Layering 虚拟设备在本文中列出的受支持的虚拟机管理程序上运行。设备是在安装过程中部署企业层管理器 (ELM) 的地方。

要使用设备的管理控制台,您需要一个支持微软 Silverlight 的浏览器。

您可以创建要在几乎任何 Hypervisor 或 Provisioning 软件上使用的层。为了获得最佳用户体验,请将图像发布到支持的平台。

设备的虚拟机管理程序

企业层管理器 (ELM) 在部署到受支持的 Hypervisor 的虚拟设备上运行。

  • Citrix Hypervisor 版本 6.5、7.0—7.6、8.0、8.1、8.2
  • Azure Resource Manager
  • Google Cloud
  • 在 Windows Server 2012 R2、Windows Server 2016 或 Windows Server 2019 上运行的 Microsoft Hyper-V
    • 使用卸载合成功能时,支持第 2 代虚拟机。
  • Nutanix Acropolis Hypervisor (AHV) 版本 5.0–5.5(仅限 Prism Element)、5.8、5.9、5.10、5.11、5.15(长期支持版本)、5.16、5.17、5.18、5.19、5.20(长期支持版本)
  • vSphere vCenter,版本 5.5、6.0、6.5、6.7、7.0
    • 使用卸载合成功能时,vSphere vCenter 6.7 和 7.0 版支持第 2 代虚拟机

网络文件共享协议

  • 服务器消息块 (SMB)

网络连接

  • Citrix 建议在设备和文件共享之间建立 10 Gbps 的连接。

目录服务

  • Microsoft Active Directory

管理控制台的互联网浏览器

管理控制台支持使用微软 Silverlight 4.0 或更高版本的以下 Web 浏览器:

  • Internet Explorer 11
  • Firefox 45 - 52.9

分层映像的操作系统

您可以将以下版本的 Windows 操作系统分层。Windows 应用商店应用程序适用于所有受支持的 Windows 版本。

重要:

部署 完全用户层 (用于持久保存用户数据和设置)需要 Windows 7 64 位或 Windows 10 64 位环境。

  • Windows Server 操作系统-支持以下会话主机版本:

    • Windows Server 2019,64 位(标准版和数据中心版)
    • Windows Server 2016,64 位(标准版和数据中心版)
    • Windows Server 2012 R2,64 位(标准版和数据中心版)
    • Windows Server 2008 R2,64 位(标准版和数据中心版)
  • 桌面操作系统-支持以下桌面版本:

    • Windows 10 版本 21H1。在 2107 或更高版本的 App Layering 中支持。
    • Windows 10,版本 20H2. 在 2011 或更高版本的 App Layering 中支持。

      注意 如果将操作系统层从早期版本升级到 Windows 10 20H2,请直接升级到构建 19042.630 或更高版本。升级到 2020 年 11 月 16 日之前发布的 Windows 10 20H2 版本可能会导致映像部署不一致。

    • Windows 10,64 位,版本 2004、1909、1903、1809、1803、1709、1703 和 1607(教育版和企业版)
    • Windows 10,64 位,版本 2004、1909、1903、1809、1803(专业版)
    • Windows 7 64 位(Enterprise 和 Professional Edition)
    • Windows 7 32 位(Enterprise 和 Professional Edition)

App Layering 支持基本美国英语 Windows 操作系统的单字节语言包。当操作系统层部署在支持的版本上时,它支持多字节语言包:

  • Citrix Hypervisor
  • VMware vSphere
  • Microsoft Hyper-V

在将操作系统导入操作系统到操作系统层之前,请在操作系统计算机上安装语言包。操作系统层 版本 上安装的语言包无法正常工作。

用户层

以下平台支持完整用户层:

  • 操作系统:
    • Windows 7 64 位
    • Windows 10 64 位
  • 发布平台:
    • Citrix Virtual Desktops
    • VMware Horizon View

分层图像

分层图像是由层组成的可启动图像。每个分层映像都包含一个操作系统层、一个平台层和任意数量的应用程序层。您可以将分层映像发布到以下平台:

  • 为 Citrix Hypervisor 创建计算机(以前为 XenServer 的 Citrix MCS)
  • 适用于 Azure 和 Azure 政府的计算机创建
  • 为 vSphere 创建计算机
  • 为 Nutanix AHV 创建计算机
  • Citrix Provisioning,版本 2106、2012、2009、2006、2003、1912、1909、1906、1903、1811、7.15 CU6、1912 CU3 和 Provisioning Services (PVS) 版本 7.6 LTSR

    备注:

    • Citrix 向 Provisioning 存储建议使用 10 Gbps 的网络速度。
    • 不再支持 Provisioning Services (PVS) 版本 7.1、7.7—7.9、7.11—7.18 和 1808 版。

设备和连接器在以下环境中运行:

  • Citrix Virtual Apps and Desktops,版本 7:1808、1811、1903、1906、1909、1912(LTSR、CU1-CU3)、2003、2006、2009、2012、2103、2106
  • Citrix XenApp 和 XenDesktop,版本 6.5、7.0—7.18 和 7.15 版(LTSR,CU3-CU7)
  • 适用于 Azure 的 Citrix Virtual Apps and Desktops Essentials
  • Citrix Hypervisor(以前称为 Citrix XenServer)
  • Google Cloud
  • Microsoft Azure
  • Microsoft Hyper-V
  • Nutanix Acropolis
  • VMware vSphere
  • VMware Horizon View 版本 6.x、7.0.x、7.1.x、7.2、7.3、7.4、7.6、7.8、7.9、7.11、7.13、8.2

桌面 Provisioning 和应用程序交付

只要 启用弹性分层或用户层(完整或 Office 365),就可以将分层映像用于持久桌面。

要启用用户层或弹性层, 必须使用非持久性计算机

注意:

弹性分层不支持视图角色管理。