适用于 iOS 的 Citrix Workspace 应用程序

安装必备条件

系统要求和兼容性

设备要求

  • 适用于 iOS 的 Citrix Workspace 应用程序 21.9.1 或更高版本支持 iOS 15 和 iPadOS 15。
  • 适用于 iOS 的 Citrix Workspace 应用程序 20.9.0 或更高版本支持 iOS 14 和 iPadOS 14。
  • 适用于 iOS 的 Citrix Workspace 应用程序 19.9.0 或更高版本支持 iOS 13 和 iPadOS 13。
  • 此软件更新已在以下设备上通过验证:
    • iPhone 7x 各型号、iPhone 8x 各型号和仅 iPhone X 型号。
    • 除不受支持的 iPad 1 和 iPad 2 以外的所有 iPad 型号(包括 iPad Pro)。
  • 外部显示器支持
    • iPhone - 受 iOS 支持。
    • iPad - 与 iOS 支持的对象相同(不使用整个屏幕)。

服务器要求

验证您是否已为服务器安装了所有最新的修补程序。

  • Citrix Workspace 应用程序支持使用 Citrix StoreFront 和 Web Interface 连接到虚拟桌面和应用程序。

    StoreFront:

    • StoreFront 3.6 或更高版本(推荐使用)。Citrix Workspace 应用程序已通过最新版本的 StoreFront 的验证;以前支持的版本包括 StoreFront 2.6 或更高版本。

      用于直接访问 StoreFront 应用商店。Citrix Workspace 应用程序还支持早期版本的 StoreFront。

      注意:

      在 XenApp 和 XenDesktop 7.8 中,Citrix 引入了对 Framehawk 虚拟通道和 3D Pro 的支持。此功能已扩展到 Citrix Workspace 应用程序。

    • 配置了适用于 Web 的 Workspace 站点的 StoreFront

      用于从 Safari Web 浏览器访问 StoreFront 应用商店。用户必须使用浏览器手动打开 ICA 文件。有关此部署的限制,请参阅 StoreFront 文档。

    Web Interface:

    • 配置了 Web Interface 站点的 Web Interface 5.4

    • 配置了 XenApp 和 XenDesktop 站点的 Web Interface 5.4

    • Citrix Gateway 上的 Web Interface(基于浏览器的访问仅限使用 Safari)

      启用 Citrix Gateway 提供的重写策略。

  • Citrix Virtual Apps and DesktopsXenAppXenDesktop(以下任意产品):

    • Citrix Virtual Apps and Desktops 7 1808 或更高版本
    • Citrix XenDesktop 7.x 或更高版本
    • Citrix XenApp 7.5 或更高版本

连接、证书和身份验证

对于与 StoreFront 的连接,Citrix Workspace 应用程序支持以下身份验证方法:

  适用于 Web 的 Workspace(使用浏览器) StoreFront 服务站点(本机) StoreFront XenApp 和 XenDesktop 站点(本机) Citrix Gateway 到适用于 Web 的 Workspace(浏览器) Citrix Gateway 到 StoreFront 服务站点(本机)
匿名      
是* 是*
域直通    
安全令牌       是* 是*
双重身份验证(域 + 安全令牌)       是* 是*
SMS       是*
智能卡     是* 是*
用户证书       是(Citrix Gateway 插件) 是(Citrix Gateway 插件)

*仅适用于:

  • 适用于 Web 站点的 Workspace
  • 包含 Citrix Gateway 的部署,而无论设备上是否已安装关联的插件。

对于与 Web Interface 5.4 的连接,Citrix Workspace 应用程序支持以下身份验证方法:

注意:

Web Interface 使用术语“显式”表示域和安全令牌身份验证。

  Web Interface(浏览器) Web Interface XenApp 和 XenDesktop 站点 Citrix Gateway 到 Web Interface(浏览器) Citrix Gateway 到 Web Interface XenApp 和 XenDesktop 站点
匿名      
是*  
域直通      
安全令牌     是*  
双重身份验证(域 + 安全令牌)     是*  
SMS     是*  
智能卡        
用户证书     是(需要 Citrix Gateway 插件)  

证书

专用(自签名)证书

可以使用 Citrix Workspace 应用程序成功访问 Citrix 资源:

  • 在远程网关上安装专用证书时。
  • 当设备上安装了组织的证书颁发机构颁发的根证书时。

注意:

如果在连接时无法验证远程网关的证书(因为本地密钥库中不包含根证书),系统会显示一条警告,指出该证书不受信任。如果用户选择忽略该警告而继续进行操作,系统将显示应用程序列表,但应用程序无法启动。

手动安装的证书

在 iOS 10.3 及更高版本中,手动安装的配置文件中包含的证书不会自动信任 SSL。在 iOS 中信任手动安装的证书配置文件

  1. 请确保您已在设备上安装了证书配置文件。
  2. 转至设置 > 常规 > 关于 > 证书信任设置

    通过配置文件安装的每个根证书将在 Enable Full Trust For Root Certificates(启用对根证书的完全信任)下显示。

  3. 可以打开或关闭每个根证书。

将根证书导入到 iPad 和 iPhone 设备中

可以获取证书颁发者的根证书,并通过电子邮件将其发送到设备上已配置的电子邮件帐户。单击附件时,系统会要求您导入根证书。

通配符证书

通配符证书用于代替同一域内任意服务器的各个服务器证书。Citrix Workspace 应用程序支持通配符证书。

中间证书与 Citrix Gateway

您的证书链中包含中间证书时,必须将该中间证书附加到 Citrix Gateway(或 Access Gateway)服务器证书。此外,对于 Access Gateway 安装,请参阅 Citrix ADC 文档中与您的要求匹配的安装、链接和更新证书

Secure Gateway 配置(仅通过 Web Interface 进行的配置)和所有受支持的 Access Gateway 配置均支持 RSA SecurID 身份验证。

Citrix Workspace 应用程序支持 Access Gateway 所支持的所有身份验证方法。

联合服务器证书验证策略

Citrix Workspace 应用程序的各版本具有更加严格的服务器证书验证策略。

重要

安装 Citrix Workspace 应用程序之前,请确认服务器或网关上的证书已按此处所述正确配置。以下情况下连接可能会失败:

  • 服务器或网关配置包括错误的根证书
  • 服务器或网关配置不包括所有中间证书
  • 服务器或网关配置包括过期或无效的中间证书
  • 服务器或网关配置包括交叉签名的中间证书

验证服务器证书时,Citrix Workspace 应用程序现在会使用服务器(或网关)提供的所有证书。与在早期版本的 Citrix Workspace 应用程序中相同,也会检查证书是否可信。如果证书不全部可信,连接将失败。

与 Web 浏览器中的证书策略相比,此策略更加严格。许多 Web 浏览器都包括大量信任的根证书。

必须为服务器(或网关)配置一组正确的证书。一组不正确的证书可能会导致 Citrix Workspace 应用程序连接失败。

假定为网关配置了以下有效的证书。建议需要更加严格的验证的客户使用此配置,方式是准确确定 Citrix Workspace 应用程序使用的根证书:

  • 服务器证书示例
  • 示例中间证书
  • 示例根证书

然后,Citrix Workspace 应用程序将检查所有这些证书是否都有效。Citrix Workspace 应用程序还会验证示例根证书是否已受信任。

备注:

  • 如果 Citrix Workspace 应用程序不信任示例根证书,连接将失败。
  • 某些证书颁发机构具有多个根证书。如果您需要使用更加严格的验证方法,请确保您的配置使用恰当的根证书。

例如,当前有两个证书:

  • DigiCert 或 GTE CyberTrust Global Root

  • DigiCert Baltimore Root 或 Baltimore CyberTrust Root

这些证书可以验证相同的服务器证书。在某些用户设备上,这两个根证书都可用。在其他设备上,只有一个可用(DigiCert Baltimore RootBaltimore CyberTrust Root)。

如果您在网关上配置了 GTE CyberTrust Global Root,这些用户设备上的 Citrix Workspace 应用程序连接将失败。请参阅证书颁发机构的文档以确定必须使用的根证书。另请注意,根证书最终会过期,所有证书也是如此。

Citrix Workspace 应用程序将使用这两个证书。该应用程序将搜索用户设备上的根证书。如果该应用程序发现一个正确验证的根证书并且也可信(例如示例根证书),连接将成功。否则,连接将失败。

此配置提供 Citrix Workspace 应用程序所需的中间证书,但是还允许 Citrix Workspace 应用程序选择任何有效的可信根证书。

现在假定为网关配置了以下证书:

  • 服务器证书示例
  • 示例中间证书
  • 错误的根证书

Web 浏览器可能会忽略错误的根证书。但是,Citrix Workspace 应用程序不会忽略错误的根证书,因此连接将失败。

某些证书颁发机构使用多个中间证书。在这种情况下,通常为网关配置所有中间证书(但不配置根证书),例如:

  • 服务器证书示例
  • 示例中间证书 1
  • 示例中间证书 2

重要

某些证书颁发机构使用交叉签名的中间证书。此类证书适用于以下情况:存在多个根证书,并且在使用更高版本的根证书的同时,仍在使用早期版本的根证书。在此类情况下,至少存在两个中间证书。

例如,早期版本的根证书 Class 3 Public Primary Certification Authority 具有相应的交叉签名的中间证书 Verisign Class 3 Public Primary Certification Authority - G5。但是,相应的较高版本的根证书 Verisign Class 3 Public Primary Certification Authority - G5 也可用,该版本将替换 Class 3 Public Primary Certification Authority。更高版本的根证书不使用交叉签名的中间证书。

注意

交叉签名的中间证书和根证书的使用者名称相同(颁发对象),但交叉签名的中间证书具有不同的颁发者名称(颁发者)。颁发者名称将交叉签名的中间证书与普通的中间证书(例如示例中间证书 2)区分开来。

通常推荐使用此配置(忽略根证书和交叉签名的中间证书):

  • 服务器证书示例
  • 示例中间证书

请避免将网关配置为使用交叉签名的中间证书,因为 Citrix Workspace 应用程序选择更早版本的根证书:

  • 服务器证书示例
  • 示例中间证书
  • 示例交叉签名中间证书 [不推荐]

不建议仅为网关配置服务器证书:

  • 服务器证书示例

在此类情况下,如果 Citrix Workspace 应用程序找不到所有中间证书,连接将失败。

安装必备条件