Session Recording

打开并播放录制件

打开录制件

您可以通过以下三种方式在会话录音播放器中打开会话录音:

  • 使用会话录音播放器执行搜索。符合搜索条件的录制会话将显示在搜索结果区域中。
  • 直接从本地磁盘驱动器或共享驱动器访问录制会话文件。
  • 从收藏夹文件夹访问录制会话文件。

当您打开未带数字签名的文件时,将显示警告消息。该消息指出未验证文件的来源和完整性。如果您确信文件的完整性,请在警告窗口中单击以打开文件。

会话录音播放器在播放录制会话之前会检查 Citrix Workspace™ 应用版本。如果播放器不支持 Citrix Workspace 应用版本,则会返回错误。要消除此错误,请在会话录音服务器属性中选择跳过 Citrix Workspace 应用版本检查

跳过 Citrix Workspace 应用程序的版本检查

注意:

会话录音的管理员日志记录功能允许您将会话录音播放器中的录制件下载记录到日志中。有关详细信息,请参阅管理员日志记录

在搜索结果区域中打开录制件

  1. 登录到安装了会话录音播放器的计算机。
  2. 开始菜单中,选择会话录音播放器
  3. 执行搜索。
  4. 如果搜索结果区域不可见,请在“工作区”窗格中选择 搜索结果
  5. 在搜索结果区域中,选择要播放的会话。
  6. 执行以下任一操作:
    • 双击该会话记录。
    • 右键单击并选择 播放
    • 会话录制播放器 菜单栏中,选择 播放 > 播放

通过访问文件打开录制件

录制文件名称以 i_ 开头,后跟唯一的字母数字文件 ID,然后是 .icl.icle 扩展名。.icl 扩展名表示未应用播放保护的录制件。.icle 扩展名表示已应用播放保护的录制件。录制的会话文件保存在一个文件夹中,该文件夹包含会话录制日期。例如,2014 年 12 月 22 日录制的会话文件保存在文件夹路径 2014\12\22 中。

  1. 请登录到安装了会话录制播放器的工作站。
  2. 开始 菜单中,选择 会话录制播放器
  3. 执行以下任一操作:
    • 会话录制播放器 菜单栏中,选择 文件 > 打开 并浏览文件。
    • 使用 Windows 资源管理器,导航到文件并将文件拖到 播放器 窗口。
    • 使用 Windows 资源管理器,导航到文件并双击该文件。
    • 如果在“工作区”窗格中创建了收藏夹,请选择 收藏夹,然后以与从搜索结果区域打开文件相同的方式从收藏夹区域打开文件。

使用收藏夹

创建收藏夹文件夹可让您快速访问经常查看的录制件。这些收藏夹文件夹引用录制的会话文件,这些文件存储在您的工作站或网络驱动器上。您可以将这些文件导入和导出到其他工作站,并与其他 Session Recording 播放器用户共享这些文件夹。

注意:

只有对 Session Recording 播放器具有访问权限的用户才能下载与收藏夹文件夹关联的录制会话文件。请联系您的 Session Recording 管理员以获取访问权限。

要创建收藏夹子文件夹:

  1. 登录到安装了 Session Recording 播放器的工作站。
  2. 开始菜单中,选择会话录制播放器
  3. Session Recording Player窗口中,在“工作区”窗格中选择收藏夹文件夹。
  4. 从菜单栏中,选择文件 > 文件夹 > 新建文件夹。新文件夹将显示在收藏夹文件夹下。
  5. 键入文件夹名称,然后按 Enter 或单击任意位置以接受新名称。

使用文件 > 文件夹菜单中显示的其他选项可删除、重命名、移动、复制、导入和导出文件夹。

播放录制件

在 Session Recording 播放器中打开录制会话后,可以使用以下方法浏览录制会话:

  • 使用播放器控件播放、停止、暂停以及提高或降低播放速度。
  • 使用查找滑块向前或向后移动。

您还可以通过转到插入的标记和自定义事件来浏览录制的会话。

注意:

  • 在播放录制的会话期间,可能会出现第二个鼠标指针。第二个指针出现在录制中用户在 Internet Explorer 中导航并单击了最初大于屏幕但被 Internet Explorer 自动缩小的图像时。会话期间只出现一个指针,但在播放期间可能会出现两个。
  • 此版本的会话录制不支持 SpeedScreen 多媒体加速和 Flash 质量调整策略设置。启用此选项时,播放会显示一个黑色方块。
  • 当您以高于或等于 4096 x 4096 的分辨率录制会话时,录制外观中可能会出现碎片。

使用播放器控件

您可以单击播放器窗口下方的播放器控件,也可以通过从“会话录制播放器”菜单栏中选择“播放”来访问它们。

播放器控件 功能
播放按钮 播放选定的会话文件。
暂停按钮 暂停播放。
停止按钮 停止播放。如果单击“停止”,然后单击“播放”,录制将从文件开头重新开始。
减慢播放速度(/zh-cn/session-recording/2203-ltsr/media/ps-sa-icon-control-speed-backwards.png) 将当前播放速度减半,最低可达正常速度的四分之一。
加快播放速度(/zh-cn/session-recording/2203-ltsr/media/ps-sa-icon-control-button-speed-forward.png) 将当前播放速度加倍,最高可达正常速度的 32 倍。

使用进度滑块

使用播放器窗口下方的进度滑块,跳转到录制会话中的不同位置。您可以将进度滑块拖动到录制中要查看的点,或单击滑块条上的任意位置以移动到该位置。

您还可以使用以下键盘按键控制进度滑块:

键盘按键 功能
主页 跳转到开头。
End 跳转到结尾。
右箭头 向前跳转五秒。
左箭头 向后跳转五秒。
向下滚动鼠标滚轮一格 向前跳转 15 秒。
向上滚动鼠标滚轮一格 向后跳转 15 秒。
Ctrl + 右箭头 向前跳转 30 秒。
Ctrl + 左箭头 向后跳转 30 秒。
下一页 向前跳转一分钟。
上一页 向后跳转一分钟。
Ctrl + 向下滚动鼠标滚轮一格 向前跳转 90 秒。
Ctrl + 向上滚动鼠标滚轮一格 向后跳转 90 秒。
Ctrl + 下翻页 向前跳转六分钟。
Ctrl + 上翻页 向后跳转六分钟。

要调整跳转滑块的速度:从“会话录制播放器”菜单栏中,选择“工具 > 选项 > 播放器”,然后拖动滑块以增加或减少跳转响应时间。更快的响应时间需要更多内存。响应速度可能会因录制文件的大小和计算机硬件而异。

如何更改播放速度

您可以将播放速度设置为从正常播放速度的四分之一到正常播放速度的 32 倍的指数增量。

  1. 登录到安装有会话录制播放器的工作站上。
  2. 从“开始”菜单中,选择“会话录制播放器”。
  3. 从“会话录制播放器”菜单栏中,选择“播放 > 播放速度”。
  4. 选择一个速度选项。

速度会立即调整。指示指数速率的文本会短暂地以绿色显示在播放器窗口的下部。

突出显示录制会话的空闲时段

录制会话的空闲时段是指没有发生任何操作的部分。会话录制播放器可以在播放期间突出显示录制会话的空闲时段。此选项默认处于启用状态。有关详细信息,请参阅突出显示空闲时段

跳过没有发生操作的空间

快速审阅模式允许您设置播放器跳过录制会话中没有发生操作的部分。此设置可节省播放查看时间。但是,它不会跳过动画序列,例如动画鼠标指针、闪烁的光标或带有秒针移动的显示时钟。

  1. 请登录到已安装了会话录制播放器的工作站。
  2. 开始菜单中,选择会话录制播放器
  3. 会话录制播放器菜单栏中,选择播放 > 快速审阅模式

此选项可进行切换。每次选择此选项时,其状态都会在播放器窗口中短暂显示为绿色。

更改播放显示方式

您可以执行以下操作来更改录制会话在播放器窗口中的显示方式:

  • 平移和缩放图像。
  • 将播放内容全屏显示
  • 在单独的窗口中显示播放器窗口
  • 在录制会话周围显示红色边框,以将其与播放器窗口背景区分开来。

将播放器窗口全屏显示

  1. 请登录到已安装了会话录制播放器的工作站。
  2. 从“开始”菜单中,选择“会话录音播放器”。
  3. 从“会话录音播放器”菜单栏中,选择“视图 > 播放器全屏”。
  4. 要返回原始大小,请按 EscF11

在单独的窗口中显示播放器窗口

  1. 登录并进入安装了会话录制播放器的工作站。
  2. 从“开始”菜单中,选择“会话录音播放器”。
  3. 从“会话录音播放器”菜单栏中,选择“视图 > 在单独的窗口中播放器”。将出现一个新窗口,其中包含播放器窗口。您可以拖动并调整该窗口的大小。
  4. 要将播放器窗口嵌入主窗口中,请选择“视图 > 在单独的窗口中播放器”,或按 F10

缩放会话播放以适应播放器窗口

  1. 登录并进入安装了会话录制播放器的工作站。
  2. 从“开始”菜单中,选择“会话录音播放器”。
  3. 从“会话录音播放器”菜单栏中,选择“播放 > 平移和缩放 > 适应大小”。
    • 适应大小(快速渲染)可在提供良好质量的同时缩小图像。图像的绘制速度比使用“高质量”选项更快,但图像和文本不清晰。如果您在使用“高质量”模式时遇到性能问题,请使用此选项。
    • 适应大小(高质量)可在提供高质量的同时缩小图像。使用此选项可能会导致图像的绘制速度比“快速渲染”选项慢。

平移图像

  1. 登录到在其中安装了会话录制播放器的工作站。
  2. 从“开始”菜单中,选择“会话录制播放器”。
  3. 从“会话录制播放器”菜单栏中,选择“播放 > 平移和缩放 > 平移”。指针变为手形。屏幕的小型表示形式将显示在播放器窗口的右上角。
  4. 拖动图像。小型表示形式指示您在图像中的位置。
  5. 要停止平移,请选择一个缩放选项。

在会话录制周围显示红色边框

  1. 登录到在其中安装了会话录制播放器的工作站。
  2. 从“开始”菜单中,选择“会话录制播放器”。
  3. 从“会话录制播放器”菜单栏中,选择“工具 > 选项 > 播放器”。
  4. 选择“在会话录制周围显示边框”复选框。 如果未选中“在会话录制周围显示边框”复选框,您可以通过在指针位于播放器窗口中时单击并按住鼠标左键来暂时查看红色边框。