Systemanforderungen und Kompatibilität

Anforderungen

  • 1 GB RAM
  • Anforderungen für .NET Framework
    • Das Self-Service-Plug-In erfordert .NET 4.6.2. Sie können die Apps und Desktops über die Benutzeroberfläche der Workspace-App für Windows oder über die Befehlszeile abonnieren und starten. Weitere Informationen finden Sie unter Verwenden von Befehlszeilenparametern.
  • Aktuelle Version von Microsoft Visual C++ Redistributable.

    Hinweis:

    Citrix empfiehlt, die neueste Version von Microsoft Visual C++ Redistributable zu verwenden. Andernfalls wird während eines Upgrades möglicherweise eine Aufforderung zum Neustart angezeigt.

    Ab Version 1904 enthält das Citrix Workspace App-Installationspaket keine einzelnen Microsoft Visual C++ Redistributable-Binärdateien, sondern das Microsoft Visual C++ Redistributable-Installationsprogramm. Während der Installation überprüft das Citrix Workspace-App-Installationsprogramm, ob das Microsoft Visual C++ Redistributable-Paket auf dem System vorhanden ist und installiert es gegebenenfalls. Für die Citrix Workspace-App Version 1912 und höher ist Microsoft Visual C++ Redistributable Version 14.24.28127.4 oder höher erforderlich.

    Hinweis:

    Versuche, die Citrix Workspace-App mit Nicht-Administratorrechten auf einem System ohne Microsoft Visual C++ Redistributable-Paket zu installieren, schlagen möglicherweise fehl.

    Nur ein Administrator kann das Microsoft Visual C++ Redistributable-Paket installieren.

    Informationen zur Behebung von Problemen mit der Installation von .NET Framework oder Microsoft Visual C++ Redistributable finden Sie im Knowledge Center-Artikel CTX250044.

Kompatibilitätsmatrix

Die Citrix Workspace-App ist auch kompatibel mit allen derzeit unterstützten Versionen von Citrix Virtual Apps and Desktops und Citrix DaaS (ehemals Citrix Virtual Apps and Desktops Service) und Citrix Gateway, die in der Citrix Product Lifecycle Matrix aufgeführt sind.

Die Citrix Workspace-App ist mit folgenden Windows-Betriebssystemen kompatibel:

Hinweis:

Das Citrix Gateway Plug-In für die Endpunktanalyse (EPA) wird für Citrix Workspace unterstützt. In der nativen Citrix Workspace-App wird es nur unterstützt, wenn die mehrstufige Authentifizierung verwendet wird. Weitere Informationen finden Sie unter Konfigurieren des EPA-Scans für die Vor- und Nachauthentifizierung als Faktor in der mehrstufigen Authentifizierung (nFactor) in der Dokumentation zu Citrix ADC.

Betriebssystem
Windows 10 (32-Bit- und 64-Bit-Enterprise Editionen) Weitere Informationen zum kompatiblen Windows 10-Betriebssystem finden Sie unter Kompatibilität von Windows 10 mit der Citrix Workspace-App für Windows.
Windows 10 32-Bit- und 64-Bit-Pro-Editionen (unterstützt ab Citrix Workspace-App 1912 LTSR CU5 für Windows)
Windows 8.1, 32-Bit- und 64-Bit-Editionen (inkl. Embedded Edition)
Windows 7, 32-Bit- und 64-Bit-Editionen (Erweitertes Sicherheitsupdate – ESU)
Windows 7 Embedded Standard (Erweitertes Sicherheitsupdate - ESU)
Windows Thin PC
Windows Server 2016
Windows Server 2012 R2, Standard und Datacenter Edition
Windows Server 2019
Windows Server 2008 R2
Windows 10 Enterprise LTSC 2019
Windows 10 Enterprise 2016 LTSB 1607

Kompatibilität von Windows 10 mit der Citrix Workspace-App für Windows

Hinweis:

  • Die Installation von Citrix-Softwareversionen, die vor der Version für den halbjährlichen Kanal veröffentlicht wurden, wird nicht empfohlen. Kunden, die diese Versionen dennoch installieren, müssen im Supportfall prüfen, ob ihr Problem nicht durch ein Upgrade auf eine neuere Citrix-Softwareversion behoben werden kann (sofern verfügbar) und diese gegebenenfalls installieren.
  • Sobald eine Windows 10-Version ihr Dienstende erreicht, wird sie von Microsoft nicht länger unterstützt. Citrix unterstützt die eigene Software nur für Betriebssysteme, die vom Hersteller unterstützt werden. Weitere Informationen zum Dienstende von Windows 10-Versionen finden Sie im Informationsblatt zum Lebenszyklus von Windows.
Version der Citrix Workspace-App Version der Windows 10 Enterprise Edition Buildnummer
1912 CU7 und höher LTSC 2021 19044
1912 CU6 und höher 21H2 19044
1912 CU6 und höher 21H2 19044
1912 CU5 und höher 21H1 19043.1165
1912 CU2 und höher 20H2 19042.685
1912 CU1 und höher 2004 19041.329
1911 und höher 1909 18363.418
1909 und höher 1903 18362.116
1812 und höher 1809 17763.107
1808 und höher 10 1803 17134.376

Unterstützte Browser

Eine Liste der unterstützten Browser finden Sie unter Zugriff auf Stores über Citrix Receiver für Web-Sites.

Betriebssystemmatrix

Auf Touchgeräten unterstützte Betriebssysteme
Windows 10
Windows 8
Windows 7
Auf VDAs unterstützte Betriebssysteme
Windows 10
Windows 8
Windows 7
Windows 2012 R2
Windows Server 2016
Windows 2008 R2

Überprüfen auf freien Speicherplatz

Die folgende Tabelle enthält Informationen zum Speicherplatz, der für die Installation der Citrix Workspace-App für Windows erforderlich ist:

Installationstyp Erforderlicher Speicherplatz
Neuinstallation 572 MB
Upgrade 350 MB

Die Citrix Workspace-App prüft, ob genügend Speicherplatz zum Abschließen der Installation verfügbar ist. Die Überprüfung erfolgt sowohl bei einer Neuinstallation als auch bei einem Upgrade.

Bei einer Neuinstallation wird die Installation abgebrochen, wenn nicht genügend Speicherplatz vorhanden ist, und das folgende Dialogfeld wird angezeigt.

alt_text

Bei einem Upgrade wird die Installation abgebrochen, wenn nicht genügend Speicherplatz vorhanden ist, und das folgende Dialogfeld wird angezeigt.

alt_text

Hinweis:

  • Das Installationsprogramm führt die Überprüfung des Speicherplatzes erst aus, wenn Sie das Installationspaket extrahiert haben.
  • Wenn bei einer automatischen Installation nicht genug Speicherplatz vorhanden ist, wird das Dialogfeld nicht angezeigt, aber die Fehlermeldung wird im Protokoll CTXInstall\_TrolleyExpress-\*.log aufgezeichnet.

Verbindungen, Zertifikate und Authentifizierung

Verbindungen

  • HTTP-Store
  • HTTPS-Store
  • Citrix Gateway 10.5 und höher
  • Webinterface 5.4

Zertifikate

Hinweis:

Die Citrix Workspace-App für Windows ist digital signiert. Die digitale Signatur ist mit einem Zeitstempel versehen. Das Zertifikat ist also auch nach Ablauf gültig.

  • Privat (selbstsigniert)
  • Stamm
  • Platzhalter
  • Zwischenzertifikat

Private (selbstsignierte) Zertifikate

Wenn ein privates Zertifikat auf dem Remotegateway installiert ist, muss das Stammzertifikat der Zertifizierungsstelle des Unternehmens auf dem Benutzergerät installiert sein, mit dem Sie auf Citrix-Ressourcen zugreifen.

Hinweis:

Wenn das Zertifikat des Remotegateways beim Herstellen der Verbindung nicht verifiziert werden kann (da das Stammzertifikat nicht im lokalen Schlüsselspeicher ist), wird eine Warnung über ein nicht vertrauenswürdiges Zertifikat angezeigt. Wenn der Benutzer weiterarbeitet, werden die Apps angezeigt, können jedoch nicht gestartet werden.

Stammzertifikate

Für in Domänen eingebundene Computer können Sie ZS-Zertifikate mit der administrativen Gruppenrichtlinienobjektvorlage verteilen und als vertrauenswürdig einstufen.

Für nicht domänengebundene Computer können Unternehmen ein benutzerdefiniertes Installationspaket erstellen und damit das Zertifikat der Zertifizierungsstelle verteilen und installieren. Wenden Sie sich bei Fragen an den Systemadministrator.

Zertifikate mit Platzhalterzeichen

Zertifikate mit Platzhalterzeichen werden für einen Server in derselben Domäne verwendet.

Die Citrix Workspace-App unterstützt Zertifikate mit Platzhalterzeichen. Diese dürfen jedoch nur gemäß den jeweils gültigen Sicherheitsrichtlinien verwendet werden. In der Praxis kann als Alternative zu Zertifikaten mit Platzhalterzeichen ein Zertifikat verwendet werden, das eine Liste der Servernamen mit der SAN-Erweiterung (Subject Alternative Name) enthält. Private und öffentliche Zertifizierungsstellen stellen diese Zertifikate aus.

Zwischenzertifikate

Wenn die Zertifikatkette ein Zwischenzertifikat enthält, muss das Zwischenzertifikat dem Citrix Gateway-Serverzertifikat angehängt werden. Weitere Informationen finden Sie unter Konfigurieren von Zwischenzertifikaten.

Authentifizierung

Authentifizierung bei StoreFront

  Workspace für Web über Browser StoreFront Services-Site (nativ) StoreFront, Citrix Virtual Apps and Desktops (nativ), Citrix DaaS Citrix Gateway bei Workspace für Web (Browser) Citrix Gateway bei StoreFront Services-Site (nativ)
Anonym Ja Ja      
Domäne Ja Ja Ja Ja* Ja*
Domänen-Passthrough Ja Ja Ja    
Sicherheitstoken       Ja* Ja*
Zweistufige Authentifizierung (Domäne mit Sicherheitstoken)       Ja* Ja*
SMS       Ja* Ja*
Smartcard Ja Ja   Ja Ja
Benutzerzertifikat       Ja (Citrix Gateway Plug-In) Ja (Citrix Gateway Plug-In)

* Mit oder ohne Citrix Gateway als installiertes Plug-In auf dem Gerät.

Hinweis:

Die Citrix Workspace-App unterstützt die zweistufige Authentifizierung (Domäne plus Sicherheitstoken) über Citrix Gateway beim nativen StoreFront-Service.

Authentifizierung beim Webinterface

Die Citrix Workspace-App unterstützt die folgenden Authentifizierungsmethoden (beim Webinterface wird die Authentifizierung mit Domäne und Sicherheitstoken als explizit bezeichnet):

  Webinterface (Browser) Webinterface-Site mit Citrix Gateway Citrix Gateway bei Webinterface (Browser) Citrix Gateway bei Webinterface-Site mit Citrix Gateway
Anonym Ja      
Domäne Ja Ja Ja*  
Domänen-Passthrough Ja Ja    
Sicherheitstoken     Ja*  
Zweistufige Authentifizierung (Domäne mit Sicherheitstoken)     Ja*  
SMS     Ja*  
Smartcard Ja Ja    
Benutzerzertifikat     Ja (Citrix Gateway Plug-In)  

* Nur in Bereitstellungen verfügbar, die Citrix Gateway mit oder ohne installiertem zugeordneten Plug-In auf dem Gerät enthalten.

Informationen zur Authentifizierung finden Sie hier:

Zertifikatsperrliste

Wenn Sie die Überprüfung von Zertifikatsperrlisten (CRL) aktivieren, überprüft die Citrix Workspace-App, ob das Zertifikat des Servers widerrufen wurde. Durch diese Überprüfung wird die kryptografische Authentifizierung für den Server sowie die allgemeine Sicherheit der TLS-Verbindung zwischen Benutzergerät und Server verbessert.

Sie können die Überprüfung der Zertifikatsperrlisten in mehreren Stufen einstellen. Sie können die Citrix Workspace-App beispielsweise so konfigurieren, dass nur die lokale Zertifikatsperrliste oder die lokale und die Netzwerkzertifikatsperrliste überprüft werden. Außerdem können Sie die Überprüfung der Zertifikatsperrliste so konfigurieren, dass Benutzer sich nur anmelden können, wenn alle Zertifikatsperrlisten überprüft wurden.

Schließen Sie die Citrix Workspace-App und alle Citrix Workspace-Komponenten, einschließlich Connection Center.

Weitere Informationen finden Sie unter TLS.

Systemanforderungen und Kompatibilität