Systemanforderungen

Beim Planen der Installation empfiehlt Citrix, mindestens 2 GB zusätzlichen RAM für StoreFront über die Anforderungen aller anderen, auf dem Server installierten Produkte hinaus zu veranschlagen. Der Abonnementstoredienst erfordert mindestens 5 MB Speicherplatz und pro 1000 Anwendungsabonnements sind zusätzlich ca. 8 MB Speicherplatz erforderlich. Alle anderen Hardwareelemente müssen die Mindestanforderungen an die Hardware für das installierte Betriebssystem erfüllen.

Hinweis:

Ein Upgrade auf die aktuelle Version von einer älteren Version, die jetzt das Ende des Lebenszyklus erreicht hat, wird nicht unterstützt. Weitere Informationen finden Sie unter CTX200356.

Nach entsprechenden Tests bietet Citrix nun Unterstützung für StoreFront auf folgenden Plattformen:

  • Windows Server 2019 (Standard- und Datacenter-Editionen)
  • Windows Server 2016 (Standard- und Datacenter-Editionen)
  • Windows Server 2012 R2 Datacenter- und Standard-Editionen

Das Aktualisieren des Betriebssystems eines Servers, auf dem StoreFront ausgeführt wird, wird nicht unterstützt. Citrix empfiehlt die Installation von StoreFront auf einer neuen Installation des Betriebssystems. Auf allen Servern in einer Multiserverbereitstellung muss die gleiche Betriebssystemversion mit den gleichen Gebietsschemaeinstellungen ausgeführt werden. StoreFront-Servergruppen mit unterschiedlichen Betriebssystemversionen und Gebietsschemas werden nicht unterstützt. Zwar kann eine Servergruppe maximal sechs Server enthalten, basierend auf Simulationen bieten Servergruppen mit mehr als drei Servern jedoch für die Kapazität keinen Vorteil. Alle Server in einer Servergruppe müssen sich am gleichen geografischen Standort befinden, um Leistungsverluste durch Latenz zu vermeiden.

Microsoft Internetinformationsdienste (IIS) und Microsoft .NET Framework sind auf dem Server erforderlich. Wenn eine dieser beiden erforderlichen Komponenten installiert, aber nicht aktiviert ist, aktiviert das StoreFront-Installationsprogramm die Komponente, bevor das Produkt installiert wird. Windows PowerShell und Microsoft Management Console, beides Standardkomponenten von Windows Server, müssen auf dem Webserver installiert werden, bevor Sie StoreFront installieren können. Der relative Pfad zu StoreFront in IIS muss auf allen Servern in einer Gruppe identisch sein.

Das StoreFront-Installationsprogramm fügt die erforderlichen IIS-Features hinzu. Liste der Anforderungen, falls Sie diese Features vorinstallieren:

Alle Plattformen:

  • Web-Static-Content
  • Web-Default-Doc
  • Web-Http-Errors
  • Web-Http-Redirect
  • Web-Http-Logging
  • Web-Mgmt-Console
  • Web-Scripting-Tools
  • Web-Windows-Auth
  • Web-Basic-Auth
  • Web-AppInit
  • Web-Asp-Net45
  • Net-Wcf-Tcp-PortSharing45

StoreFront verwendet die folgenden Ports für die Kommunikation. Stellen Sie sicher, dass Firewalls und andere Netzwerkgeräte den Zugriff auf diese Ports zulassen.

  • Die TCP-Ports 80 und 443 werden für die Kommunikation über HTTP bzw. HTTPS verwendet und müssen von innerhalb und außerhalb des Unternehmensnetzwerks zugänglich sein.
  • TCP-Port 808 wird für die Kommunikation zwischen StoreFront-Servern verwendet und muss daher zugänglich sein.
  • Ein nach dem Zufallsprinzip unter allen nicht reservierten Ports ausgewählter TCP-Port wird für die Kommunikation zwischen den StoreFront-Servern in eine Servergruppe verwendet. Wenn Sie StoreFront installieren, wird eine Windows-Firewallregel konfiguriert, die den Zugriff auf die ausführbare StoreFront-Datei gestattet. Da der Port jedoch nach dem Zufallsprinzip zugewiesen wird, müssen Sie sicherstellen, dass Firewalls oder andere Geräte im internen Netzwerk keinen Datenverkehr an einen der nicht zugewiesenen TCP-Ports blockieren.
  • TCP-Port 8008 wird (wo aktiviert) von der Citrix Workspace-App für HTML5 oder unterstützten Versionen von Citrix Receiver bzw. der Citrix Workspace-App für die Kommunikation zwischen lokalen Benutzern im internen Netzwerk und den Servern verwendet, die die Desktops und Anwendungen bereitstellen.

StoreFront unterstützt reine IPv6-Netzwerke und Umgebungen mit dualem Stapel (IPv4 und IPv6).

Anforderungen an die Infrastruktur

Citrix hat StoreFront mit den folgenden Citrix Produktversionen getestet und unterstüzt sie.

Anforderungen für den Citrix Server

In StoreFront-Stores aggregierte Desktops und Anwendungen von den folgenden Produkten.

  • Citrix Virtual Apps and Desktops 7 1906
  • Citrix Virtual Apps and Desktops 7 1903
  • Citrix Virtual Apps and Desktops 7 1811
  • Citrix Virtual Apps and Desktops 7 1808
  • XenApp und XenDesktop 7.18
  • XenApp und XenDesktop 7.17
  • XenApp und XenDesktop 7.15 LTSR
  • XenApp und XenDesktop 7.6 LTSR

Anforderungen für Citrix Gateway

Die folgenden Versionen von Citrix Gateway und NetScaler Gateway können verwendet werden, um Benutzern in öffentlichen Netzwerken Zugriff auf StoreFront zu geben.

  • Citrix Gateway 13.0
  • Citrix Gateway 12.1
  • NetScaler Gateway 12.0
  • NetScaler Gateway 11.x

Citrix Workspace-App für HTML5-Anforderungen

Wenn Sie beabsichtigen, Benutzern den Zugriff auf Desktops und Anwendungen mit der Citrix Workspace-App für HTML5 auf Receiver für Web-Sites zu ermöglichen, gelten die folgenden zusätzlichen Anforderungen.

Bei internen Netzwerkverbindungen bietet Citrix Workspace-App für HTML5 den Zugriff auf Desktops und Anwendungen der folgenden Produkte.

  • Citrix Virtual Apps and Desktops 7 1906
  • Citrix Virtual Apps and Desktops 7 1903
  • Citrix Virtual Apps and Desktops 7 1811
  • Citrix Virtual Apps and Desktops 7 1808
  • XenApp und XenDesktop 7.18
  • XenApp und XenDesktop 7.17
  • XenApp und XenDesktop 7.15 LTSR
  • XenApp und XenDesktop 7.6 LTSR

Hinweis:

Die Citrix Workspace-App für HTML5 startet Desktops und Apps über interne Netzwerkverbindungen nur, wenn sichere Verbindungen zu den VDAs konfiguriert wurden, auf denen die Ressourcen gehostet werden. HTTP-Verbindungen mit VDAs, die die Apps und Desktops hosten, können nicht verwendet werden.

Remotebenutzern außerhalb des Unternehmensnetzwerks ermöglicht die Citrix Workspace-App für HTML5 den Zugriff auf Desktops und Anwendungen über die folgenden Citrix Gateway- und NetScaler Gateway-Versionen.

  • Citrix Gateway 13.0
  • Citrix Gateway 12.1
  • NetScaler Gateway 12.0
  • NetScaler Gateway 11.x

Bei Verbindungen über Citrix Gateway bietet Citrix Workspace-App für HTML5 den Zugriff auf Desktops und Anwendungen folgender Produkte.

  • Citrix Virtual Apps and Desktops 7 1906
  • Citrix Virtual Apps and Desktops 7 1903
  • Citrix Virtual Apps and Desktops 7 1811
  • Citrix Virtual Apps and Desktops 7 1808
  • XenApp und XenDesktop 7.18
  • XenApp und XenDesktop 7.17
  • XenApp und XenDesktop 7.15 LTSR
  • XenApp und XenDesktop 7.6 LTSR

Anforderungen für Benutzergeräte

StoreFront bietet Benutzern verschiedene Optionen für den Zugriff auf Desktops und Anwendungen. Citrix Workspace-App-Benutzer können entweder über die Citrix Workspace-App auf Stores zugreifen oder einen Webbrowser verwenden, um sich bei einer Citrix Receiver für Web-Site für den Store anzumelden. Benutzern, die die Citrix Workspace-App nicht installieren können, jedoch einen HTML5-kompatiblen Webbrowser haben, können Sie direkten Zugriff auf Desktops und Anwendungen im Webbrowser ermöglichen, indem Sie die Citrix Workspace-App für HTML5 für Ihre Citrix Receiver für Web-Site aktivieren.

Benutzer mit nicht domänengebundenen Desktopgeräten können auf ihre Desktops über ihren Webbrowser zugreifen, der für den Zugriff auf Desktopgerätesites konfiguriert ist. Benutzer von domänengebundenen Desktopgeräten und umfunktionierten PCs, auf denen Citrix Desktop Lock ausgeführt wird, sowie Benutzer mit älteren Citrix Clients, die nicht aktualisiert werden können, können über die XenApp-Services-URL direkt auf Stores zugreifen.

Wenn Sie Offlineanwendungen bereitstellen möchten, ist neben der Citrix Workspace-App für Windows auch das Offline Plug-In erforderlich. Wenn Sie Microsoft Application Virtualization (App-V)-Sequenzen für Benutzer bereitstellen möchten, wird außerdem eine unterstützte Version von Microsoft Application Virtualization Desktop Client benötigt. Weitere Informationen finden Sie unter Verwalten von gestreamten Anwendungen. Benutzer können nicht über Citrix Receiver für Web-Sites auf Offlineanwendungen oder App-V-Sequenzen zugreifen.

Es wird vorausgesetzt, dass alle Benutzergeräte die Mindestanforderungen an die Hardware für das installierte Betriebssystem erfüllen.

Anforderungen für Citrix Workspace-App-fähige Stores

Unterstützte Versionen der Citrix Workspace-App können für den Zugriff auf StoreFront-Stores über interne Netzwerkverbindungen und über Citrix Gateway verwendet werden. Lifecycle-Daten der Citrix Workspace-App und von Citrix Receiver finden Sie unter https://www.citrix.com/support/product-lifecycle/milestones/receiver.html.

Verbindungen über Citrix Gateway können per Citrix Gateway-Plug-In, ICA-Proxy oder clientloses VPN hergestellt werden. Siehe Einheitliche Benutzeroberfläche.

Anforderungen für den Zugriff auf Stores über Citrix Receiver für Web-Sites

Die folgenden Kombinationen aus Citrix Workspace-App, Betriebssystem und Webbrowser werden für den Zugriff auf Citrix Receiver für Web-Sites über interne Netzwerkverbindungen und Citrix Gateway empfohlen. Verbindungen über Citrix Gateway können per Citrix Gateway-Plug-In, ICA-Proxy oder clientloses VPN hergestellt werden.

Sofern nicht anders angegeben, werden die neuesten Browserversionen empfohlen.

  • Citrix Receiver für Windows 4.9 und höher und Citrix Workspace-App 1808 für Windows und höher.
  • Citrix Receiver für Windows 4.9 LTSR oder Citrix Receiver für Windows 4.12 und Citrix Workspace-App 1808 für Windows oder höher.
    • Windows 10 (32-Bit- und 64-Bit-Edition)
      • Microsoft Edge
      • Internet Explorer 11
      • Google Chrome
      • Mozilla Firefox
    • Windows 8.1 (32- und 64-Bit-Edition)
      • Internet Explorer 11 (32-Bit-Modus)
      • Google Chrome
      • Mozilla Firefox
    • Windows 8 (32-Bit- und 64-Bit-Edition)
      • Internet Explorer 11 (32-Bit-Modus)
      • Google Chrome
      • Mozilla Firefox
    • Windows 7 mit Service Pack 1 (32-Bit- und 64-Bit-Editionen)
      • Internet Explorer 11
      • Google Chrome
      • Mozilla Firefox
    • Windows Embedded Standard 7 Service Pack 1 oder Windows Thin PC
      • Internet Explorer 11
  • Citrix Receiver für Mac 12.8 und Citrix Workspace-App 1808 für Mac und höher.
    • macOS 10.14 Mohave
      • Safari 11
      • Google Chrome
      • Mozilla Firefox
    • macOS 10.13 High Sierra
      • Safari 11
      • Google Chrome
      • Mozilla Firefox
    • macOS 10.12 Sierra
      • Safari 11
      • Google Chrome
      • Mozilla Firefox
    • OS X 10.11 El Capitan
      • Safari 9
      • Google Chrome
      • Mozilla Firefox
    • OS X 10.10 Yosemite
      • Safari 8
      • Google Chrome
      • Mozilla Firefox
    • OS X 10.9 Mavericks
      • Safari 7
      • Google Chrome
      • Mozilla Firefox
  • Citrix Receiver für Linux 13.x und Citrix Workspace-App 1808 für Linux oder höher.
    • Ubuntu 16.04 (64-Bit)
      • Google Chrome
      • Mozilla Firefox

Anforderungen für den Zugriff auf Desktops und Anwendungen über die Citrix Workspace-App für HTML5

Die folgenden Betriebssysteme und Webbrowser werden für den Zugriff auf Desktops und Anwendungen mit Citrix Workspace-App für HTML5 auf Receiver für Web-Sites empfohlen. Es werden sowohl interne Netzwerkverbindungen als auch Verbindungen über Citrix Gateway unterstützt. Außerdem sind bestimmte Versionen von Citrix Gateway erforderlich, um Verbindungen von außerhalb des Unternehmensnetzwerks zu ermöglichen. Weitere Informationen finden Sie unter Anforderungen an die Infrastruktur.

Sofern nicht anders angegeben, werden die neuesten Browserversionen empfohlen.

  • Browser
    • Microsoft Edge
    • Internet Explorer 11
    • Safari 12
    • Google Chrome
    • Mozilla Firefox
  • Betriebssysteme
    • Windows 10 (32-Bit- und 64-Bit-Edition)
    • Windows 8.1 (32- und 64-Bit-Edition)
    • Windows 8 (32-Bit- und 64-Bit-Edition)
    • Windows 7 mit Service Pack 1 (32-Bit- und 64-Bit-Editionen)
    • Windows Vista mit Service Pack 2 (32-Bit- und 64-Bit-Editionen)
    • Windows Embedded XP
    • macOS 10.14 Mojave
    • macOS 10.13 High Sierra
    • macOS 10.12 Sierra
    • OS X 10.11 El Capitan
    • OS X 10.10 Yosemite
    • OS X 10.9 Mavericks
    • OS X 10.8 Mountain Lion
    • Google Chrome OS 48
    • Google Chrome OS 47
    • Ubuntu 16.04 (32 Bit)
    • Ubuntu 12.04 (32 Bit)

Anforderungen für den Zugriff auf Stores über Desktopgerätesites

Die folgenden Kombinationen aus Citrix Receiver (jetzt Citrix Workspace-App), Betriebssystem und Webbrowser werden für den Zugriff auf Desktopgerätesites über interne Netzwerkverbindungen empfohlen. Verbindungen über Citrix Gateway werden nicht unterstützt.

  • Citrix Receiver für Windows 4.9 und höher und Citrix Workspace-App 1808 für Windows und höher.
    • Windows 8.1 (32- und 64-Bit-Edition)
      • Internet Explorer 11 (32-Bit-Modus)
    • Windows 8 (32-Bit- und 64-Bit-Edition)
      • Internet Explorer 10 (32-Bit-Modus)
    • Windows 7 Service Pack 1 (32-Bit- und 64-Bit-Edition), Windows Embedded Standard 7 Service Pack 1 oder Windows Thin PC
      • Internet Explorer 9 (32-Bit-Modus)
      • Internet Explorer 8 (32-Bit-Modus)
    • Windows Embedded XP
      • Internet Explorer 8 (32-Bit-Modus)

Anforderungen für den Zugriff auf Stores über XenApp Services-URLs

Alle o. g. Clientversionen können für den Zugriff auf StoreFront-Stores mit reduziertem Funktionsumfang über XenApp Services-URLs verwendet werden. Verbindungen über Citrix Gateway, sofern unterstützt, können mit dem Citrix Gateway-Plug-In oder über clientlosen Zugriff hergestellt werden.

Anforderungen für Smartcards

Smartcardanforderungen für Citrix Receiver für Windows 4.x und Citrix Workspace-App 1808 für Windows und höher

Citrix testet die Kompatibilität mit folgenden Smartcards: CAC (Common Access Card, US-Behörden), NIST PIV (National Institute of Standards and Technology Personal Identity Verification, USA) und diverse USB-Smartcardtoken. Sie können Kontaktkartenleser verwenden, die mit der Spezifikation “USB Chip/Smart Card Interface Devices” (CCID) übereinstimmen und vom deutschen Zentralen Kreditausschuss (ZKA) als Klasse 1-Smartcardleser klassifiziert wurden. Bei ZKA Klasse 1-Kontaktkartenlesern müssen Benutzer die Smartcards in den Leser einlegen. Andere Smartcardleser, einschließlich Klasse 2-Leser (mit Tastatur für die PIN-Eingabe), kontaktlose Leser und virtuelle TPM-Chip-basierte (Trusted Platform Module) Smartcards werden nicht unterstützt.

Für Windows-Geräte basiert die Smartcard-Unterstützung auf dem PC/SC-Standard (Personal Computer/Smart Card) von Microsoft. Als Mindestanforderung müssen Smartcards und Smartcardleser vom Betriebssystem unterstützt werden und über die Windows-Hardwarezertifizierung verfügen.

Weitere Informationen über Citrix-kompatible Smartcards und Middleware finden Sie unter Smartcards in derCitrix Virtual Apps and Desktops-Dokumentation und unter http://www.citrix.com/ready.

Anforderungen für die Authentifizierung über Citrix Gateway

Die folgenden Versionen von Citrix Gateway können verwendet werden, um Benutzern in öffentlichen Netzwerken den Zugriff auf StoreFront mit Smartcardauthentifizierung zu ermöglichen.

  • Citrix Gateway 13.0
  • Citrix Gateway 12.1
  • NetScaler Gateway 12.0
  • NetScaler Gateway 11.x

Anforderungen für Citrix Analytics

Sie können Citrix StoreFront so konfigurieren, dass die Citrix Workspace-App Daten an Citrix Analytics senden kann. Konfigurationsdetails werden unter Citrix Analytics-Dienst beschrieben. Diese Funktionalität wird für die folgenden Szenarien unterstützt:

  • Stores, auf die über Citrix Receiver für Websites mit HTML5-kompatiblen Browsern zugegriffen wird. Beim Starten von Ressourcen mithilfe der nativen Citrix Workspace-App oder von HTML5 werden CAS-Daten bereitgestellt.
  • Stores, auf die über die Citrix Workspace-App 1903 für Windows oder höher zugegriffen wird.
  • Stores, auf die über die Citrix Workspace-App 1901 für Linux oder höher zugegriffen wird.