App Layering

Requisitos del sistema

El dispositivo virtual App Layering se ejecuta en los hipervisores compatibles enumerados en este artículo. El dispositivo es donde se despliega Enterprise Layer Manager (ELM) durante la instalación.

Para utilizar la consola de administración del dispositivo, necesita un explorador compatible con Microsoft Silverlight.

Puede crear capas para utilizarlas en prácticamente cualquier Hypervisor o software de Provisioning. Para obtener la mejor experiencia de usuario, publique imágenes en las plataformas compatibles.

Hipervisores para el dispositivo

Enterprise Layer Manager (ELM) se ejecuta en un dispositivo virtual implementado en un Hypervisor compatible.

  • Citrix Hypervisor, versiones 6.5, 7.0—7.6, 8.0, 8.1, 8.2
  • Azure Resource Manager
  • Google Cloud Platform (GCP)
  • Microsoft Hyper-V que se ejecuta en Windows Server 2012 R2, Windows Server 2016 o Windows Server 2019
    • Las máquinas virtuales de generación 2 se admiten cuando se utiliza la función de composición de descarga.
  • Nutanix Acropolis Hypervisor (AHV), versiones 5.0 a 5.5 (solo elemento prisma), 5.8, 5.9, 5.10, 5.11, 5.15 (versión de soporte a largo plazo), 5.16, 5.17, 5.18, 5.19
  • vSphere vCenter, versiones 5.5, 6.0, 6.5, 6.7, 7.0
    • Las máquinas virtuales de generación 2 son compatibles con vSphere vCenter versiones 6.7 y 7.0 cuando utiliza la función de composición de descarga

Protocolo de recursos compartidos de archivos de red

  • Bloque de mensajes de servidor (SMB)

Conexión de red

  • Citrix recomienda una conexión de 10 Gbps entre el dispositivo y el recurso compartido de archivos.

Servicio de directorios

  • Microsoft Active Directory

Explorador de Internet para consola de administración

La consola de administración admite los siguientes exploradores web con Microsoft Silverlight 4.0 o posterior:

  • Internet Explorer 11
  • Firefox versión 45 - 52.9

Sistema operativo para imágenes en capas

Puede aplicar capas a las siguientes versiones del sistema operativo Windows. Las aplicaciones de Microsoft Store funcionan en todas las versiones compatibles de Windows.

Importante:

La implementación de capas de usuarios completo (para la persistencia de datos y configuraciones de usuario) requiere un entorno de Windows 7 de 64 bits o Windows 10 de 64 bits.

  • Sistemas operativos Windows Server: se admiten las siguientes versiones de host de sesión:

    • Windows Server 2019, 64 bits (ediciones estándar y de centro de datos)
    • Windows Server 2016, 64 bits (ediciones estándar y de centro de datos)
    • Windows Server 2012 R2, 64 bits (ediciones estándar y de centro de datos)
    • Windows Server 2008 R2, 64 bits (ediciones estándar y de centro de datos)
  • Sistemas operativos de escritorio: se admiten las siguientes versiones de escritorio:

    • Windows 10, versión 20H2. Compatible con App Layering versión 2011 o posterior.

      Advertencia: si actualiza la capa del sistema operativo a Windows 10 20H2 desde una versión anterior, actualice directamente a la compilación 19042.630 o superior. La actualización a compilaciones de Windows 10 20H2 publicadas antes del 16/11/2020 puede dar lugar a implementaciones de imágenes inconsistentes.

    • Windows 10, 64 bits, versiones 2004, 1909, 1903, 1809, 1803, 1709, 1703 y 1607 (ediciones educativas y empresariales)
    • Windows 10, 64 bits, versiones 2004, 1909, 1903, 1809, 1803 (edición Professional)
    • Windows 7, 64 bits (ediciones Enterprise y Professional)
    • Windows 7, 32 bits (ediciones Enterprise y Professional)

App Layering admite paquetes de idioma de un solo byte para el sistema operativo Windows básico de inglés de Estados Unidos. Admite paquetes de idioma de varios bytes cuando la capa del sistema operativo se implementa en versiones compatibles de:

  • Citrix Hypervisor
  • VMware vSphere
  • Microsoft Hyper-V

Instale los paquetes de idioma en la máquina del sistema operativo antes de importar el sistema operativo a una capa del sistema operativo. Los paquetes de idioma instalados en una versión de capa del sistema operativo no funcionan correctamente.

Capas de usuarios

Las capas de usuarios completas se admiten en las siguientes plataformas:

  • Sistemas operativos:
    • Windows 7, 64 bits
    • Windows 10, 64 bits
  • Plataformas de publicación:
    • Citrix Virtual Desktops
    • VMware Horizon View

Imágenes en capas

Las imágenes en capas son imágenes de arranque compuestas a partir de capas. Cada imagen en capas contiene una capa de SO, una capa de plataforma y cualquier número de capas de aplicaciones. Puede publicar imágenes en capas en estas plataformas:

  • Machine Creation for Citrix Hypervisor (anteriormente Citrix MCS for XenServer)
  • Creación de máquinas para Azure y Azure Government
  • Machine Creation for vSphere
  • Machine Creation for Nutanix AHV
  • Citrix Provisioning, versiones 2012, 2009, 2006, 2003, 1912, 1909, 1906, 1903, 1811, 7.15 CU6 y Provisioning Service (PVS), versiones 7.6 LTSR

    Notas:

    • Citrix recomienda velocidades de red de 10 Gbps al almacén de aprovisionamiento
    • Provisioning Service (PVS), las versiones 7.1, de 7.7 a 7.9, de 7.11 a 7.18, 1808 ya no son compatibles. El dispositivo y los conectores se ejecutan en los siguientes entornos:
  • Citrix Virtual Apps and Desktops, versiones 7:1808, 1811, 1903, 1906, 1909, 1912 (LTSR, CU1, CU2), 2003, 2006, 2009, 2012
  • Citrix XenApp y XenDesktop, versiones 6.5, 7.0—7.18 y 7.15 (LTSR, CU3 - CU7)
  • Citrix Virtual Apps and Desktops Essentials para Azure
  • Citrix Hypervisor (anteriormente Citrix XenServer)
  • Google Cloud Platform (GCP)
  • Microsoft Azure
  • Microsoft Hyper-V
  • Nutanix Acropolis
  • VMware vSphere
  • VMware Horizon View, versiones 6.x, 7.0.x, 7.1.x, 7.2, 7.3, 7.4, 7.6, 7.8, 7.9, 7.11, 7.13

Provisioning de escritorios y entrega de aplicaciones

Puede utilizar imágenes en capas para escritorios persistentes, siempre y cuando no habilite capas elásticas o capas de usuarios (Full u Office 365).

Para habilitar Capas de usuario o capas elásticas, debe utilizar máquinas no persistentes.

Nota:

Las capas elásticas no son compatibles con View Persona Management.