Linux Virtual Delivery Agent

Systemanforderungen

Linux-Distributionen

Hinweis:

Die Systemanforderungen für Komponenten, die hier nicht behandelt werden (z. B. die Citrix Workspace-App), werden in der jeweiligen Dokumentation beschrieben.

Installieren Sie vor der Linux VDA-Installation .NET Core Runtime 3.1 gemäß den Anweisungen unter https://docs.microsoft.com/en-us/dotnet/core/install/linux-package-managers.

Der Linux VDA unterstützt keine SecureICA-Verschlüsselung. Wenn SecureICA auf dem Linux VDA aktiviert ist, führt dies zu einem Sitzungsstartfehler.

Weitere Informationen zur Verwendung dieser aktuellen Version (CR) in einer LTSR-Umgebung (Long Term Service Release) und zu anderen häufig gestellten Fragen finden Sie im Knowledge Center-Artikel.

Folgende Linux-Distributionen werden vom Linux VDA unterstützt:

Wichtig:

Wenn Ihr Betriebssystem vom Hersteller nicht mehr unterstützt wird, kann Citrix Probleme möglicherweise nur noch eingeschränkt beheben.
Informationen zu veralteten oder entfernten Plattformen finden Sie unter Einstellung von Features und Plattformen.

  • Amazon Linux
    • Amazon Linux 2
  • CentOS Linux
    • CentOS 8 (2105)
    • CentOS 8.3
    • CentOS 8.2
    • CentOS 8.1
    • CentOS 7.9
    • CentOS 7.8
  • Debian Linux
    • Debian 10.9
  • Red Hat Enterprise Linux
    • Workstation 8.4
    • Workstation 8.3
    • Workstation 8.2
    • Workstation 8.1
    • Workstation 7.9
    • Workstation 7.8
    • Server 8.4
    • Server 8.3
    • Server 8.2
    • Server 8.1
    • Server 7.9
    • Server 7.8
  • SUSE Linux Enterprise:
    • Server 15 Service Pack 3
    • Server 15 Service Pack 2
    • Server 12 Service Pack 5 + SUSE Linux Enterprise Workstation Extension 12 SP5
    • Server 12 Service Pack 5
  • Ubuntu Linux
    • Ubuntu Desktop 20.04
    • Ubuntu Server 20.04
    • Ubuntu Desktop 18.04
    • Ubuntu Server 18.04
    • Ubuntu Live Server 18.04
    • Ubuntu Desktop 16.04
    • Ubuntu Server 16.04

Hinweis:

  • Das CentOS-Projekt verlagert den Fokus auf CentOS Stream. CentOS Linux 8 endet als Rebuild von RHEL 8 Ende 2021. CentOS Stream wird nach diesem Datum als Upstream- (Entwicklungs-)Zweig von Red Hat Enterprise Linux fortgesetzt. Weitere Informationen finden Sie unter https://www.redhat.com/en/blog/centos-stream-building-innovative-future-enterprise-linux.

  • Wenn Sie Citrix Provisioning zum Streamen von Linux-Zielgeräten verwenden, erstellen Sie eine separate Startpartition auf dem freigegebenen Datenträgerimage, damit die bereitgestellten Geräte wie erwartet gestartet werden können.

  • Vermeiden Sie es, Partitionen mit btrfs zu formatieren. GRUB2 hat Probleme beim Auffinden von btrfs-Partitionen. GRUB steht für (GRand Unified Bootloader).

Die folgende Tabelle bietet eine Übersicht der Linux-Distributionen und Xorg-Versionen, die von dieser Version des Linux VDA unterstützt werden. Weitere Informationen finden Sie unter XorgModuleABIVersions.

Linux-Distribution Xorg-Version
Amazon Linux 2 1.20
Debian 10.9 1.20
RHEL 8.4, CentOS 8 (2105) 1.20.10
RHEL 8.3, CentOS 8.3 1.20.8
RHEL 8.2, CentOS 8.2 1.20.8
RHEL 8.1, CentOS 8.1 1.20.8
RHEL 7.9, CentOS 7.9 1.20
RHEL 7.8, CentOS 7.8 1.20
SUSE 15.3 1.20
SUSE 15.2 1.20
SUSE 12.5 1.19
Ubuntu 20.04 1.20
Ubuntu 18.04 1.19
Ubuntu 16.04 1.18

Verwenden Sie für Ubuntu keinen HWE Kernel oder HWE Xorg.

Verwenden Sie PulseAudio 13.99 für RHEL 8.x und CentOS 8.x.

Verwenden Sie PulseAudio 14.2 unter SUSE 15.3 und PulseAudio 13.0 unter SUSE 15.2.

In allen Fällen wird die Prozessorarchitektur x86-64 unterstützt.

Hinweis:

GNOME- und KDE-Desktops werden unter CentOS 7, CentOS 8, RHEL 7, RHEL 8 und SUSE 12 unterstützt. Unity-Desktop wird unter Ubuntu 16.04 unterstützt. GNOME-Desktop wird unter Amazon Linux 2, Debian 10.9, SUSE 15, Ubuntu 20.04 und Ubuntu 18.04 unterstützt. MATE-Desktop wird unter allen vom Linux VDA unterstützten Linux-Distributionen mit Ausnahme von SUSE unterstützt. Mindestens ein Desktop muss installiert sein.

Citrix Virtual Desktops

Der Linux VDA ist kompatibel mit allen zurzeit unterstützten Versionen von Citrix Virtual Apps and Desktops. Weitere Informationen zum Citrix Produktlebenszyklus und wann Citrix die Unterstützung bestimmter Produktversionen beendet, finden Sie unter Citrix Product Lifecycle Matrix.

Die Konfiguration von Linux VDAs ist etwas anders als bei Windows VDAs. Alle Delivery Controller-Farmen können jedoch Windows- und Linux-Desktops vermitteln.

Unterstützte Hostplattformen und Virtualisierungsumgebungen

  • Bare-Metal-Server
  • Citrix Hypervisor
  • VMware ESX und ESXi
  • Microsoft Hyper-V
  • Nutanix AHV
  • Microsoft Azure Resource Manager
  • Amazon Web Services (AWS)
  • Google Cloud Platform (GCP)

Tipp:

Eine Liste der unterstützten Plattformen finden Sie in der Herstellerdokumentation.

Hinweis:

Azure, AWS und GCP sind nur mit Citrix Virtual Apps and Desktops Service kompatibel. Bare-Metal-Server werden nicht unterstützt, wenn MCS zum Erstellen virtueller Maschinen verwendet wird.

Active Directory-Integrationspakete

Die folgenden Active Directory-Integrationspakete oder -produkte werden vom Linux VDA unterstützt:

  • Samba Winbind
  • Quest Authentication Services v4.1 oder höher
  • Centrify DirectControl
  • SSSD
  • PBIS (kompatibel mit RHEL 7, Ubuntu und Debian)
  Winbind SSSD Centrify PBIS Quest
Amazon Linux 2 Ja Ja Ja Ja Nein
Debian 10.9 Ja Ja Ja Ja Nein
RHEL 8.4, CentOS 8 (2105) Ja Ja Ja Ja Nein
RHEL 8.3, CentOS 8.3 Ja Ja Ja Ja Nein
RHEL 8.2, CentOS 8.2 Ja Ja Ja Ja Nein
RHEL 8.1, CentOS 8.1 Ja Ja Ja Ja Nein
RHEL 7.9, CentOS 7.9 Ja Ja Ja Ja Ja
RHEL 7.8, CentOS 7.8 Ja Ja Ja Ja Ja
SUSE 15.3 Ja Ja Ja Ja Nein
SUSE 15.2 Ja Ja Ja Ja Nein
SUSE 12.5 Ja Ja Ja Ja Ja
Ubuntu 20.04 Ja Ja Ja Ja Ja
Ubuntu 18.04 Ja Ja Ja Ja Ja
Ubuntu 16.04 Ja Ja Ja Ja Ja

HDX 3D Pro

Die nachstehenden Hypervisors und NVIDIA GRID™-GPUs sind für HDX 3D Pro erforderlich.

Hypervisors

  • Citrix Hypervisor
  • VMware ESX und ESXi
  • Nutanix AHV

Hinweis:

Die Hypervisors sind mit bestimmten Linux-Distributionen kompatibel.

Grafikprozessor

Der Linux VDA unterstützt die folgenden GPUs für GPU-Passthrough:

  • NVIDIA GRID - Tesla T4
  • NVIDIA GTX750Ti
  • NVIDIA GRID - Tesla M60
  • NVIDIA GRID - K2
  • NVIDIA GRID - Tesla P40
  • NVIDIA GRID - Tesla P4
  • NVIDIA GRID - Tesla P100

Der Linux VDA unterstützt die folgenden GPUs für vGPU:

  • NVIDIA GRID - Tesla T4
  • NVIDIA GRID - Tesla V100
  • NVIDIA GRID - Tesla M60
  • NVIDIA GRID - Tesla M10
  • NVIDIA GRID - Tesla P40
  • NVIDIA GRID - Tesla P4
  • NVIDIA GRID - Tesla P100
Systemanforderungen