Product Documentation

Hyper-V VM prerequisite configurations

Important: This topic describes deprecated functions and will be removed from the documentation. For more information about deprecated functions in Smart Tools, see What’s New in Citrix Smart Tools.

The following VM configurations are required for Smart Tools to deploy and manage Hyper-V VMs:

On Windows:

  • Hyper-V integration services must be installed and running

    Hyper-V services highlighted in Windows Services console

  • Windows Firewall exception must be added for Windows Management Instrumentation (WMI)

    WMI services highlighted in Allowed apps dialog in Windows Firewall console

On Linux:

  • Hyper-V integration services must be installed and running
  • VHD running on the Linux VM must support SSH

Hyper-V VM prerequisite configurations

In this article