XenMobile compatibility

Note:

This article covers compatibility for XenMobile Server 10.9. For components tested with Endpoint Management, see Endpoint Management compatibility.

To use new features, fixes, and policy updates, Citrix recommends that you install the most recent version of the MDX Toolkit, Secure Hub, and mobile productivity apps. You can use the MDX Service instead of the MDX Toolkit. For details, see XenMobile MDX Service.

Important:

Citrix ceased support of enterprise distribution for XenMobile productivity apps on December 31, 2017. For details, see the Citrix Product Matrix. Now, Citrix supports only public app store distribution.

This article summarizes the versions of the supported XenMobile components that you can integrate.

Supported versions and upgrade paths

The latest versions of Secure Hub, MDX Toolkit, and mobile productivity apps are compatible with the latest version and the two prior versions of XenMobile Server.

The latest version of the mobile productivity apps requires the latest version of Secure Hub. The two previous versions of the apps are compatible with the latest Secure Hub.

XenMobile Server (on-premises)

  • Citrix supports upgrades from the last two versions of XenMobile Server.
  • Latest version of XenMobile Server:
    • XenMobile Server 10.9
  • Upgrade from:
    • XenMobile Server 10.8.x
    • XenMobile Server 10.7.x

MDX Toolkit

  • Citrix supports the latest three releases (n.n.n) of MDX Toolkit.
  • The latest toolkit version is MDX Toolkit 10.8.60 (for iOS and Android) for wrapping third-party apps. You can upgrade to MDX Toolkit 10.8.60 from MDX Toolkit 10.8.35, and 10.8.5.

You can also use XenMobile MDX Service for wrapping apps. For details, see XenMobile MDX Service.

Mobile productivity apps from public stores

  • Citrix supports upgrades from the last two versions.
    • Users who have automatic updates enabled receive the latest version from the app store.
    • The latest app supports the previous two MDX files.
  • Latest versions of Secure Hub, Secure Mail, and Secure Web for Android:
    • 10.8.60
    • 10.8.55
    • 10.8.50
  • Latest versions of Secure Hub, Secure Mail, and Secure Web for iOS:
    • 10.8.60
    • 10.8.55
    • 10.8.50

Note:

Users access ShareFile for XenMobile from the public app stores after version 6.5.

Browser support

XenMobile 10.9 supports the following browsers:

  • Internet Explorer, though not versions 9 or earlier
  • Chrome
  • Firefox
  • Safari on mobile devices for use with the Self Help Portal

XenMobile 10.9 is compatible with the most current version of the browser and one version before the current version.

XenMobile compatibility