System requirements and compatibility

Requirements

Image of System Requirements for Hardware Image of System Requirements for Libraries Image of System Requirements for Components 1 Image of System Requirements for Components 2 Image of System Requirements for Components 3 Image of System Requirements for Components 4

Compatibility matrix

Citrix Workspace app for Linux is compatible with all currently supported versions of the Citrix products. For information about the Citrix product lifecycle, and to find out when Citrix stops supporting specific versions of products, see the Citrix Product Lifecycle Matrix.

  • You can use Citrix Workspace app for Linux 1808 or later browser-based access with StoreFront Citrix Workspace app for Web and Web Interface, with - or without - the Citrix Gateway plug-in.

    StoreFront:

    • StoreFront 3.x, 2.6, 2.5 and 2.1

      Provides direct access to StoreFront stores.

    • StoreFront configured with a Citrix Workspace app for Web site

      Provides access to StoreFront stores from a web browser. For the limitations of this deployment, refer to “Important considerations” in StoreFront Citrix Workspace app for Web sites.

    Web Interface with the NetScaler VPN client:

    • Web Interface 5.4 for Windows web sites.

      Provides access to virtual desktops and apps from a web browser.

    • Web Interface 5.4 for Linux with Citrix Virtual Apps Services or Citrix Virtual Desktops Services sites

  • Ways to deploy Citrix Workspace app to users:

    • Download the Citrix Workspace app from the Citrix download page, then configure using an email or services address with StoreFront.
    • Offer to install from Citrix Workspace app for Web site (configured with StoreFront).
    • Offer to install Citrix Workspace app from Citrix Web Interface 5.4.

Browser

Mozilla Corporation has announced that NPAPI support is deprecated as of version 52 of the Firefox browser. Other browsers, too, have deprecated support for NPAPI.

Thus, Citrix has introduced workspace launcher.

System requirements and compatibility