Kumulatives Update 1 (CU1)

Info zu diesem Release

Das kumulative Update (CU1) für XenApp und XenDesktop 7.15 LTSR behebt mehr als 80 Probleme, die seit dem Erstrelease von 7.15 LTSR gemeldet wurden.

7.15 LTSR (Allgemeine Informationen)

Seit XenApp und XenDesktop 7.15 LTSR (Erstrelease) behobene Probleme

Bekannte Probleme in diesem Release

Vor dem Upgrade von 7.6 LTSR CU5

Der Hauptvorteil des Upgrades von 7.6 LTSR CU5 auf 7.15 LTSR CU1 besteht darin, dass die Basis 7.15 LTSR wesentlich mehr Features enthält als die Basis 7.6 LTSR. Wenn Sie diese Aktualisierung in Betracht ziehen, beachten Sie jedoch, dass eine kleine Teilmenge der Korrekturen, die in 7.6 LTSR CU5 enthalten sind, in 7.15 LTSR CU1 nicht vorhanden ist. Das liegt daran, dass 7.15 LTSR CU1 vor 7.6 LTSR CU5 veröffentlicht wurde. Eine Liste der Korrekturen, die für 7.15 gelten, aber nicht in 7.15 LTSR CU1 enthalten sind, finden Sie unter Liste der Korrekturen in 7.6 LTSR CU5, aber nicht in 7.15 LTSRCU1. Wenn Ihre Bereitstellung von bestimmten Fixes in 7.6 LTSR CU5 abhängig ist, empfiehlt Citrix, dass Sie diese Liste vor dem Upgrade überprüfen.

Neue Bereitstellungen

Wie stelle ich das CU1 von Grund auf bereit?

Mit dem CU1-Metainstaller können Sie eine neue XenApp und XenDesktop-Umgebung basierend auf dem CU1 einrichten. Machen Sie sich mit dem Produkt vertraut, bevor Sie beginnen.

Bevor Sie mit der Planung der Bereitstellung beginnen, lesen Sie die Dokumentation zu XenApp und XenDesktop 7.15 LTSR (Erstrelease) und besonders die Abschnitte Technische Übersicht, Installation und Konfiguration und Sicherheit. Stellen Sie sicher, dass die Systemanforderungen für alle Komponenten erfüllt sind.

Vorhandene Bereitstellungen

Wie funktioniert das Aktualisieren?

Das CU1 umfasst Updates für 13 Basiskomponenten von 7.15 LTSR. Nicht vergessen: Citrix empfiehlt die Aktualisierung der LTSR-Komponenten auf CU1. Beispiel: Wenn Provisioning Services zur LTSR-Bereitstellung gehört, aktualisieren Sie die Provisioning Services-Komponenten auf die CU1-Version. Wenn Provisioning Services nicht zu Ihrer Bereitstellung gehört, brauchen Sie es nicht zu installieren oder zu aktualisieren.

Basiskomponenten von XenApp und XenDesktop 7.15 LTSR CU1

7.15 LTSR CU1-Basiskomponente Version Hinweise
VDA für Desktopbetriebssystem 7.15.1000  
VDA für Serverbetriebssystem 7.15.1000  
Delivery Controller 7.15.1000  
Citrix Studio 7.15.1000  
Citrix Director 7.15.1000  
Gruppenrichtlinienverwaltung 3.1.1000  
StoreFront 3.12.1000  
Provisioning Services 7.15.1  
Universeller Druckserver 7.15.1000  
Sitzungsaufzeichnung 7.15.1000 nur Platinum Edition
Linux VDA 7.15.1000 Informationen zu den unterstützten Plattformen finden Sie in der Linux VDA-Dokumentation.
Profilverwaltung 7.15.1000  
Verbundauthentifizierungsdienst 7.15.1000  

XenApp und XenDesktop 7.15 LTSR CU1-kompatible Komponenten

Die folgenden Komponenten werden zur Verwendung in 7.15 LTSR CU1-Umgebungen empfohlen. Für diese Komponenten können die LTSR-Vorteile (erweiterter Lebenszyklus und kumulative Updates mit Fixes) nicht beansprucht werden. Citrix fordert Sie u. U. auf, ein Upgrade auf eine neuere Version der folgenden Komponenten in Ihrer 7.15 LTSR CU1-Umgebung durchzuführen.

Mit 7.15 LTSR kompatible Komponenten und Plattformen Version
AppDNA 7.16
Citrix SCOM Management Pack for License Server 1.2
Citrix SCOM Management Pack für Provisioning Services 1.19
Citrix SCOM Management Pack für StoreFront 1.13
Citrix SCOM Management Pack für XenApp und XenDesktop 3.14
HDX RealTime Optimization Pack 2.2.100
Lizenzserver 11.14.0.1 Build 22103
Workspace Environment Management 4.4
App Layering 4.6
Self-Service-Kennwortzurücksetzung 1.1

Kompatible Versionen von Citrix Receiver

Damit Wartungsfreundlichkeit und optimale Leistung gewährleistet sind, empfiehlt Citrix, dass Sie ein Upgrade auf die aktuelle Version von Citrix Receiver ausführen, sobald sie verfügbar ist. Die neuesten Versionen stehen unter Downloads zum Download zur Verfügung. Wenn Sie den Citrix Receiver-RSS-Feed abonnieren, erhalten Sie eine Benachrichtigung, wenn eine neue Version von Citrix Receiver zur Verfügung steht.

Für Citrix Receiver können die XenApp und XenDesktop LTSR-Vorteile (erweiterter Lebenszyklus und kumulative Updates mit Fixes) nicht beansprucht werden. Citrix fordert Sie u. U. auf, in Ihrer 7.15 LTSR CU1-Umgebung ein Upgrade auf eine neuere Version von Citrix Receiver durchzuführen. Citrix hat ein spezielles LTSR-Programm für Citrix Receiver für Windows angekündigt. Weitere Informationen zu diesem Programm finden Sie unter Lifecycle Milestones for Citrix Receiver.

7.15 LTSR CU1 unterstützt insbesondere die folgenden Versionen von Citrix Receiver und alle neueren Versionen:

Mit LTSR kompatible Citrix Receiver-Version

Mit LTSR kompatible Citrix Receiver-Version Version
Citrix Receiver für Android 3.12.3 oder höher
Citrix Receiver für Chrome 2.5.2 oder höher
Citrix Receiver für HTML5 2.5.2 oder höher
Citrix Receiver für iOS 7.3.1 oder höher
Citrix Receiver für Linux 13.7 oder höher
Citrix Receiver für Mac 12.7 oder höher
Citrix Receiver für UWP (Universelle Windows-Plattform) 1.0.5 oder höher
Citrix Receiver für Windows 4.9 oder höher

XenApp und XenDesktop 7.15 LTSR – wichtige Ausschlüsse

Für die folgenden Features, Komponenten und Plattformen können die 7.15-LTSR-Lebenszyklusmeilensteine und Vorteile nicht in Anspruch genommen werden. Insbesondere sind kumulative Updates und die mit dem erweiterten Lebenszyklus verbundenen Vorteile ausgeschlossen. Updates für ausgeschlossene Features und Komponenten sind durch regelmäßige aktuelle Releases verfügbar.

Ausgeschlossene Features
Framehawk
StoreFront/Citrix Online-Integration
Ausgeschlossene Komponenten
Personal vDisk: für Windows 10-Maschinen ausgeschlossen •Windows 7-Maschinen: begrenzte LTSR-Unterstützung bis zum 14. Januar 2020 (CU-Anforderungen gelten)
AppDisks
Ausgeschlossene Windows Plattformen*
Windows 2008 32 Bit (für den universellen Druckserver)

*Citrix behält sich das Recht vor, die Plattformunterstützung basierend auf den Lebenszyklusmeilensteinen von Drittanbietern zu aktualisieren.

Analysedaten zu Installationen und Upgrades

Wenn Sie mit dem Produktinstallationsprogramm XenApp- oder XenDesktop-Komponenten bereitstellen oder aktualisieren, werden anonyme Informationen über den Installationsvorgang gesammelt und auf der Maschine gespeichert, auf der Sie die Komponente installieren/aktualisieren. Mithilfe dieser Daten verbessert Citrix das Kundenerlebnis bei der Installation. Weitere Informationen finden Sie unter https://more.citrix.com/XD-INSTALLER.

XenApp 6.5-Migration

Der XenApp 6.5-Migrationsprozess ermöglicht eine effiziente und schnelle Migration von einer XenApp 6.5-Farm zu einer Site mit XenApp 7.15 CU1. Dies ist nützlich bei Bereitstellungen mit vielen Anwendungen und Citrix Gruppenrichtlinien, da das Fehlerrisiko beim manuellen Verschieben von Anwendungen und Citrix Gruppenrichtlinien in die neue XenApp-Site verringert wird.

Nach der Installation der Kernkomponenten von XenApp 7.15 LTSR CU1 und dem Erstellen einer Site wird der Migrationsprozess in der folgenden Reihenfolge ausgeführt:

  • Führen Sie das XenApp 7.15 CU1-Installationsprogramm auf jedem XenApp 6.5-Worker aus. Damit wird dieser automatisch auf einen neuen Virtual Delivery Agent für Serverbetriebssysteme zur Verwendung in der neuen Site aktualisiert.
  • Führen Sie PowerShell-Export-Cmdlets auf einem XenApp 6.5-Controller aus, um die Anwendung und Citrix Richtlinieneinstellungen in XML-Dateien zu exportieren.
  • Bearbeiten Sie, falls gewünscht, die XML-Dateien, um genau zu bestimmen, welche Elemente Sie in die neue Site importieren möchten. Durch Anpassen der Dateien können Sie Richtlinien- und Anwendungseinstellungen phasenweise (d. h. einige sofort, andere später) in die XenApp 7.15 LTSR CU1-Site importieren.
  • Führen Sie PowerShell-Import-Cmdlets auf dem neuen XenApp 7.15 CU1-Controller aus, um die Einstellungen aus den XML-Dateien in die neue XenApp-Site zu importieren.

Konfigurieren Sie die neue Site nach Bedarf um und testen Sie sie.

Weitere Informationen finden Sie unter Migrieren von XenApp 6.x

Liste der Korrekturen in 7.6 LTSR CU5, aber nicht in 7.15 LTSR CU1

Wenn Sie ein Upgrade von 7.6 LTSR CU5 auf 7.15 LTSR CU1 in Betracht ziehen, beachten Sie, dass einige wenige Korrekturen von 7.6 LTSR CU5 nicht in 7.15 LTSR CU1 enthalten sind. Wenn Ihre Bereitstellung von bestimmten Fixes in 7.6 LTSR CU5 abhängig ist, empfiehlt Citrix, dass Sie diese Liste vor dem Upgrade überprüfen.

  • LC6311
  • LC6985
  • LC7430
  • LC7450
  • LC7574
  • LC7600
  • LC7777
  • LC7911
  • LC8046
  • LC8080
  • LC8130
  • LC8170
  • LC8281
  • LC8339
  • LC8492
  • LC8732
  • LC8750
  • LC8774