Citrix

Produktdokumentation



Ganzes Dokument herunterladen

Systemanforderungen für Receiver für Android

Nov. 20, 2015

Geräteanforderungen

Wichtig

Diese Version von Citrix Receiver wird nicht unter Android M (6.0) unterstützt.  Wenn Benutzer auf Android M aktualisiert haben, sollten sie auf die aktuelle Version von Citrix Receiver aktualisieren. Die aktuelle Version steht auf Google Play zum Download zur Verfügung.

  • Citrix Receiver für Android 3.6 wird von den Android-Versionen 4.0 und 5.0 unterstützt.
  • Citrix Receiver für Android unterstützt das Starten von Sitzungen über Citrix Receiver für Web, sofern der verwendete Browser mit Citrix Receiver für Web funktioniert. Erfolgen keine Sitzungsstarts, konfigurieren Sie Ihr Konto direkt über Receiver für Android.
  • Wenn eine Technology Preview-Version von Citrix Receiver installiert ist, deinstallieren Sie sie, bevor Sie die neue Version installieren.
Wichtig: Weitere Informationen zum Sichern der Verbindungen mit Ihrer Citrix Umgebung finden Sie im Abschnitt Verbindungen (unten).

Server

Für Verbindungen mit virtuellen Desktops und Apps unterstützt Citrix Receiver Citrix StoreFront und das Webinterface.

StoreFront:

  • StoreFront 2.6 (empfohlen)

    Bietet direkten Zugriff auf StoreFront-Stores. Receiver unterstützt auch vorherige Versionen von StoreFront.

  • StoreFront konfiguriert mit einer Receiver für Web-Site

    Bietet Zugriff auf StoreFront-Stores über einen Webbrowser. Weitere Informationen zu den Beschränkungen dieser Bereitstellung finden Sie in der StoreFront-Dokumentation.

Webinterface (wird nicht für XenDesktop 7-Bereitstellungen unterstützt)
  • Webinterface 5.4 mit Webinterface-Sites
  • Webinterface 5.4 mit XenApp Services-Sites
  • Webinterface auf NetScaler

    Sie müssen die Rewrite-Richtlinien aktivieren, die von NetScaler bereitgestellt werden.

  • XenApp und XenDesktop (eines der folgenden Produkte):
    • XenApp 7.x
    • XenApp 6.5 für Windows Server 2008 R2
    • XenApp 6 für Windows Server 2008 R2
    • XenApp Fundamentals 6.0 für Windows Server 2008 R2
    • XenApp 5 für Windows Server 2008
    • XenApp 5 für Windows Server 2003
    • Citrix Presentation Server 4.5
    • XenDesktop 7.x
    • XenDesktop 7 (in Englisch)
    • XenDesktop 5, 5.5 und 5.6

Connectivity

Citrix Receiver unterstützt HTTP-, HTTPS- und ICA-über-TLS-Verbindungen mit einer XenApp-Serverfarm über eine der folgenden Konfigurationen:

LAN-Verbindungen:
  • StoreFront 2.x oder 2.6 (empfohlen), Webinterface 5.4 oder eine XenApp Services-Site (früher Program Neighborhood Agent).

Sichere Remoteverbindungen (eines der folgenden Produkte):

  • Citrix NetScaler Gateway 10 (einschließlich Versionen von VPX, MPX und SDX)
  • Citrix Access Gateway Enterprise Edition 9.x und 10.x (einschließlich Versionen von VPX, MPX und SDX)
    • CloudGateway wird nur ab Version 9.3 unterstützt

Sichere Verbindungen und TLS-Zertifikate

Beim Sichern von Remoteverbindungen mit TLS überprüft das Mobilgerät die Echtheit des TLS-Zertifikats des Remote-Gateways unter Verwendung eines lokalen Speichers mit vertrauenswürdigen Stammzertifizierungsstellen. Das Gerät erkennt automatisch kommerziell ausgestellte Zertifikate (z. B. VeriSign und Thawte), wenn das Stammzertifikat für die Zertifizierungsstelle im lokalen Schlüsselspeicher vorhanden ist.

Private (selbstsignierte) Zertifikate

Wenn ein privates Zertifikat auf dem Remote-Gateway installiert ist, muss das Stammzertifikat der Zertifizierungsstelle des Unternehmens auf dem Mobilgerät installiert sein, um erfolgreich mit Citrix Receiver auf Citrix Ressourcen zuzugreifen.

Hinweis: Wenn das Zertifikat des Remote-Gateways beim Herstellen der Verbindung nicht verifiziert werden kann (da das Stammzertifikat nicht im lokalen Schlüsselspeicher vorhanden ist), wird eine Warnung über ein nicht vertrauenswürdiges Zertifikat angezeigt. Wenn der Benutzer weiterarbeitet, wird eine Liste der Anwendungen angezeigt; die Anwendung kann jedoch nicht gestartet werden.

Importieren von Stammzertifikaten auf Android-Geräten

Geräte mit Android 4.x unterstützen den Import von Stammzertifikaten ohne Rootzugriff auf dem Gerät. Android-Geräte vor 4.0 unterstützen nicht den automatischen Import von Stammzertifikaten.

Zertifikate mit Platzhalterzeichen

Zertifikate mit Platzhalterzeichen werden statt einzelner Serverzertifikate für jeden Server in derselben Domäne verwendet. Citrix Receiver für Android unterstützt Zertifikate mit Platzhalterzeichen.

Zwischenzertifikate und das Access Gateway

Wenn die Zertifikatkette ein Zwischenzertifikat enthält, muss das Zwischenzertifikat dem Access Gateway-Serverzertifikat angehängt werden. Weitere Informationen finden Sie im Knowledge Base-Artikel, der für Ihre Edition von Access Gateway relevant ist:

CTX114146: How to Install an Intermediate Certificate on Access Gateway Enterprise Edition

Zusätzlich zu den Konfigurationsabschnitten in diesem Abschnitt von eDocs finden Sie weitere Informationen auch an folgender Stelle:

CTX124937: How to Configure Citrix Access Gateway Enterprise Edition for Use with Citrix Receiver for Mobile Devices

Authentifizierung

Hinweis: RSA SecurID-Authentifizierung wird für Secure Gateway-Konfigurationen nicht unterstützt. Wenn Sie RSA SecurID verwenden möchten, verwenden Sie das Access Gateway.
Citrix Receiver unterstützt die Authentifizierung über das Access Gateway mit den folgenden Methoden (abhängig von Ihrer Edition):
  • Keine Authentifizierung (nur Standard- und Enterprise-Versionen)
  • Domänenauthentifizierung
  • RSA SecurID, einschließlich Softwaretokens für WiFi--Geräte und Geräte ohne WiFi
  • Domänenauthentifizierung zusammen mit RSA SecurID
  • SMS-Passcode-Authentifizierung (OTP)
  • Smartcardauthentifizierung*
* Receiver für Android unterstützt jetzt die folgenden Produkte und Konfigurationen.
Hinweis: Die Smartcard-Authentifizierung an Webinterface-Sites wird nicht unterstützt.
Unterstützte Smartcardleser:
  • BaiMobile 3000MP Bluetooth-Smartcardleser
Unterstützte Smartcards:
  • PIV-Karten
  • Common Access Cards
Unterstützte Konfigurationen:
  • Smartcardauthentifizierung bei NetScaler Gateway ab StoreFront 2.x und XenDesktop 5.6 sowie ab XenApp 6.5
  • Smartcardauthentifizierung bei NetScaler Gateway ab Webinterface 5.4.2 und XenDesktop 5.6 oder ab XenApp 6.5
Hinweis: Andere token-basierte Authentifizierungslösungen können mit RADIUS konfiguriert werden. Wenn Sie weitere Informationen zur SafeWord-Token-Authentifizierung benötigen, suchen Sie in eDocs nach "SafeWord-Authentifizierung konfigurieren" und lesen Sie die für Ihre Edition von Access Gateway relevanten Abschnitte.
Back to Top