新增功能

重要:

本文档反映了 Citrix Virtual Apps and Desktops 7 1912 中的功能和配置。本版本既适用于使用当前版本 (CR) 的客户,也适用于使用长期服务版本 (LTSR) 的客户。

这是本版本的 CR 版本的文档。本版本的 LTSR 版本的文档在 Citrix Virtual Apps and Desktops 7 1912 LTSR 中提供。

关于此版本

此 Citrix Virtual Apps and Desktops 发行版包括新版本的 Windows Virtual Delivery Agent (VDA) 以及多个新版本的核心组件。可以执行以下操作:

  • 安装或升级站点

    请在此版本中使用 ISO 安装或升级核心组件和 VDA。安装或升级到最新版本允许您使用所有最新功能。

  • 在现有站点中安装或升级 VDA

    如果您已有部署,但尚未准备好升级核心组件,仍可通过安装(或升级到)新的 VDA 来使用多个最新的 HDX 功能。如果要在非生产环境中测试增强功能,仅升级 VDA 通常会非常有用。

    将 VDA 升级到此版本(从版本 7.9 或更高版本)后,不需要更新计算机目录的功能级别。7.9(或更高版本)值将保留默认功能级别,并对此版本有效。有关详细信息,请参阅 VDA 版本和功能级别

相关说明:

Citrix Virtual Apps and Desktops 7 1912

关于升级 VDA 的重要通知

如果 VDA 上曾安装过 Personal vDisk (PvD) 组件,则无法将该 VDA 升级到 1912 LTSR 或更高版本。要使用新 VDA,必须卸载当前 VDA,然后安装新 VDA。

即使您安装了 PvD 但从未使用,此指导也适用。

了解您是否受到影响

如何判断是否已在早期版本中安装了 PvD:

  • 在 VDA 安装程序的图形界面中,PvD 是其他组件页面上的一个选项。默认情况下,7.15 LTSR 和更早的 7.x 版本启用了此选项。因此,如果您接受默认值(或在任何版本中明确启用了该选项),则安装了 PvD。
  • 在命令行上,/baseimage 选项安装了 PvD。如果指定了此选项,或使用了包含此选项的脚本,则安装了 PvD。

如果您不知道 VDA 是否已安装 PvD,请在计算机或映像上运行新 VDA(1912 LTSR 或更高版本)的安装程序。

  • 如果安装了 PvD,则会显示一条消息,指示存在不兼容的组件。
    • 对于图形界面,单击包含消息的页面上的取消,然后确认您要关闭安装程序。
    • 在 CLI 中,命令将失败并显示消息。
  • 如果未安装 PvD,则会继续升级。

要执行的操作

如果 VDA 未安装 PvD,请按照常规的升级过程进行操作。

如果 VDA 已安装 PvD:

  1. 卸载当前 VDA。有关详细信息,请参阅删除组件
  2. 安装新 VDA。

如果要在 Windows 7 或 Windows 10(1607 及更早版本,无更新)计算机上继续使用 PvD,VDA 7.15 LTSR 为受支持的最新版本。

安装和升级:单会话 VDA 中的新用户个性化层组件

安装或升级单会话 VDA 时,可以包含用户个性化层组件。此功能由 Citrix App Layering 提供技术支持,在非持久性计算机上,此功能会跨会话保留用户的数据和本地安装的应用程序。

此功能替换已弃用的 Personal vDisk 功能。如果要升级之前安装了 PvD 的 VDA,请参阅关于升级 VDA 的重要通知

有关新增功能的详细信息,请参阅用户个性化层文档。有关 VDA 安装指南,请参阅安装 VDA

安装和升级:Microsoft Visual C++ Runtime 2017 必备组件

安装 Delivery Controller 或 Windows VDA 时,如果尚未安装 Microsoft Visual C++ Runtime 2017,则会自动安装该版本(或受支持的更高版本)。这是一个比早期 Citrix Virtual Apps and Desktops 版本中安装的版本更新的 Visual C++ Runtime 版本。

安装和升级:SQL Server Express 版本

安装第一个 Delivery Controller 时,可以选择让 Citrix 在同一台计算机上安装 Microsoft SQL Server Express,以用作站点数据库。截至此版本,对于新安装,我们安装带累积更新 16 的 SQL Server Express 2017。这是一个比早期 Citrix Virtual Apps and Desktops 版本更新的版本。对于升级,我们不升级已安装的任何 SQL Server Express 版本。

安装 Controller 时,Microsoft SQL Server Express LocalDB 会自动安装,以便与本地主机缓存一起使用。(此安装独立于用于站点数据库的 SQL Server Express。)对于新安装,我们将安装带累积更新 16 的 SQL Server Express LocalDB 2017。这是一个比早期 Citrix Virtual Apps and Desktops 版本更新的版本。对于升级,我们不升级已安装的任何 SQL Server Express LocalDB 版本。

安装和升级:VDA 支持的 Windows 10 版本

此版本支持 Windows 10 32 位 (x86) 和 64 位 (x64) 操作系统。1909 当前版本中不支持 32 位 Windows 10 操作系统。当前没有计划在 1912 LTSR 之后的当前版本中支持该操作系统。对于 Windows 10 计算机,Citrix 建议使用 64 位 (x64)。

安装和升级:防止挂起的重新启动检查

安装或升级核心组件时,如果安装程序检测到计算机上先前的 Windows 安装正在等待重新启动,则将停止运行。现在,使用命令行界面时,可以通过在命令中包含 /no_pending_reboot_check 选项来阻止检查挂起的重新启动。有关详细信息,请参阅 在安装任何组件过程中

VDA 和计算机目录:操作系统名称变更

VDA 和计算机目录的操作系统名称已变更。

  • 多会话操作系统(以前称为服务器操作系统):多会话操作系统计算机目录为大规模部署的标准化 Windows 多会话或 Linux 操作系统计算机提供托管共享桌面。

  • 单会话操作系统(以前称为桌面操作系统):单会话操作系统计算机目录提供的 VDI 桌面是各种不同用户的理想选择。

组件版本号:更改为本地值

在产品和组件版本号 (YYMM.c.m.b) 中,本地版本的 c 的值为 0。例如,在应用程序和功能中,此版本显示为 1912.0.0.内部版本号

在早期本地版本和 Citrix Cloud 版本中,c 的值为 1

有关详细信息,请参阅 产品和组件版本号

Citrix Studio

支持在 Amazon Web Services 上预配 Linux 计算机

Citrix Studio 现在支持使用 Machine Creation Service (MCS) 在 Amazon Web Services (AWS) 上配置 Linux 计算机。有关详细信息,请参阅 使用 MCS 创建 Linux VM

Virtual Delivery Agent (VDA) 1912

除本文前面列出的 VDA 安装和升级项目外,版本为 1912 的适用于多会话操作系统的 VDA 和适用于单会话操作系统的 VDA 包括以下增强功能:

注意:

虽然 VDA 版本号显示为“Citrix Virtual Apps and Desktops 7 1912 LTSR”,但 LTSR 和 CR 部署支持 VDA。

支持本地安全机构 (LSA) 保护

现在,我们支持在多会话服务器操作系统和单会话桌面操作系统中使用本地安全机构 (LSA) 保护来进行标准身份验证、联合身份验证服务 (FAS) 身份验证和智能卡身份验证。有关 LSA 保护的详细信息,请参阅 Microsoft 文章配置其他 LSA 保护

应用程序保护

此版本引入了一项附加功能,该功能可在使用 Citrix Workspace 应用程序时增强安全性。新策略在会话中提供 anti-keylogging 和 anti-screen-capturing 功能。适用于 Windows 的 Citrix Workspace 应用程序 1912 或更高版本随附的新策略可帮助保护数据免受键盘记录器和屏幕抓取工具的影响。有关详细信息,请参阅 应用程序保护

Citrix Licensing 11.16.3

Citrix Licensing 11.16.3 包含新增功能以及已修复已知问题。

Citrix 联合身份验证服务 1912

Citrix 联合身份验证服务 (FAS) 1912 包含新增功能

详细信息

  • 请务必检查 弃用 中是否存在对公告和删除版本的任何变更。
  • 有关 2018 中引入的产品名称和版本号变更的信息,请参阅新名称和版本号