Citrix DaaS

Requisitos do sistema

Introdução

Os requisitos de sistema de componentes não cobertos aqui (como aplicativo Citrix Workspace e Citrix Provisioning) são descritos em suas respectivas documentações.

Recomendações específicas para dimensionar VMs que fornecem áreas de trabalho e aplicativos não podem ser fornecidas devido à natureza complexa e dinâmica das ofertas de hardware. Cada implantação tem necessidades específicas. Geralmente, o dimensionamento de uma VM é baseado no hardware e não nas cargas de trabalho do usuário (exceto para RAM; você precisa de mais RAM para aplicativos que consomem mais). O Citrix VDI Handbook and Best Practices contém as orientações mais recentes sobre dimensionamento de VDA.

Lembre-se: em uma implantação do Citrix DaaS (anteriormente Citrix Virtual Apps and Desktops), você não precisa instalar ou gerenciar os componentes principais (Delivery Controllers, o banco de dados do site ou consoles de gerenciamento e monitoramento). Para obter orientações de instalação do Virtual Delivery Agent (VDA), consulte:

Conectores de nuvem

Para obter detalhes, consulte Detalhes técnicos do Cloud Connector.

VDAs em um ambiente Azure

Sistemas operacionais compatíveis:

  • Windows 11 multissessão
  • Windows 11 de sessão única
  • Windows 10 multissessão
  • Windows 10 de sessão única
  • Windows 7 de sessão única
  • Windows Server 2022 (requer o mínimo de VDA 2106)
  • Windows Server 2019
  • Windows Server 2016
  • Windows Server 2012 R2

Todos os VDAs que não atingiram o fim da vida útil têm suporte para uso com o Citrix DaaS. Quanto aos VDAs LTSR, recomendamos usá-los com a atualização cumulativa mais recente. Para obter mais informações sobre o ciclo de vida dos VDAs, consulte Citrix Product Matrix.

O Windows 7 é compatível apenas com VDA 7.15 atualização cumulativa 5 (ou atualizações cumulativas posteriores).

O Windows Server 2012 R2 é compatível apenas com VDA 7.15 atualização cumulativa 5 (e atualizações cumulativas posteriores) ou VDA 1912 (e atualizações cumulativas posteriores).

O Windows Server requer licenciamento do Microsoft RDS.

Para obter informações sobre a Área de Trabalho Virtual do Azure, consulte a documentação da Microsoft.

VDA para SO de sessão única

As informações a seguir se aplicam à versão mais recente do VDA.

Sistemas operacionais compatíveis:

  • Windows 11
  • Windows 10
    • Para obter suporte à edição, consulte CTX224843. Esse artigo também contém links para problemas conhecidos da Citrix com as versões compatíveis do Windows.
    • O redirecionamento de composição da área de trabalho e o modo gráfico herdado não são suportados no Windows 10.

Requisitos:

  • O Microsoft .NET Framework 4.8 é instalado automaticamente, se ele (ou uma versão posterior) ainda não estiver instalado.
  • Microsoft Visual C++ 2015-2019 redistribuível.

    • Se a máquina contiver uma versão anterior do Runtime (como 2015-2017), o instalador Citrix a atualizará.
    • Se a máquina contiver uma versão anterior a 2015, a Citrix instalará a versão mais recente em paralelo.

O Remote PC Access usa esse VDA, que você instala em PCs de escritórios físicos. Esse VDA suporta a Inicialização Segura para o acesso ao PC remoto do Citrix Virtual Desktops.

Vários recursos de aceleração de multimídia (como HDX MediaStream Windows Media Redirection) exigem que o Microsoft Media Foundation esteja instalado no computador em que você instala o VDA. Se o computador não tiver o Media Foundation instalado, os recursos de aceleração de multimídia não serão instalados e não funcionarão. Não remova o Media Foundation do computador depois de instalar o software da Citrix. Caso contrário, os usuários não podem fazer logon no computador. Na maioria das edições Windows de SO de área de trabalho suportadas, o suporte ao Media Foundation já está instalado e não pode ser removido. No entanto, as edições N não incluem certas tecnologias relacionadas à mídia. Você pode obter esse software da Microsoft ou de terceiros.

Mais informações:

VDA para SO multissessão

As informações a seguir se aplicam à versão mais recente do VDA.

Sistemas operacionais compatíveis:

  • Windows Server 2022 (requer o mínimo de VDA 2106)
  • Windows Server 2019, edições Standard e Datacenter
  • Windows Server 2016, edições Standard e Datacenter

O instalador implanta automaticamente os seguintes requisitos:

  • O Microsoft .NET Framework 4.8 é instalado automaticamente, se ele (ou uma versão posterior) ainda não estiver instalado.
  • Microsoft Visual C++ 2015-2019 redistribuível.

    • Se a máquina contiver uma versão anterior do Runtime (como 2015-2017), o instalador Citrix a atualizará.
    • Se a máquina contiver uma versão anterior a 2015, a Citrix instalará a versão mais recente em paralelo.

O instalador instala e ativa automaticamente os serviços de função dos Serviços de Área de Trabalho Remota, se ainda não estiverem instalados e ativados. Isso provoca um reinício.

Vários recursos de aceleração de multimídia (como HDX MediaStream Windows Media Redirection) exigem que o Microsoft Media Foundation esteja instalado no computador em que você instala o VDA. Se o computador não tiver o Media Foundation instalado, os recursos de aceleração de multimídia não serão instalados e não funcionarão. Não remova o Media Foundation do computador depois de instalar o software da Citrix. Caso contrário, os usuários não podem fazer logon no computador. Na maioria das versões do Windows Server, o recurso Media Foundation é instalado por meio do Gerenciador do Servidor. No entanto, as edições N não incluem certas tecnologias relacionadas à mídia. Você pode obter esse software da Microsoft ou de terceiros.

Se o Media Foundation não estiver presente no VDA, estes recursos multimídia não funcionam:

  • Redirecionamento Flash
  • Windows Media Redirection
  • Redirecionamento de vídeo HTML5
  • Redirecionamento de Webcam HDX RealTime

Mais informações:

Recursos de virtualização e hosts

Os seguintes recursos de virtualização/host (listados alfabeticamente) são suportados. Quando aplicável, as versões superior.inferior são suportadas, incluindo atualizações a essas versões. CTX131239 contém as informações mas atuais sobre a versão atual de hipervisor, além de links para problemas conhecidos.

Nota:

Você não deve instalar o software VDA em nenhum servidor Citrix DDC ou StoreFront. O VDA deve ser um sistema autônomo. A instalação de vários componentes em uma única VM só é permitida para desenvolver uma prova de conceito ou ao publicar o console de administração do Studio somente para administradores. Nesse caso, você deve garantir que os usuários não administradores não tenham acesso às VMs DDC/StoreFront.

Níveis funcionais do Active Directory

Os seguintes níveis funcionais para a floresta e o domínio do Active Directory são suportados:

  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2

Para obter mais informações sobre o Active Directory, consulte Active Directory.

Tecnologias HDX

Para obter suporte e requisitos específicos de recursos HDX, consulte HDX.

Universal Print Server

O servidor de impressão universal compreende componentes cliente e servidor. O componente UpsClient está incluído na instalação do VDA. Você instala o componente UpsServer em cada servidor de impressão onde residam impressoras compartilhadas que você deseje provisionar com o Citrix Universal Print Driver nas sessões do usuário.

O componente UpsServer é compatível com:

  • Windows Server 2019
  • Windows Server 2016

Requisitos:

  • Microsoft .NET Framework 4.8 (mínimo)
  • Microsoft Visual C++ 2015-2022 redistribuível.

    • Se a máquina contiver uma versão anterior do Runtime (como 2015-2017), o instalador Citrix a atualizará.
    • Se a máquina contiver uma versão anterior a 2015, a Citrix instalará a versão mais recente em paralelo.

Para VDAs de multissessão, a autenticação do usuário durante as operações de impressão exige que o servidor de impressão universal esteja conectado ao mesmo domínio que o VDA.

Os pacotes de componentes cliente e servidor autônomos também estão disponíveis para download.

Para obter mais informações, consulte Provisionar impressoras.

Conectividade de serviço

Consulte Requisitos de sistema e conectividade para obter informações sobre conexão à Internet. Essas informações incluem requisitos comuns à maioria dos serviços do Citrix Cloud, além de requisitos específicos do Citrix DaaS.

Outros

  • O Console de Gerenciamento de Política de Grupo (GPMC) da Microsoft é necessário se você armazenar informações de políticas da Citrix no Active Directory em vez de no banco de dados de configuração do site. A máquina na qual você instalar o CitrixGroupPolicyManagement_x64.msi deverá ter o tempo de execução do Visual Studio 2015 instalado. Para obter mais informações, consulte a documentação da Microsoft.

  • Este produto oferece suporte ao PowerShell versões 3 a 5.

  • Para componentes e recursos de produtos que podem ser instalados em Windows Servers, Server Core e instalações Nano Server não têm suporte, salvo indicação em contrário.

  • Para obter detalhes sobre limites de recursos em uma implantação, consulte Limites.

  • Para ver as versões compatíveis com o StoreFront, consulte os requisitos do sistema StoreFront.

  • Para obter informações sobre globalização, consulte CTX119253.

  • Para obter informações sobre as portas que o Citrix DaaS usa, consulte Communications Ports Used by Citrix Technologies.

  • Para obter informações sobre os requisitos ao usar a interface de gerenciamento Quick Deploy, consulte Requisitos.

Requisitos do sistema