Product Documentation

Compatibilidad de XenMobile

Oct 31, 2016

Important

A partir de la versión 10.4, las aplicaciones móviles Worx pasan a llamarse aplicaciones XenMobile. La mayoría de las aplicaciones XenMobile también cambian de nombre, aunque no todas. Para obtener más información, consulte Acerca de aplicaciones XenMobile.

En este artículo, se ofrece un resumen de las versiones de los componentes de XenMobile respaldados que pueden integrarse, incluido NetScaler Gateway y la versión de MDX Toolkit necesaria para empaquetar, configurar y distribuir aplicaciones móviles Worx o XenMobile.

XenMobile 10.x

Versiones de NetScaler Gateway respaldadas:

  • 11.1.x
  • 11.0.x
  • 10.5.x

Citrix respalda la versión actual de XenMobile y las dos anteriores. Por ejemplo, si la versión actual es XenMobile 10.4, Citrix también respalda XenMobile 10.3.6 (un Service Pack más que una versión completa) y XenMobile 10.3.5.

Los componentes de cliente de XenMobile cumplen los siguientes requisitos de compatibilidad:

  • Las versiones más recientes de Secure Hub y del MDX Toolkit son compatibles con la versión más reciente del servidor XenMobile y con las dos versiones anteriores a esa.
  • La versión más reciente de Secure Hub y la anterior son compatibles con las versiones más recientes de MDX Toolkit y las aplicaciones XenMobile.
  • La versión más reciente de una de las aplicaciones XenMobile se ha probado con la versión más reciente de MDX Toolkit.

Para sacar partido a las ventajas que ofrecen las nuevas características, soluciones y actualizaciones de directivas, Citrix recomienda instalar la versión más reciente de MDX Toolkit, Secure Hub y las aplicaciones XenMobile.

Para aprovechar las ventajas de las nuevas funciones, soluciones y actualizaciones de directivas, Citrix recomienda instalar la versión más reciente del MDX Toolkit, Worx Home y las aplicaciones móviles de Worx.

Versiones del MDX Toolkit para iOS y Android

Versiones de Worx Home/Secure Hub

Android

iOS

10.4

10.3.10

10.3.9

10.3.6

10.3.5

10.3.1

10.2.1

10.0.7

10.0.5

10.0.3

10.4

10.3.10

10.3.9

10.3.8

10.3.6

10.3.5

10.3.1

10.3

10.2.1

10.0.8

10.0.3

10.4

10.3.10

10.3.9

10.3.8

10.3.6

10.3.5

10.3.1


10.2.1

10.0.8

10.0.3

 

MDX Toolkit para Windows Phone

Versiones de Worx Home compatibles*

10.0.7

10.0.3

10.0.5 - 10.0.3

10.0.3

10.0.0

10.0.0

* Las versiones de Worx Home anteriores a 10.0.3 son compatibles, pero no se respaldan.

Nota

Actualmente, Windows Phone 10 solo recibe respaldo en XenMobile 10 y 10.3.x. No recibe respaldo en XenMobile 10.1.  Para XenMobile 9, se debe instalar una revisión para que las aplicaciones funcionen correctamente. Para obtener más información, consulte CTX215497.  

XenMobile 10.x respalda las versiones de aplicaciones XenMobile o aplicaciones móviles Worx que figuran en la siguiente tabla.

Aplicación

Android

iOS

Windows Phone 8.1/101

Secure Hub10.410.4 

Worx Home

10.3.10

10.3.9

10.3.8

10.3.6

10.3.5

10.3.1

10.2.1

10.0.8

10.0.3

10.0.0

10.3.10

10.3.9

10.3.8

10.3.6

10.3.5

10.3

10.2.1

10.0.8

10.0.3

10.0.0

10.0.3

10.0.0

Secure Forms
 

10.4

10.3.10

10.3.9

10.3.8

10.3.6

 
Secure Mail  10.410.4 
WorxMail

10.3.10

10.3.9

10.3.8

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.3

10.0.0

10.3.10

10.3.9

10.3.8

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.3

10.0.0

10.2  

10.0.7

Secure Notes10.410.4 

Worx Notes

10.3.10

10.3.9

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.0

10.3.10

10.3.9

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.0

 

Secure Tasks10.410.4 

WorxTasks

10.3.10

10.3.9

10.3.6

10.3.5

10.3

10.2

10.0.7

10.3.10

10.3.9

10.3.6

10.3.5

10.3

10.2

10.0.7

 

Secure Web10.410.4 

WorxWeb

10.3.10

10.3.9

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.3

10.0.0

10.3.10

10.3.9

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.3

10.0.0

10.2

10.0.3

QuickEdit2

6.5


6.4

 

 

ShareConnect

3.6


3.8

 

ShareFile

4.9

 

4.7.1
 

1 Windows Phone 10 no recibe respaldo en XenMobile 10.1.

2 Solo se respaldan las versiones más recientes de QuickEdit, ShareConnect y ShareFile.

Respaldo para exploradores Web

XenMobile 10.x admite los siguientes exploradores:

  • Internet Explorer, no admite versiones 9 o anteriores
  • Chrome
  • Firefox
  • Safari en dispositivos móviles para usrarlo con el Self Help Portal.

XenMobile 10.x es compatible con la versión más actualizada del explorador Web y con una versión anterior a la actual.

XenMobile 9

XenMobile 9 incluye Device Manager 9.0 y App Controller 9.0.

Versiones de NetScaler Gateway respaldadas:

  • 11.0.64
  • 10.5.x.e
  • 10.5.x MR
  • 10.1.x.e
  • 10.1.x MR

Por lo general, los componentes de cliente de XenMobile respetan los siguientes requisitos de compatibilidad:

  • La versión más reciente de Secure Hub y MDX Toolkit es compatible con las dos últimas versiones de XenMobile Server.
  • La última versión de MDX Toolkit es compatible con la versión más reciente de aplicaciones XenMobile.
  • Las últimas versiones de MDX Toolkit son compatibles con las siguientes versiones de Secure Hub:

Versiones del MDX Toolkit para iOS y Android

Versiones de Worx Home/Secure Hub*

Android

iOS

10.4

10.3.6

10.3.5

10.3.1

10.3

10.2.1

10.0.7

10.0.5

10.0.3

10.4

10.3.6

10.3.5

10.3.1

10.3

10.2.1

10.0.8

10.0.3

10.4

10.3.6

10.3.5

 

10.3

10.2.1

10.0.8

10.0.3

 

MDX Toolkit para
Windows Phone 10
1

Versiones compatibles de Secure Hub
-

10.410.4
  
10.3.510.3.5
  
10.3.110.3
  
10.310.3
  
10.210.2

1En XenMobile 9, Windows 10 requiere la instalación de una revisión, disponible aquí.

MDX Toolkit para Windows Phone 8.1

Versiones compatibles de Secure Hub*

10.3.510.3.5
10.3.110.3
10.310.3

10.2.1

10.2.1

10.0.5 - 10.0.3

10.0.3

10.0.0

10.0.0

* Las versiones de Secure Hub anteriores a 10.0.3 son compatibles, pero no se respaldan.

XenMobile 9 respalda las versiones de aplicaciones móviles Worx o aplicaciones XenMobile que figuran en la siguiente tabla.

Aplicación

Android

iOS

Windows Phone 8.1

Secure Hub10.410.4 

Worx Home

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3.1

10.2.1

10.0.3

10.0.0

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2.1

10.0.8

10.0.3

10.0.0

10.0.3


10.0.0

Secure Mail10.410.4 

WorxMail

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.3

10.0.0

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.3

10.0.0

10.2

10.0.7

 

Secure Notes10.410.4 

WorxNotes*

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.0.0

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.0

 

Secure Tasks10.410.4 

WorxTasks

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.0.7

 

Secure Web10.410.4 

WorxWeb

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.0.3

10.0.0

10.3.10

10.3.9

10.3.8

10.3.7

10.3.6

10.3.5

10.3

10.2

10.0.7

10.0.3

10.0.0

10.2

10.0.3

QuickEdit1

6.0.2
6.3.10
 

ShareConnect

3.2

 

3.6

 

 

ShareFile

4.6.5

4.5

 

 

1 Solo se respaldan las versiones más recientes de QuickEdit, ShareConnect y ShareFile.

* MDX Toolkit 2.3 y 2.2.1 no respalda WorxNotes/Secure Notes.