XenMobile

Systèmes d’exploitation d’appareils pris en charge

Remarque :

Cet article couvre les systèmes d’exploitation des appareils pris en charge pour XenMobile Server 10.13. Pour les systèmes d’exploitation pris en charge par Endpoint Management, consultez la section Systèmes d’exploitation d’appareils pris en charge.

XenMobile prend en charge les appareils exécutant les plates-formes et les systèmes d’exploitation suivants pour la gestion de la mobilité d’entreprise, y compris la gestion d’applications et d’appareils. En raison de restrictions spécifiques à la plate-forme et de fonctionnalités de sécurité, XenMobile ne prend pas en charge toutes les fonctionnalités sur toutes les plates-formes.

Les informations relatives aux plates-formes d’appareil prises en charge dans cet article s’appliquent également à XenMobile Connector pour Exchange ActiveSync et Citrix Gateway Connector pour Exchange ActiveSync.

Pour obtenir les dernières versions des applications de productivité mobiles, ainsi que les appareils pris en charge pour le cryptage MDX, consultez la section Prise en charge des applications de productivité mobiles.

Remarque :

Citrix prend en charge, au minimum, la version actuelle et une version antérieure des principales plates-formes de système d’exploitation. Les fonctionnalités de la nouvelle version de Endpoint Management ne fonctionnent pas sur toutes sur les anciennes versions de plates-formes.

Pour les annonces de fin de prise en charge, reportez-vous à la section Fin de prise en charge.

Liste des systèmes d’exploitation pris en charge

Citrix XenMobile prend en charge les systèmes d’exploitation suivants :

Remarque :

La prise en charge des versions Android 7.x et iOS 12.x de Secure Hub, Secure Mail, Secure Web et de l’application Citrix Workspace a pris fin en avril 2021.

  • Android : 8.x, 9.x, 10.x, 11.x

    Pour Android 10 et versions ultérieures, consultez Considérations relatives à Android.

  • iOS : 13.x, 14.x

    XenMobile et les applications mobiles Citrix sont compatibles avec iOS 14.x, mais ne prennent pas actuellement en charge les nouvelles fonctionnalités iOS 14.x. Le service MDX ne prend actuellement pas en charge l’encapsulation d’applications iOS pour iOS 14.x. Pour encapsuler des applications d’entreprise internes pour iOS 14.x, utilisez MDX Toolkit 20.8.5 ou version ultérieure.

  • iPadOS : 13.x, 14.x

    XenMobile et les applications mobiles Citrix sont compatibles avec iPadOS 14.x, mais ne prennent pas actuellement en charge les nouvelles fonctionnalités iPadOS 14.x.

  • macOS : 10.13x, 10.14x, 10.15x, 11.x

    XenMobile et les applications mobiles Citrix sont compatibles avec macOS 11, mais ne prennent pas actuellement en charge les nouvelles fonctionnalités macOS 11.

  • Ordinateurs et tablettes Windows 10 : Windows 10 RS4 et RS5 (MDM exclusif)

  • Windows Phone : (MDM exclusif). Windows Phone 8.1, Windows Phone 10, Windows 10 RS4 et RS5

  • Windows Mobile/CE : (MDM exclusif). À compter du deuxième trimestre de 2018, la prise en charge des appareils Windows Mobile/CE n’est plus disponible.

  • Samsung SAFE et Knox : sur les appareils Samsung compatibles, XenMobile prend en charge et étend les stratégies Samsung Knox et Samsung for Enterprise (SAFE). XenMobile nécessite l’activation d’API SAFE avant le déploiement de stratégies et de restrictions SAFE. Pour ce faire, déployez la clé Samsung Enterprise License Management (ELM) intégrée sur un appareil. Consultez Stratégie de clé de licence MDM Samsung.

Considérations relatives à Android

Avant de mettre à niveau vers Android 10 ou version ultérieure : consultez Migrer de l’administration des appareils vers Android Enterprise pour plus d’informations sur la façon dont la fin de prise en charge des API d’administration des appareils Google affecte les appareils exécutant Android 10.

  • Citrix vous recommande d’éviter d’inscrire les appareils Android 10 en mode d’administration des appareils d’ancienne génération. Google est en train de mettre fin à la prise en charge des API d’administration des appareils, ce qui a un impact sur les appareils fonctionnant sous Android 10+. Une fois les API obsolètes, l’inscription des appareils Android 10+ en mode d’administration des appareils d’ancienne génération échouera. Citrix ne prend pas en charge l’inscription d’appareils Android 11 en mode d’administration des appareils.
  • Citrix recommande d’utiliser Android Entreprise pour les appareils Android 10. Pour de plus amples informations, consultez la section Migrer de l’administration des appareils vers Android Enterprise.
  • La modification de l’API Google n’affecte pas les appareils inscrits en mode MAM-uniquement.

Avant la mise à niveau :

  • Assurez-vous que votre infrastructure de serveurs est conforme aux certificats de sécurité ayant un nom d’hôte correspondant dans l’extension SAN (autre nom de l’objet).
  • Pour vérifier un nom d’hôte, le serveur doit présenter un certificat avec un SAN correspondant. Citrix approuve les certificats uniquement s’ils contiennent un SAN correspondant au nom d’hôte.
Systèmes d’exploitation d’appareils pris en charge