XenMobile

Sistemas operacionais compatíveis de dispositivos

Nota:

Este artigo aborda os sistemas operacionais de dispositivos compatíveis com o XenMobile Server 10.12. Para sistemas operacionais compatíveis com o Endpoint Management, consulte Sistemas operacionais compatíveis de dispositivos.

O XenMobile é compatível com dispositivos que executam as seguintes plataformas e sistemas operacionais para gerenciamento de mobilidade corporativa, incluindo gerenciamento de aplicativos e dispositivos. Devido a restrições de plataforma e recursos de segurança, o XenMobile não dá suporte a todas as funcionalidades em todas as plataformas.

As informações de plataforma de dispositivo com suporte neste artigo também se aplicam ao conector do XenMobile para Exchange ActiveSync e ao conector Citrix Gateway para Exchange ActiveSync.

Para obter as versões mais recentes dos aplicativos móveis de produtividade, bem como os dispositivos suportados para criptografia MDX, consulte Suporte para aplicativos móveis de produtividade.

Nota:

A Citrix dá suporte pelo menos à versão atual e anterior de cada principal plataforma de sistema operacional. Nem todos os recursos da versão mais recente do Endpoint Management funcionam em versões mais antigas da plataforma.

Para anúncios de substituição, consulte Substituição.

Lista de compatibilidade com o sistema operacional

O Citrix XenMobile suporta os seguintes sistemas operacionais:

  • Android: 7.x, 8.x, 9.x, 10.x, 11.x

    Nota:

    Para Android 10, consulte Considerações sobre Android.

  • iOS: 11.x, 12.x, 13.x, 14

    O XenMobile e os aplicativos móveis Citrix são compatíveis com o iOS 14, mas atualmente não são compatíveis com os novos recursos do iOS 14. Atualmente, o MDX Service não suporta preparar aplicativos iOS para iOS 14. Use o MDX Toolkit 20.8.5 ou posterior.

  • macOS: 10.11 El Capitan, 10.12 Sierra, 10.13 High Sierra
  • Desktops e tablets Windows 10: Windows 10 RS4 e RS5 (somente MDM)
  • Windows Phone: Windows Phone 8.1, Windows Phone 10, Windows 10 RS4 e RS5 (somente MDM)
  • Windows Mobile/CE: (somente MDM). Desde o segundo trimestre de 2018, o suporte para dispositivos Windows Mobile/CE não está mais disponível.
  • Dispositivos Symbian: A partir do segundo trimestre de 2018, o suporte para dispositivos Symbian não está mais disponível para novos clientes. A lista a seguir inclui alguns dos dispositivos Symbian suportados pelo XenMobile para clientes que configuraram esses dispositivos anteriormente.
    • Symbian 3
    • Symbian S60 5th Edition
    • Symbian S60 3rd Edition, Pacote de recursos 2
    • Symbian S60 3rd Edition, Pacote de recursos 1
    • Symbian S60 3rd Edition
    • Symbian S60 2nd Edition, Pacote de recursos 3
    • Symbian S60 2nd Edition, Pacote de recursos 2
  • Samsung SAFE e KNOX: Em dispositivos Samsung compatíveis, o XenMobile dá suporte às políticas do Samsung for Enterprise (SAFE) e do Samsung Knox e as estende. O XenMobile requer que você habilite as APIs SAFE antes de implantar políticas e restrições SAFE. Para fazer isso, implante a chave interna Samsung Enterprise License Management (ELM) em um dispositivo. Para ativar a API Samsung Knox:
    1. Compre uma licença do Samsung Knox usando o Samsung Knox License Management System (KLMS).
    2. Implante a chave Samsung ELM.
  • HTC: Para políticas específicas da HTC, HTC API versão 0.5.0
  • Sony: Para políticas específicas da Sony, Sony Enterprise SDK 2.0

Considerações sobre Android

Antes de atualizar para o Android 10 (também conhecido como Android Q), consulte Migrar do Device Administration para o Android Enterprise para obter informações sobre como a substituição de APIs do Google Device Administration afeta os dispositivos que executam o Android 10.

  • A Citrix recomenda que você evite registrar dispositivos Android 10 no modo de administração de dispositivos legados. O Google está substituindo as APIs do Device Administration, o que afeta os dispositivos que executam o Android 10. Depois que as APIs forem preteridas, o registro de dispositivos Android 10 no modo de administração de dispositivos legados apresentará falha.
  • A Citrix recomenda o uso do Android Enterprise para dispositivos Android 10. Para obter mais informações, consulte Migrar do Device Administration para o Android Enterprise.
  • A alteração da API do Google não afeta os dispositivos registrados no modo somente MAM.

Antes de atualizar para a plataforma Android P:

  • Certifique-se de que sua infraestrutura de servidor está em conformidade com os certificados de segurança que tenham um nome de host correspondente na extensão subjectAltName (SAN).
  • Para confirmar um nome de host, o servidor deve apresentar um certificado com uma SAN correspondente. A Citrix confia em certificados somente se eles contiverem uma SAN que corresponda ao nome de host.
  • Para obter detalhes, consulte o artigo do site do desenvolvedor do Android em Android P behavior changes.

Com o lançamento do Android O (versão 8):

  • O SSLv3 não é suportado com o Android O. O Google não suporta mais conexões SSLv3. Isso significa que aplicativos móveis de produtividade executados em dispositivos Android O não podem se conectar a servidores internos que estão usando conexões SSLv3. Se você tiver servidores que utilizam o SSLv3, é importante resolver essa limitação antes de implantar o Android O para evitar falhas de conectividade com os usuários.
  • O suporte terminou para o Android 4.4x a partir da versão 10.6.20 da versão da loja de aplicativos pública dos aplicativos móveis de produtividade da Citrix.
  • Aplicativos móveis de produtividade da Citrix e aplicativos preparados com MDX estão disponíveis em dispositivos Android com processadores baseados em ARM. Eles não são suportados em dispositivos Android com base em Intel x86 ou x64.

BlackBerry

O gerenciamento de dispositivos BlackBerry é fornecido por meio do conector de Gateway para Exchange ActiveSync. Para obter detalhes, consulte Conector do XenMobile para Exchange ActiveSync.

Sistemas operacionais compatíveis de dispositivos