系统要求

注意:

单击此处了解与产品名变更有关的信息。

简介

本文档中的系统要求适用于此发布版本的产品。将定期进行更新。本文档中未涉及的组件(例如主机系统、Citrix Workspace 应用程序以及 Citrix Provisioning)的系统要求在其各自的文档中进行说明。

重要:

请在开始安装之前阅读准备安装一文。

除非另有说明,否则如果在计算机上未检测到所需版本的软件必备项,则组件安装程序会自动部署这些软件必备项(如 .NET 和 C++ 软件包)。Citrix 安装介质还包含部分必备软件。

安装介质包含多个第三方组件。使用 Citrix 软件之前,请检查是否存在第三方安全更新并进行安装。

有关全球化信息,请参阅 CTX119253

对于可以安装在 Windows Server 上的组件和功能,除非另有说明,否则不支持 Nano 服务器安装。只有 Delivery Controller 和 Director 支持服务器核心。

硬件要求

RAM 和磁盘空间值是对计算机上的产品映像、操作系统和其他软件的附加。性能会有所不同,具体取决于您的配置。这包括您使用的功能,以及用户数和其他因素。仅使用最低配置会导致性能缓慢。

下表列出了核心组件的最低要求。

组件 最低
所有核心组件都位于一台服务器上,仅供评估使用,不用于生产部署 5 GB RAM
所有核心组件位于一个服务器上,供测试部署或小型的生产环境 12 GB RAM
Delivery Controller(本地主机缓存需要更多磁盘空间) 5 GB RAM、800 MB 硬盘、数据库:请参阅大小调整指南
Studio 1 GB RAM,100 MB 硬盘
Director 2 GB RAM,200 MB 硬盘
StoreFront 2 GB RAM,请参阅 StoreFront 文档获取磁盘建议
许可证服务器 2 GB RAM,请参阅许可文档获取磁盘建议

对可提供桌面和应用程序的 VM 进行大小调整

由于硬件产品的复杂性和不确定性,无法提供具体的建议,而且每个部署都有各自的独特需求。通常来说,调整 Citrix Virtual Apps VM 的大小是基于硬件而非用户工作负载进行的(RAM 除外;应用程序消耗的资源越多,需要的 RAM 也越多)。Citrix VDI Handbook and Best Practices(Citrix VDI 手册和最佳做法)包含有关 VDA 大小的最新指导信息。

Delivery Controller

支持的操作系统:

  • Windows Server 2016 Standard Edition 和 Datacenter Edition,包含服务器核心选项
  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition 以及适用于 Windows Server 2012 R2 的服务器核心

要求:

  • 如果尚未安装 .NET Framework 4.7.1(或更高版本),该框架将自动安装。
  • Microsoft Internet Information Services(自动安装;当前由 Citrix Orchestration Service 在部署中安装的一项功能使用)。
  • Windows PowerShell 3.0 或更高版本。
  • Microsoft Visual C++ 2015 Runtime(32 位和 64 位)。

数据库

站点配置数据库、配置日志记录数据库和监视数据库支持的 Microsoft SQL Server 版本如下:

  • SQL Server 2017 Express Edition、Standard Edition 和 Enterprise Edition。
  • SQL Server 2016 SP1 和 SP2,Express Edition、Standard Edition 和 Enterprise Edition。
  • SQL Server 2014 SP1 和 SP2,Express Edition、Standard Edition 和 Enterprise Edition。默认情况下,如果未检测到支持的现有 SQL Server 安装,安装 Controller 时将安装 SQL Server 2014 SP2 Express。
  • SQL Server 2012 到 SP4 Express Edition、Standard Edition 和 Enterprise Edition。
  • SQL Server 2008 R2 SP2 和 SP3 Express Edition、Standard Edition、Enterprise Edition 以及 Datacenter Edition。

支持下列数据库高可用性解决方案(SQL Server Express 除外,此版本仅支持独立模式):

  • SQL Server AlwaysOn 故障转移群集实例
  • SQL Server AlwaysOn 可用性组(包括 Basic 可用性组)
  • SQL Server 数据库镜像

Controller 与 SQL Server 站点数据库之间的连接需要 Windows 身份验证。

安装 Controller 时,默认安装 SQL Server Express 数据库以与本地主机缓存功能一起使用。此安装与针对站点数据库的默认 SQL Server Express 安装不同。

有关详细信息,请参阅以下文章:

Citrix Studio

支持的操作系统:

  • Windows 10
  • Windows Server 2016 Standard Edition 和 Datacenter Edition
  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition

要求:

  • 如果尚未安装 .NET Framework 4.7.1(或更高版本),该框架将自动安装。
  • Microsoft Management Console 3.0(随所有支持的操作系统提供)。
  • Windows PowerShell 3.0 或更高版本。

Citrix Director

支持的操作系统:

  • Windows Server 2016 Standard Edition 和 Datacenter Edition,包含服务器核心选项
  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition 以及适用于 Windows Server 2012 R2 的服务器核心

要求:

  • 如果尚未安装 .NET Framework 4.7.1(或更高版本),该框架将自动安装。
  • Microsoft Internet Information Services (IIS) 7.0 和 ASP.NET 2.0。确保 IIS 服务器角色安装了静态内容角色服务。如果尚未安装这些项,系统会提示您插入 Windows Server 安装介质并进行安装。

System Center Operations Manager (SCOM) 集成要求:

  • Windows Server 2012 R2
  • System Center 2012 R2 Operations Manager

支持查看 Director 的浏览器:

  • Internet Explorer 11。(您可以在 Windows Server 2012 R2 计算机上仅使用 Internet Explorer 10。)Internet Explorer 不支持兼容模式。请使用建议的浏览器设置访问 Director。安装 Internet Explorer 时,接受默认设置以使用建议的安全性和兼容性设置。如果已安装该浏览器,但选择不使用建议的设置,请转到工具 > Internet 选项 > 高级 > 重置并按照说明进行操作。
  • Microsoft Edge。
  • Firefox ESR(扩展支持版本)。
  • Chrome。

推荐的用于查看 Director 的最佳屏幕分辨率为 1366 x 1024。

Virtual Delivery Agent (VDA) for Desktop OS

支持的操作系统:

  • Windows 10,最低版本1607。
    • 有关版本支持,请参阅 CTX224843
    • 有关版本 1709 的 Citrix 已知问题,请参阅 CTX229052

要求:

  • 如果尚未安装 .NET Framework 4.7.1(或更高版本),该框架将自动安装。
  • Microsoft Visual C++ 2013 和 2015 Runtimes(32 位和 64 位)。

Remote PC Access 使用此 VDA(您可将其安装在办公室物理 PC 上)。此 VDA 在 Windows 10 上支持面向 Citrix Virtual Desktops Remote PC Access 的安全启动。

多种多媒体加速功能(如 HDX MediaStream Windows Media 重定向)要求在安装 VDA 的计算机上安装 Microsoft 媒体基础。如果该计算机未安装媒体基础,将无法安装和使用多媒体加速功能。请勿在安装 Citrix 软件后从计算机上删除媒体基础;否则,用户将无法登录到此计算机。在大多数受支持的 Windows 桌面操作系统版本上,已经安装了媒体基础支持,不能将其删除。但是,N 版本不包括某些与媒体相关的技术;您可以从 Microsoft 或第三方获取该软件。有关详细信息,请参阅准备安装

有关 Linux VDA 的信息,请参阅 Linux Virtual Delivery Agent 各文章。

要使用 Server VDI 功能,可以在 Windows Server 2016 上使用命令行接口安装 VDA for Windows Desktop OS。有关指导,请参阅服务器 VDI

有关在 Windows 7 计算机上安装 VDA 的信息,请参阅早期版本的操作系统

Virtual Delivery Agent (VDA) for Server OS

支持的操作系统:

  • Windows Server 2016 Standard Edition 和 Datacenter Edition
  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition

安装程序将自动部署以下必需的组件,这些组件也可以在 Citrix 安装介质上的 Support 文件夹中找到:

  • 如果尚未安装 .NET Framework 4.7.1(或更高版本),该框架将自动安装。
  • Microsoft Visual C++ 2013 和 2015 Runtimes(32 位和 64 位)。

如果尚未安装并启用远程桌面服务角色服务,安装程序会自动安装并启用。

多种多媒体加速功能(如 HDX MediaStream Windows Media 重定向)要求在安装 VDA 的计算机上安装 Microsoft 媒体基础。如果该计算机未安装媒体基础,将无法安装和使用多媒体加速功能。请勿在安装 Citrix 软件后从计算机上删除媒体基础;否则,用户将无法登录到此计算机。在大多数 Windows Server 版本上,通过服务器管理器安装媒体基础功能。但是,N 版本不包括某些与媒体相关的技术;您可以从 Microsoft 或第三方获取该软件。有关详细信息,请参阅准备安装

如果 VDA 上不存在媒体基础,这些多媒体功能将不起作用:

  • Flash 重定向
  • Windows Media 重定向
  • HTML5 视频重定向
  • HDX Realtime 网络摄像机重定向

有关 Linux VDA 的信息,请参阅 Linux Virtual Delivery Agent 各文章。

有关在 Windows Server 2008 R2 计算机上安装 VDA 的信息,请参阅早期版本的操作系统

主机/虚拟化资源

某些功能可能并非在所有主机平台或所有平台版本上都受支持。有关详细信息,请参阅相关功能的文档。

Remote PC Access 局域网唤醒功能至少需要 Microsoft System Center Configuration Manager 2012 版。

重要:

支持以下 major.minor 版本,包括这些版本的更新。CTX131239 包含最新虚拟机管理程序版本信息,以及已知问题的链接。

XenServer

  • XenServer 7.6
  • XenServer 7.5
  • XenServer 7.4
  • 应用了 CU1 的 XenServer 7.1
  • XenServer 7.0

Microsoft Azure Resource Manager

VMware vSphere (vCenter + ESXi)

  • VMware vSphere 6.7
  • VMware vSphere 6.5
  • VMware vSphere 6.0
  • VMware vSphere 5.5
  • VMware vSphere 5.1
  • VMware vSphere 5.0
  • VMware vCenter 5.5、6 和 6.5 设备

不支持 vSphere vCenter“链接模式”操作。

System Center Virtual Machine Manager

包括可以注册到受支持的 System Center Virtual Machine Manager 版本中的任何 Hyper-V 版本。

  • System Center Virtual Machine Manager 2016
  • System Center Virtual Machine Manager 2012 R2
  • System Center Virtual Machine Manager 2012 SP1
  • System Center Virtual Machine Manager 2012

Nutanix Acropolis

  • 使用 PVS 时:4.5(或受支持的更高版本)
  • 使用 MCS 时:4.6.1(或受支持的更高版本)

Amazon Web Services (AWS)

  • 可以在支持的 Windows 服务器操作系统上预配应用程序和桌面。
  • 不支持 Amazon Relational Database Service (RDS)。
  • 请参阅 Citrix XenDesktop on AWS 了解更多信息。

CloudPlatform

此主机类型已弃用

Microsoft Azure(经典版)

此主机类型已弃用

Active Directory 功能级别

支持以下 Active Directory 林和域功能级别:

  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2
  • Windows Server 2008
  • Windows Server 2003
  • Windows 2000 本机(不支持域控制器)

HDX

适用于 Windows 的 Citrix Workspace 应用程序和适用于 Linux 13 的 Citrix Workspace 应用程序支持多流 ICA 的 UDP 音频。

适用于 Windows 的 Citrix Workspace 应用程序支持回声消除。

请参阅下文具体的 HDX 功能支持和要求。有关 HDX 功能和 Citrix Workspace 应用程序的详细信息,请参阅功能列表

HDX Windows Media 交付

以下客户端支持 Windows Media 客户端内容提取、Windows Media 重定向和实时 Windows Media 多媒体转码功能:适用于 Windows 的 Citrix Workspace 应用程序、适用于 iOS 的 Citrix Workspace 应用程序以及适用于 Linux 的 Citrix Workspace 应用程序。

要在 Windows 8 设备上使用 Windows Media 客户端内容提取,请将 Citrix Multimedia Redirector 设置为默认程序:在控制面板 > 程序 > 默认程序 > 设置默认程序中,选择 Citrix Multimedia Redirector,然后单击将此程序设置为默认程序选择此程序的默认值。执行 GPU 代码转换需使用具有 Compute Capability 1.1 或更高版本且支持 NVIDIA CUDA 的 GPU;请参阅 https://developer.nvidia.com/cuda/cuda-gpus

HDX Flash 重定向

支持以下客户端和 Adobe Flash Player:

  • 适用于 Windows 的 Citrix Workspace 应用程序(对于第二代 Flash 重定向功能)- 第二代 Flash 重定向功能需要安装适用于其他浏览器的 Adobe Flash Player(有时称为 NPAPI Flash Player,即 Netscape 插件应用程序编程接口 Flash Player)。
  • 适用于 Linux 的 Citrix Workspace 应用程序(支持第二代 Flash 重定向功能)- 第二代 Flash 重定向功能需要安装适用于其他 Linux 的 Adobe Flash Player 或 Adobe Flash Player for Ubuntu。
  • Citrix 联机插件 12.1(支持旧的 Flash 重定向功能)- 旧的 Flash 重定向功能要求安装 Adobe Flash Player for Windows Internet Explorer(有时称为 ActiveX 播放器)。

用户设备上的 Flash Player 主版本号必须大于或等于服务器上的 Flash Player 主版本号。如果用户设备上安装了早期版本的 Flash Player,或者用户设备上无法安装 Flash Player,则 Flash 内容将在服务器上呈现。

运行 VDA 的计算机需要:

  • Adobe Flash Player for Windows Internet Explorer(ActiveX 播放器)
  • Internet Explorer 11(非现代 UI 模式)。可以使用 Internet Explorer 7-10,但 Microsoft 支持版本 11,而 Citrix 也建议使用版本 11。Flash 重定向要求在服务器上安装 Internet Explorer;对于其他浏览器,Flash 内容将在服务器上呈现。
  • 在 Internet Explorer 中禁用保护模式(不要选中“工具”>“Internet 选项”>“安全”选项卡>“启用保护模式”复选框)。重新启动 Internet Explorer 以使更改生效。

HDX 3D Pro

VDA for Windows Desktop OS 将在运行时检测是否存在 GPU 硬件。

托管应用程序的物理机或虚拟机可以使用 GPU 直通或虚拟 GPU (vGPU) 功能:

  • GPU 直通适用于:Citrix XenServer、Nutanix AHV、VMware vSphere 和 VMware ESX,此时称为虚拟直接图形加速 (vDGA);以及 Windows Server 2016 中的 Microsoft Hyper-V,此时称为离散设备分配 (DDA)。
  • vGPU 功能随 Citrix XenServer、Nutanix AHV 和 VMware vSphere 提供;请参阅 https://www.citrix.com/products/xenapp-xendesktop/hdx-3d-pro.html。HDX 3D Pro 还支持 Microsoft Azure NV 系列和 Amazon AWS EC2 G3 产品/服务中的云服务。

Citrix 建议的主机计算机规格如下:至少 4 GB RAM,4 个时钟速度至少为 2.3 GHz 的虚拟 CPU。

图形处理器 (GPU):

  • 对于基于 CPU 的压缩(包括无损压缩),HDX 3D Pro 支持主机计算机上与要交付的应用程序兼容的任何显示适配器。
  • 为了通过使用 NVIDIA GRID API 实现虚拟化图形加速,可将 HDX 3D Pro 与受支持的 NVIDIA GRID 卡一起使用(请参阅 NVIDIA GRID)。NVIDIA GRID 将提供高帧速率,从而实现高度互动的用户体验。
  • 数据中心图形平台的 Intel Xeon Processor E3 系列支持虚拟化图形加速。有关详细信息,请参阅 https://www.citrix.com/intelhttps://www.intel.com/content/www/us/en/servers/data-center-graphics.html
  • AMD FirePro S 系列服务器卡上的 AMD RapidFire 支持虚拟化图形加速。请参阅 AMD 虚拟化解决方案)。

用户设备:

  • HDX 3D Pro 支持主机计算机上的 GPU 支持的所有显示器分辨率。但是,要在建议的最低用户设备和 GPU 规格条件下实现最佳性能,Citrix 提出了以下建议:对于 LAN 连接,建议为用户设备将显示器最大分辨率设置为 1920 x 1200 像素,对于 WAN 连接,建议将其设置为 1280 x 1024 像素。
  • Citrix 建议的用户设备规格如下:至少 1 GB RAM,1 个时钟速度至少为 1.6 GHz 的 CPU。要使用适用于低带宽连接的默认的深度压缩编解码器,需要功能更强大的 CPU,除非解码在硬件上完成。要获得最佳性能,Citrix 建议用户设备至少配有一个 2 GB 的 RAM 以及一个时钟速度至少为 3 GHz 的双核 CPU。
  • 对于多显示器访问,Citrix 建议在用户设备中配备四核 CPU。
  • 用户设备无需配备 GPU 即可访问通过 HDX 3D Pro 交付的桌面或应用程序。
  • 必须安装 Citrix Workspace 应用程序。

有关详细信息,请参阅 HDX 3D Pro 各文章www.citrix.com/xenapp/3d

HDX 视频会议对网络摄像机视频压缩的要求

支持的客户端:适用于 Windows 的 Citrix Workspace 应用程序、适用于 Mac 的 Citrix Workspace 应用程序、适用于 Chrome 的 Citrix Workspace 应用程序以及适用于 Linux 的 Citrix Workspace 应用程序。

支持的视频会议应用程序:

  • Adobe Connect
  • Cisco Webex 和 Webex for Teams
  • GoToMeeting
  • Google Hangouts 和 Hangouts Meet
  • IBM Sametime
  • Windows 8.x 或更高版本以及 Windows Server 2012 R2 及更高版本上基于 Media Foundation 的视频应用程序
  • Microsoft Lync 2010 和 2013
  • Microsoft Skype for Business 2015
  • Microsoft Skype 7 或更高版本

要在 Windows 客户端上使用 Skype,请在客户端和服务器上编辑注册表:

  • 客户端注册表项 HKEY_CURRENT_USER\Software\Citrix\HdxRealTime

    • 名称:DefaultHeight,类型:REG_DWORD,数据:240

    • 名称:DefaultWidth,类型:REG_DWORD,数据:320

  • 服务器注册表项 HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Vd3d\Compatibility

    • 名称:skype.exe,类型:REG_DWORD,数据:设置为 0

其他用户设备要求:

  • 产生声音的相应硬件。
  • 与 DirectShow 兼容的网络摄像机(使用网络摄像机默认设置)。支持硬件编码的网络摄像机可降低客户端的 CPU 使用率。
  • 如有可能,应安装网络摄像机制造商提供的网络摄像机驱动程序。

通用打印服务器

通用打印服务器由客户端和服务器组件组成。UpsClient 组件包含在 VDA 安装中。UpsServer 组件安装在每台打印服务器上,在用户会话中通过 Citrix 通用打印驱动程序预配的共享打印机驻留在这些打印服务器上。

以下操作系统支持 UpsServer 组件:

  • Windows Server 2016
  • Windows Server 2012 R2

要求:Microsoft Visual C++ 2013 Runtime(32 位和 64 位)

对于 VDA for Windows Server OS,打印操作期间的用户身份验证要求通用打印服务器加入与 VDA 相同的域。

也可以下载独立的客户端和服务器组件软件包。

有关详细信息,请参阅预配打印机

其他

StoreFront 3.0.1 是此版本所支持的最低版本。必须至少使用 StoreFront 3.7 和 NetScaler Gateway 11.0-65.x(现在称为 Citrix Gateway),才能使用区域首选项功能。

在版本中使用 Citrix Provisioning(以前称为 Provisioning Services)时,支持的最低 Provisioning Services 版本为 7.0。

仅支持 Citrix License Server 11.15。

如果您将 Citrix 策略信息存储在 Active Directory 而非站点配置数据库中,则需要 Microsoft 组策略管理控制台 (GPMC)。如果单独安装 CitrixGroupPolicyManagement_x64.msi(例如,在未安装 Citrix Virtual Apps and Desktops 核心组件的计算机上),相应的计算机上必须安装 Visual Studio 2015 Runtime。有关详细信息,请参阅 Microsoft 文档。

支持多个网络接口卡。

默认情况下,安装 VDA 时将安装适用于 Windows 的 Citrix Workspace 应用程序。有关详细信息,请参阅适用于 Windows 的 Citrix Workspace 应用程序文档。

有关受支持的 Microsoft App-V 版本,请参阅 App-V

有关该功能支持的浏览器信息,请参阅本地应用程序访问

客户端文件夹重定向 - 支持的操作系统:

  • 服务器:Windows Server 2012 R2 和 Windows Server 2016
  • 客户端(安装了最新的适用于 Windows 的 Citrix Workspace 应用程序):Windows 7、Windows 8 和 Windows 8.1

在多个显示器中使用混合 DPI。在 Citrix Virtual Apps and Desktops 环境中,不支持在多个显示器中使用不同的 DPI。您可以使用 Windows 的“控制面板”>“显示”选项来验证 DPI(% 缩放)。如果使用的是 Windows 8.1 或 Windows 10 客户端设备,则通过在 Windows 的“控制面板”>“显示”选项中启用让我选择一个适合我的所有显示器的缩放级别将相应地配置显示器。有关详细信息,请参阅 CTX201696

本版本的 Citrix Virtual Apps and Desktops 与 AppDNA 7.8 和 AppDNA 7.9 不兼容。Citrix 建议使用当前的 AppDNA 版本。