Citrix Virtual Apps and Desktops 服务

系统要求

简介

本文档中未涉及的组件(例如 Citrix Workspace 应用程序以及 Citrix Provisioning)的系统要求在其各自的文档中进行说明。

对于可以安装在 Windows Server 上的产品组件和功能,除非特别注明,否则不支持 Server Core 和 Nano Server 安装。

有关全球化信息,请参阅 CTX119253

由于硬件产品的复杂性和不确定性,无法提供具体的用于交付桌面和应用程序的 VM 的大小建议。每个部署都有独特的需求。一般而言,调整 VM 的大小基于的是硬件而非用户工作负载(RAM 除外;应用程序消耗的资源越多,需要的 RAM 也越多)Citrix VDI 手册和最佳做法中包含有关 VDA 大小调整的最新指南。

谨记: 在 Citrix Virtual Apps and Desktops 服务部署中,您无需安装或管理核心组件(Delivery Controller、站点数据库、Studio 和 Director)。有关 VDA 安装指南,请参阅:

Cloud Connector

有关详细信息,请参阅Cloud Connector 安装

Windows 虚拟桌面 (WVD) 环境中的 Virtual Delivery Agent (VDA)

支持的操作系统:

  • Windows 10 多会话
  • Windows 10 单会话
  • Windows 7 单会话
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019

支持的 VDA 版本:

  • 在受支持的 Windows 10 和 Windows Server 上:VDA 1909 或更新版本支持的版本
  • 在 Windows 7 上:VDA 7.15.5000(带累积更新 5 的版本 7.15)或更新版本支持的 7.15 CU

Citrix 支持 Windows 2008 R2,即使用 VDA 7.15.5000(版本 7.15,具有累积更新 5)或更新版本支持的 7.15 CU。如果需要,使用此操作系统需要相应的 Microsoft Windows 服务器和 RDS 许可。

有关 Windows 虚拟桌面服务的信息,请参阅 Microsoft Azure 文章 Windows 虚拟桌面和 Microsoft Azure 文档

适用于单会话操作系统的 VDA

以下信息适用于最新的 VDA 版本。

支持的操作系统:

  • Windows 10
    • 有关版本支持,请参阅 CTX224843。该文章还包含指向与受支持的 Windows 版本有关的 Citrix 已知问题的链接。
    • Windows 10 不支持桌面组合重定向和旧图形模式。

要求:

  • 如果尚未安装 .NET Framework 4.8(或更高版本),该框架将自动安装。
  • Microsoft Visual C++ 2017 Runtime(32 位和 64 位)。

Remote PC Access 使用此 VDA(您可将其安装在办公室物理 PC 上)。此 VDA 在 Windows 10 上支持面向 Citrix Virtual Desktops Remote PC Access 的安全启动。

多种多媒体加速功能(如 HDX MediaStream Windows Media 重定向)要求在安装 VDA 的计算机上安装 Microsoft 媒体基础。如果该计算机未安装媒体基础,将无法安装和使用多媒体加速功能。请勿在安装 Citrix 软件后从计算机上删除媒体基础;否则,用户将无法登录到此计算机。在大多数受支持的 Windows 桌面操作系统版本上,已经安装了媒体基础支持,不能将其删除。但是,N 版本不包括某些与媒体相关的技术;您可以从 Microsoft 或第三方获取该软件。

有关 Linux VDA 的信息,请参阅 Linux Virtual Delivery Agent 各文章。

要使用服务器 VDI 功能,可以在 Windows Server 2016 上使用命令行界面安装单会话 VDA。有关指导,请参阅服务器 VDI

有关在 Windows 7 计算机上安装 VDA 的信息,请参阅早期版本的操作系统

另请参阅Windows 虚拟桌面环境中的 Virtual Delivery Agent (VDA)

适用于多会话操作系统的 VDA

以下信息适用于最新的 VDA 版本。

支持的操作系统:

  • Windows Server 2019 Standard Edition 和 Datacenter Edition
  • Windows Server 2016 Standard Edition 和 Datacenter Edition

安装程序将自动部署以下要求:

  • 如果尚未安装 .NET Framework 4.8(或更高版本),该框架将自动安装。
  • Microsoft Visual C++ 2017 Runtime(32 位和 64 位)。

如果尚未安装并启用远程桌面服务角色服务,安装程序会自动安装并启用。这将触发重新启动操作。

多种多媒体加速功能(如 HDX MediaStream Windows Media 重定向)要求在安装 VDA 的计算机上安装 Microsoft 媒体基础。如果该计算机未安装媒体基础,将无法安装和使用多媒体加速功能。请勿在安装 Citrix 软件后从计算机上删除媒体基础;否则,用户将无法登录到此计算机。在大多数 Windows Server 版本上,通过服务器管理器安装媒体基础功能。但是,N 版本不包括某些与媒体相关的技术;您可以从 Microsoft 或第三方获取该软件。

如果 VDA 上不存在媒体基础,这些多媒体功能将不起作用:

  • Flash 重定向
  • Windows Media 重定向
  • HTML5 视频重定向
  • HDX RealTime 网络摄像机重定向

有关 Linux VDA 的信息,请参阅 Linux Virtual Delivery Agent 各文章。

有关在 Windows Server 2008 R2 计算机上安装 VDA 的信息,请参阅早期版本的操作系统

另请参阅Windows 虚拟桌面环境中的 Virtual Delivery Agent (VDA)

主机/虚拟化资源

支持以下主机/虚拟化资源(按字母顺序列出)。如果适用,则支持以下 major.minor 版本,包括这些版本的更新。CTX131239 包含最新的当前版本信息,以及指向已知问题的链接。

Active Directory 功能级别

支持以下 Active Directory 林和域功能级别:

  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2

有关 Active Directory 的详细信息,请参阅 Active Directory

HDX 技术

有关特定 HDX 功能支持和要求,请参阅HDX

通用打印服务器

通用打印服务器由客户端和服务器组件组成。UpsClient 组件包含在 VDA 安装中。UpsServer 组件安装在每台打印服务器上,在用户会话中通过 Citrix 通用打印驱动程序预配的共享打印机驻留在这些打印服务器上。

以下操作系统支持 UpsServer 组件:

  • Windows Server 2019
  • Windows Server 2016

要求:

  • Microsoft Visual C++ 2017 Runtime(32 位和 64 位)
  • Microsoft .NET Framework 4.8(最低版本)

对于多会话 VDA,打印操作期间的用户身份验证要求通用打印服务器加入与 VDA 相同的域。

也可以下载独立的客户端和服务器组件软件包。

有关详细信息,请参阅 预配打印机

服务连接性

有关 Internet 连接信息,请参阅服务连接性要求。该信息包括大多数 Citrix Cloud 服务常见的要求以及 Citrix Virtual Apps and Desktops 特定的要求

其他

有关支持的 StoreFront 版本, 请参阅StoreFront 系统要求

在版本中使用 Citrix Provisioning(以前称为 Provisioning Services)时,支持的最低 Provisioning Services 版本为 7.0。

如果您将 Citrix 策略信息存储在 Active Directory 而非站点配置数据库中,则需要 Microsoft 组策略管理控制台 (GPMC)。安装了 CitrixGroupPolicyManagement_x64.msi 的计算机必须安装 Visual Studio 2015 运行时。有关详细信息,请参阅 Microsoft 文档。

有关部署中的资源限制的详细信息,请参阅限制